summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 18:37:59 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 18:37:59 +0000
commit9007b4db03dbcd5c51565ee772fdeb50ee357265 (patch)
treed0f506f32e3a91d83ea1b102f8c4ee70631f3542
parentAdd Prefix keywords, bug #396547 (diff)
downloadgentoo-2-9007b4db03dbcd5c51565ee772fdeb50ee357265.tar.gz
gentoo-2-9007b4db03dbcd5c51565ee772fdeb50ee357265.tar.bz2
gentoo-2-9007b4db03dbcd5c51565ee772fdeb50ee357265.zip
Simplify py-compile fix.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r1.ebuild4
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r2.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 4e6d2430d45c..8809868189c9 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.267 2011/12/31 16:25:55 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.268 2011/12/31 18:37:59 tetromino Exp $
+
+ 31 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ pygtk-2.24.0-r1.ebuild, pygtk-2.24.0-r2.ebuild:
+ Simplify py-compile fix.
31 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
pygtk-2.24.0-r1.ebuild, pygtk-2.24.0-r2.ebuild:
diff --git a/dev-python/pygtk/pygtk-2.24.0-r1.ebuild b/dev-python/pygtk/pygtk-2.24.0-r1.ebuild
index 8a0e0f1221e6..9a26ed798e0e 100644
--- a/dev-python/pygtk/pygtk-2.24.0-r1.ebuild
+++ b/dev-python/pygtk/pygtk-2.24.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r1.ebuild,v 1.8 2011/12/31 16:25:55 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r1.ebuild,v 1.9 2011/12/31 18:37:59 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -41,7 +41,7 @@ src_prepare() {
# Disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
- echo -e '#!'$(type -P sh)'\n:' > py-compile
+ echo '#!/bin/sh' > py-compile
AT_M4DIR="m4" eautoreconf
diff --git a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild b/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
index 39da8a971acd..bd6d8093ce7b 100644
--- a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
+++ b/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r2.ebuild,v 1.5 2011/12/31 16:25:55 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r2.ebuild,v 1.6 2011/12/31 18:37:59 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -47,7 +47,7 @@ src_prepare() {
# Disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
- echo -e '#!'$(type -P sh)'\n:' > py-compile
+ echo '#!/bin/sh' > py-compile
AT_M4DIR="m4" eautoreconf