summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 05:18:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 05:18:16 +0000
commit8fc54af80805d60c7df9bf03fa467cd14e0e3c5c (patch)
tree6cf82f2e58cbbcd035d59e6d7fb068e8b2f6fac1
parentchange from x11-base/xfree -> virtual/x11 (diff)
downloadgentoo-2-8fc54af80805d60c7df9bf03fa467cd14e0e3c5c.tar.gz
gentoo-2-8fc54af80805d60c7df9bf03fa467cd14e0e3c5c.tar.bz2
gentoo-2-8fc54af80805d60c7df9bf03fa467cd14e0e3c5c.zip
add back in hppa -fPIC fix
-rw-r--r--media-libs/flac/flac-1.1.0-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-libs/flac/flac-1.1.0-r1.ebuild b/media-libs/flac/flac-1.1.0-r1.ebuild
index 078c36d540f7..a1ff3de726f7 100644
--- a/media-libs/flac/flac-1.1.0-r1.ebuild
+++ b/media-libs/flac/flac-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r1.ebuild,v 1.3 2004/04/15 18:59:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r1.ebuild,v 1.4 2004/04/16 05:18:16 vapier Exp $
inherit libtool
@@ -36,6 +36,14 @@ src_unpack() {
}
src_compile() {
+ # hppa need -fPIC for to compile when X and xmss are in USE
+ # the --with-pic is not enough to fix this ... Makefiles probably
+ # need to get patched :p
+ if use xmms && use X && [ "${ARCH}" = "hppa" ]
+ then
+ export CFLAGS="${CFLAGS} -fPIC"
+ fi
+
econf \
--with-pic \
`use_enable sse` \