summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-05 18:28:31 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-05 18:28:31 +0000
commit8f6626144208e24cc0c46008e3dc0db0c44c93c8 (patch)
tree0f0c2b25f0b329884e646545727d0974a8d545df
parentMinor Fixes, cosmetic changes and changing KEYWORDS (diff)
downloadgentoo-2-8f6626144208e24cc0c46008e3dc0db0c44c93c8.tar.gz
gentoo-2-8f6626144208e24cc0c46008e3dc0db0c44c93c8.tar.bz2
gentoo-2-8f6626144208e24cc0c46008e3dc0db0c44c93c8.zip
Added debian patch to zsh-4.0.6 to avoid a segfault on 'echo $terminfo[home]'.
-rw-r--r--app-shells/zsh/ChangeLog11
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.6-r22
-rw-r--r--app-shells/zsh/zsh-4.0.6-r2.ebuild54
3 files changed, 65 insertions, 2 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 5901217ec627..64d1a85dbf8e 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/zsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.10 2002/08/29 15:44:13 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.11 2002/11/05 18:28:31 phoenix Exp $
+
+*zsh-4.0.6-r2 (05 Oct 2002)
+
+ 05 Oct 2002; phoen][x <phoenixk@gentoo.org> zsh-4.0.6-r2.ebuild
+ files/digest-zsh-4.0.6-r2 :
+
+ Incorporated the debian patch to work around a segfault.
+ See bug #9743 for further details.
*zsh-4.0.6-r1 (29 Aug 2002)
@@ -9,7 +17,6 @@
Fixed a sandbox violation. Check bug 6780 for further details.
-
*zsh-4.0.6 (19 Aug 2002)
24 Aug 2002; Sascha Schwabbauer <cybersystem@gentoo.org> zsh-4.0.6.ebuild :
diff --git a/app-shells/zsh/files/digest-zsh-4.0.6-r2 b/app-shells/zsh/files/digest-zsh-4.0.6-r2
new file mode 100644
index 000000000000..9364361da9b5
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.6-r2
@@ -0,0 +1,2 @@
+MD5 6a86da9120e97ebe03afd6a51f717c0f zsh-4.0.6.tar.gz 2146169
+MD5 c8faa44cae89a15cd3616c0dc803fb40 zsh_4.0.6-15.diff.gz 36360
diff --git a/app-shells/zsh/zsh-4.0.6-r2.ebuild b/app-shells/zsh/zsh-4.0.6-r2.ebuild
new file mode 100644
index 000000000000..7e4f8ad5b7fe
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.6-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r2.ebuild,v 1.1 2002/11/05 18:28:31 phoenix Exp $
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+MYPATCH="zsh_4.0.6-15.diff"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.gz
+ http://ftp.debian.org/debian/pool/main/z/${PN}/${MYPATCH}.gz"
+HOMEPAGE="www.zsh.org/"
+SLOT="0"
+LICENSE="ZSH"
+
+DEPEND=">=sys-libs/ncurses-5.1"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 < ${MYPATCH}
+}
+
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-maildir-support \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zshlogin=/etc/zsh/zshlogin \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs || die "configure failed"
+ # emake still b0rks
+ make || die "make failed"
+ #make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ dodoc ChangeLog META-FAQ README INSTALL LICENCE config.modules
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+ dodir /etc/zsh
+ cp ${S}/StartupFiles/z* ${D}/etc/zsh
+}