summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-18 00:33:34 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-18 00:33:34 +0000
commit8f438e900610e6ce3f3f47babaee3305f6a6b1a6 (patch)
tree71ba978b162f16444d89d8c080331b3c17992e90
parentrun lib install commands with set -e (diff)
downloadgentoo-2-8f438e900610e6ce3f3f47babaee3305f6a6b1a6.tar.gz
gentoo-2-8f438e900610e6ce3f3f47babaee3305f6a6b1a6.tar.bz2
gentoo-2-8f438e900610e6ce3f3f47babaee3305f6a6b1a6.zip
Clean up dependency generation to avoid parallel build issues #333155 by Samuli Suominen.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--sys-fs/xfsprogs/ChangeLog12
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-3.1.2-depend.patch239
-rw-r--r--sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild3
3 files changed, 249 insertions, 5 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index e568baf682ee..384b5a952333 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.125 2010/08/17 13:14:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.126 2010/08/18 00:33:33 vapier Exp $
- 17 Aug 2010; Mike Frysinger <vapier@gentoo.org> -xfsprogs-3.0.0.ebuild,
- -xfsprogs-3.0.1-r1.ebuild, files/xfsprogs-3.1.1-sharedlibs.patch,
- xfsprogs-3.1.2.ebuild:
+ 18 Aug 2010; Mike Frysinger <vapier@gentoo.org> xfsprogs-3.1.2.ebuild,
+ +files/xfsprogs-3.1.2-depend.patch:
+ Clean up dependency generation to avoid parallel build issues #333155 by
+ Samuli Suominen.
+
+ 17 Aug 2010; Mike Frysinger <vapier@gentoo.org>
+ files/xfsprogs-3.1.1-sharedlibs.patch, xfsprogs-3.1.2.ebuild:
Clean up library install and prefer readline over editline like upstream
#311109.
diff --git a/sys-fs/xfsprogs/files/xfsprogs-3.1.2-depend.patch b/sys-fs/xfsprogs/files/xfsprogs-3.1.2-depend.patch
new file mode 100644
index 000000000000..4c1b16e8ad7c
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-3.1.2-depend.patch
@@ -0,0 +1,239 @@
+http://bugs.gentoo.org/333155
+
+hackish fix for constant dependency and parallel build failures
+
+--- a/copy/Makefile
++++ b/copy/Makefile
+@@ -13,7 +13,7 @@
+ LTDEPENDENCIES = $(LIBXFS)
+ LLDFLAGS =
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/db/Makefile
++++ b/db/Makefile
+@@ -30,7 +30,7 @@
+ CFLAGS += -DENABLE_EDITLINE
+ endif
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/estimate/Makefile
++++ b/estimate/Makefile
+@@ -9,7 +9,7 @@
+ LTCOMMAND = xfs_estimate
+ CFILES = xfs_estimate.c
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/fsr/Makefile
++++ b/fsr/Makefile
+@@ -10,7 +10,7 @@
+ CFILES = xfs_fsr.c
+ LLDLIBS = $(LIBHANDLE)
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/growfs/Makefile
++++ b/growfs/Makefile
+@@ -22,7 +22,7 @@
+ LLDFLAGS =
+ LSRCFILES = xfs_info.sh
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/include/buildrules
++++ b/include/buildrules
+@@ -94,10 +94,9 @@
+
+ MAKEDEP := $(MAKEDEPEND) $(CFLAGS)
+
+-ltdepend: $(CFILES) $(HFILES)
++# a bit hackish, but works for now
++LTDEP_FILTER = $(SED) -e 's,^\([^:]*\)\.o,\1.lo,'
++DEP_FILTER = cat
++.dep: $(CFILES) $(HFILES)
+ @echo " [DEP]"
+- $(Q)$(MAKEDEP) $(CFILES) | $(SED) -e 's,^\([^:]*\)\.o,\1.lo,' > .dep
+-
+-depend: $(CFILES) $(HFILES)
+- @echo " [DEP]"
+- $(Q)$(MAKEDEP) $(CFILES) > .dep
++ $(Q)$(MAKEDEP) $(CFILES) | $(DEP_FILTER) > .dep
+--- a/io/Makefile
++++ b/io/Makefile
+@@ -63,7 +63,7 @@
+ LCFLAGS += -DHAVE_FALLOCATE
+ endif
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/libdisk/Makefile
++++ b/libdisk/Makefile
+@@ -20,7 +20,7 @@
+ LSRCFILES = $(LINUX_DRIVERS)
+ endif
+
+-default: ltdepend $(LTLIBRARY)
++default: $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+@@ -32,4 +32,5 @@
+
+ install-qa: install-dev
+
++DEP_FILTER = $(LTDEP_FILTER)
+ -include .dep
+--- a/libhandle/Makefile
++++ b/libhandle/Makefile
+@@ -15,7 +15,7 @@
+ CFILES = handle.c jdm.c
+ LSRCFILES = libhandle.sym
+
+-default: ltdepend $(LTLIBRARY)
++default: $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+@@ -27,4 +27,5 @@
+
+ install-qa: install-dev
+
++DEP_FILTER = $(LTDEP_FILTER)
+ -include .dep
+--- a/libxcmd/Makefile
++++ b/libxcmd/Makefile
+@@ -28,7 +28,7 @@
+ LCFLAGS += -DENABLE_EDITLINE
+ endif
+
+-default: ltdepend $(LTLIBRARY)
++default: $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+@@ -40,4 +40,5 @@
+
+ install-qa: default
+
++DEP_FILTER = $(LTDEP_FILTER)
+ -include .dep
+--- a/libxfs/Makefile
++++ b/libxfs/Makefile
+@@ -36,7 +36,7 @@
+ # don't try linking xfs_repair with a debug libxfs.
+ DEBUG = -DNDEBUG
+
+-default: ltdepend $(LTLIBRARY)
++default: $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+@@ -48,4 +48,5 @@
+
+ install-qa: default
+
++DEP_FILTER = $(LTDEP_FILTER)
+ -include .dep
+--- a/libxlog/Makefile
++++ b/libxlog/Makefile
+@@ -17,7 +17,7 @@
+ # don't want to link xfs_repair with a debug libxlog.
+ DEBUG = -DNDEBUG
+
+-default: ltdepend $(LTLIBRARY)
++default: $(LTLIBRARY)
+
+ include $(BUILDRULES)
+
+@@ -29,4 +29,5 @@
+
+ install-qa: default
+
++DEP_FILTER = $(LTDEP_FILTER)
+ -include .dep
+--- a/logprint/Makefile
++++ b/logprint/Makefile
+@@ -16,7 +16,7 @@
+ LTDEPENDENCIES = $(LIBXFS) $(LIBXLOG)
+ LLDFLAGS =
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/mdrestore/Makefile
++++ b/mdrestore/Makefile
+@@ -12,7 +12,7 @@
+ LTDEPENDENCIES = $(LIBXFS)
+ LLDFLAGS =
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/mkfs/Makefile
++++ b/mkfs/Makefile
+@@ -27,7 +27,7 @@
+ LSRCFILES = $(FSTYP).c
+ LDIRT = $(FSTYP)
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ ifneq ($(ENABLE_BLKID),yes)
+ default: $(FSTYP)
+--- a/quota/Makefile
++++ b/quota/Makefile
+@@ -28,7 +28,7 @@
+ CFLAGS += -DENABLE_EDITLINE
+ endif
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
+--- a/repair/Makefile
++++ b/repair/Makefile
+@@ -24,7 +24,7 @@
+ LTDEPENDENCIES = $(LIBXFS) $(LIBXLOG)
+ LLDFLAGS =
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ globals.o: globals.h
+
+--- a/rtcp/Makefile
++++ b/rtcp/Makefile
+@@ -9,7 +9,7 @@
+ CFILES = xfs_rtcp.c
+ LLDFLAGS =
+
+-default: depend $(LTCOMMAND)
++default: $(LTCOMMAND)
+
+ include $(BUILDRULES)
+
diff --git a/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild b/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild
index c762ec8e4b9e..f0b0b53d8afb 100644
--- a/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild,v 1.3 2010/08/17 13:14:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.1.2.ebuild,v 1.4 2010/08/18 00:33:33 vapier Exp $
EAPI="3"
@@ -40,6 +40,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.1.1-sharedlibs.patch
+ epatch "${FILESDIR}"/${PN}-3.1.2-depend.patch #333155
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \