summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-20 07:17:11 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-20 07:17:11 +0000
commit8ee2706876c3d37ec0af86532ff27d82f0ad6b91 (patch)
treed1dfefebb9eb8829e4304db4d4a7a77bae5d31b9
parentRevision bump to create a stable candidate. (diff)
downloadgentoo-2-8ee2706876c3d37ec0af86532ff27d82f0ad6b91.tar.gz
gentoo-2-8ee2706876c3d37ec0af86532ff27d82f0ad6b91.tar.bz2
gentoo-2-8ee2706876c3d37ec0af86532ff27d82f0ad6b91.zip
Respecting LDFLAGS, linking correctly, #247931 & #343339; More config options added
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
-rw-r--r--net-analyzer/nessus-libraries/ChangeLog12
-rw-r--r--net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch61
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild44
3 files changed, 115 insertions, 2 deletions
diff --git a/net-analyzer/nessus-libraries/ChangeLog b/net-analyzer/nessus-libraries/ChangeLog
index 0644a73d1e7b..5da7636908b8 100644
--- a/net-analyzer/nessus-libraries/ChangeLog
+++ b/net-analyzer/nessus-libraries/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/nessus-libraries
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/ChangeLog,v 1.91 2010/09/06 18:35:14 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/ChangeLog,v 1.92 2011/04/20 07:17:11 jlec Exp $
+
+*nessus-libraries-2.2.9-r1 (20 Apr 2011)
+
+ 20 Apr 2011; Justin Lecher <jlec@gentoo.org>
+ +nessus-libraries-2.2.9-r1.ebuild,
+ +files/nessus-libraries-2.2.9-linking.patch:
+ Respecting LDFLAGS, linking correctly, #247931 & #343339; More config options
+ added
06 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
-nessus-libraries-2.2.6.ebuild:
diff --git a/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch b/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch
new file mode 100644
index 000000000000..41cd2b21c938
--- /dev/null
+++ b/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch
@@ -0,0 +1,61 @@
+ Makefile | 4 ++--
+ libhosts_gatherer/Makefile | 2 +-
+ libnessus/Makefile | 4 ++--
+ libnessus/kb.c | 1 +
+ 4 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 938d1b2..672d8cf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,8 +3,8 @@ include nessus.tmpl
+ ALLDEPS = nessus.tmpl nessus-config
+
+ all: $(ALLDEPS) $(PCAP_MAKE)
+- cd libnessus && ${MAKE}
+- cd libhosts_gatherer && ${MAKE}
++ ${MAKE} -C libnessus
++ ${MAKE} -C libhosts_gatherer
+
+ nessus-config: nessus-config.pre Makefile nessus.tmpl
+ @echo Creating $@ ...
+diff --git a/libhosts_gatherer/Makefile b/libhosts_gatherer/Makefile
+index e2a647c..7d628d8 100644
+--- a/libhosts_gatherer/Makefile
++++ b/libhosts_gatherer/Makefile
+@@ -22,7 +22,7 @@ install : libhosts_gatherer.la
+ $(LIBTOOL) --finish $(DESTDIR)${libdir}
+
+ libhosts_gatherer.la : $(OBJS)
+- $(LIBTOOL) $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
+diff --git a/libnessus/Makefile b/libnessus/Makefile
+index c5a96db..211f57a 100644
+--- a/libnessus/Makefile
++++ b/libnessus/Makefile
+@@ -100,8 +100,8 @@ kb.o: kb.c
+ snprintf.o : snprintf.c
+ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
+ libnessus.la: $(OBJS)
+- $(LIBTOOL) $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
+- -version-info ${PACKAGE_VERSION}
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
++ -version-info ${PACKAGE_VERSION} `pcap-config --libs` `pkg-config --libs openssl`
+
+ install : libnessus.la
+ test -d $(DESTDIR)${libdir} || $(INSTALL_DIR) -m 755 $(DESTDIR)${libdir}
+diff --git a/libnessus/kb.c b/libnessus/kb.c
+index 921c1a1..cbfd840 100644
+--- a/libnessus/kb.c
++++ b/libnessus/kb.c
+@@ -20,6 +20,7 @@
+ */
+
+ #include <includes.h>
++#include <fnmatch.h>
+ #define HASH_MAX 65537
+
+
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..1c92dccb1b19
--- /dev/null
+++ b/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild,v 1.1 2011/04/20 07:17:11 jlec Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt debug static-libs"
+
+# Hard dep on SSL since libnasl won't compile when this package is emerged -ssl.
+DEPEND="
+ dev-libs/openssl
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-linking.patch
+ sed \
+ -e "s:^\(LDFLAGS=\):\1 ${LDFLAGS}:g" \
+ -i nessus.tmpl.in
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable crypt cypher) \
+ $(use_enable debug) \
+ $(use_enable debug debug-ssl) \
+ $(use_enable static-libs static) \
+ --enable-shared \
+ --with-ssl="${EPREFIX}/usr/$(get_libdir)" \
+ --disable-nessuspcap
+}