summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDion Moult <moult@gentoo.org>2013-12-15 12:12:16 +0000
committerDion Moult <moult@gentoo.org>2013-12-15 12:12:16 +0000
commit8e20b0a59acd9a2e254222777b394b209810aea1 (patch)
treed7983741dac373e0ed5e75c635bc3f77cebf0731
parentIntroduce the Glide64mk2 video plugin for mupen64plus-2.0. (diff)
downloadgentoo-2-8e20b0a59acd9a2e254222777b394b209810aea1.tar.gz
gentoo-2-8e20b0a59acd9a2e254222777b394b209810aea1.tar.bz2
gentoo-2-8e20b0a59acd9a2e254222777b394b209810aea1.zip
<=net-libs/opal-2.2.11 removal (pending 11 July 2013), see #290062 and #290063 for reference.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--net-libs/opal/ChangeLog6
-rw-r--r--net-libs/opal/opal-2.2.11.ebuild106
2 files changed, 5 insertions, 107 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index 8cfe15194048..04d0cddb42c5 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.97 2013/10/27 09:43:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.98 2013/12/15 12:12:16 moult Exp $
+
+ 15 Dec 2013; Dion Moult <moult@gentoo.org> -opal-2.2.11.ebuild:
+ <=net-libs/opal-2.2.11 removal (pending 11 July 2013), see #290062 and #290063
+ for reference.
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due voip herd removal:
diff --git a/net-libs/opal/opal-2.2.11.ebuild b/net-libs/opal/opal-2.2.11.ebuild
deleted file mode 100644
index 29ac32eadab4..000000000000
--- a/net-libs/opal/opal-2.2.11.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.11.ebuild,v 1.9 2010/07/20 18:41:58 jer Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="OPAL library, used by Ekiga"
-HOMEPAGE="http://www.ekiga.org"
-SRC_URI="http://www.ekiga.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="novideo noaudio debug"
-
-RDEPEND="~dev-libs/pwlib-1.10.$((${PV##*.}-1))
- >=media-video/ffmpeg-0.4.7"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # Makefile is currently broken with NOTRACE=1, fix that
- epatch "${FILESDIR}"/${PN}-2.1.1-notrace.diff
-}
-
-src_compile() {
- tc-export CC CXX
- local makeopts
- local myconf
-
- # remove -fstack-protector, may cause problems (bug #75259)
- filter-flags -fstack-protector
-
- # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
- # compile with PTRACING if the user wants to debug stuff
- if ! use debug; then
- makeopts="${makeopts} NOTRACE=1"
- fi
-
- # doesn't work with osptoolkit-3.3.1
- # iax2 support is missing in the tarball, disable it too
- myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
-
- use novideo \
- && myconf="${myconf} --disable-video"
-
- use noaudio \
- && myconf="${myconf} --disable-audio"
-
- econf \
- PWLIBDIR=/usr/share/pwlib \
- OPALDIR="${S}" \
- ${myconf} || die "configure failed"
-
- emake ${makeopts} opt || die "make failed"
-}
-
-src_install() {
- local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
- local makeopts libdir libname
-
- # make NOTRACE=1 opt ==> linux_$ARCH_n
- # make opt ==> linux_$ARCH_r
- if ! use debug; then
- OPAL_SUFFIX="n"
- makeopts="NOTRACE=1"
- else
- OPAL_SUFFIX="r"
- fi
-
- # use ptlib-config to get the right values here (for hppa, amd64 ...)
- OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
-
- # set ALT_ARCH
- if use debug; then
- ALT_ARCH=${OPAL_ARCH/_r/_n}
- else
- ALT_ARCH=${OPAL_ARCH/_n/_r}
- fi
-
- ###
- # Install stuff
- #
- make PREFIX=/usr DESTDIR="${D}" \
- ${makeopts} install || die "install failed"
-
- libdir=$(get_libdir)
- libname="libopal_${OPAL_ARCH}.so.${PV}"
-
- # compat symlinks
- for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
- dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
- done
- dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
- dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
-
- ###
- # Compatibility "hacks"
- #
-
- # install version.h into $OPALDIR
- insinto /usr/share/opal
- doins version.h
-}