summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-01-05 18:01:48 +0000
committerJim Ramsay <lack@gentoo.org>2012-01-05 18:01:48 +0000
commit8dba62c14b2afe017a55397c4d30de70acdd1b77 (patch)
treea0cc5bc738c091ae5e2794e1fb4ac955263cec12
parentVersion bump: 7.3.372 is released (diff)
downloadgentoo-2-8dba62c14b2afe017a55397c4d30de70acdd1b77.tar.gz
gentoo-2-8dba62c14b2afe017a55397c4d30de70acdd1b77.tar.bz2
gentoo-2-8dba62c14b2afe017a55397c4d30de70acdd1b77.zip
Version bump: 7.3.372 is released
(Portage version: 2.1.10.41/cvs/Linux x86_64)
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/gvim-7.3.372.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index d2f207fa496d..4b5ff0daae6c 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.361 2011/11/28 18:20:30 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.362 2012/01/05 18:01:48 lack Exp $
+
+*gvim-7.3.372 (09 Dec 2011)
+
+ 09 Dec 2011; Jim Ramsay <jim_ramsay@gentoo.org> +gvim-7.3.372.ebuild:
+ Version bump: 7.3.372 is released
*gvim-7.3.353 (28 Nov 2011)
diff --git a/app-editors/gvim/gvim-7.3.372.ebuild b/app-editors/gvim/gvim-7.3.372.ebuild
new file mode 100644
index 000000000000..13bdd16a2f49
--- /dev/null
+++ b/app-editors/gvim/gvim-7.3.372.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.3.372.ebuild,v 1.1 2012/01/05 18:01:48 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+}