summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-12 18:49:52 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-12 18:49:52 +0000
commit8d7378f9d798a6397b6f9482899d8a9d6326d81d (patch)
treef7e1b4ec70221db08ad3b3a089b571f7f1c6392f
parentVersion bump for Gnome 2.32 (diff)
downloadgentoo-2-8d7378f9d798a6397b6f9482899d8a9d6326d81d.tar.gz
gentoo-2-8d7378f9d798a6397b6f9482899d8a9d6326d81d.tar.bz2
gentoo-2-8d7378f9d798a6397b6f9482899d8a9d6326d81d.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
-rw-r--r--gnome-base/nautilus/ChangeLog14
-rw-r--r--gnome-base/nautilus/metadata.xml3
-rw-r--r--gnome-base/nautilus/nautilus-2.32.0.ebuild84
3 files changed, 100 insertions, 1 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index fa9ea15ba9d4..5a24cc6d22bb 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.357 2010/10/09 09:27:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.358 2010/10/12 18:49:52 pacho Exp $
+
+*nautilus-2.32.0 (12 Oct 2010)
+
+ 12 Oct 2010; Pacho Ramos <pacho@gentoo.org> +nautilus-2.32.0.ebuild:
+ Version bump for Gnome 2.32: Save passwords for the session by default,
+ don't show 'File Browser' anymore in the window title, port to GDBus,
+ change the default order for files in special directories, add 'Trashed
+ On' and 'Original Location' columns in the trash, new dialog to handle
+ conflicts within file copy/move operations, new button in the trashbar to
+ restore selected items, other bugfixes and translation updates. Add
+ introspection support, switch to upstream way of handling bug #266398, use
+ addpredict instead of addwrite since it looks to be enough.
09 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
nautilus-2.30.1-r1.ebuild:
diff --git a/gnome-base/nautilus/metadata.xml b/gnome-base/nautilus/metadata.xml
index 317d01b8c2ff..7f7e136c1c68 100644
--- a/gnome-base/nautilus/metadata.xml
+++ b/gnome-base/nautilus/metadata.xml
@@ -5,6 +5,9 @@
<use>
<flag name='beagle'>Enables support for searching using the Beagle
(<pkg>app-misc/beagle</pkg>) desktop search tool</flag>
+ <flag name="introspection">Use
+ <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
<flag name='tracker'>Enables support for searching using the Tracker
(<pkg>app-misc/tracker</pkg>) search tool</flag>
</use>
diff --git a/gnome-base/nautilus/nautilus-2.32.0.ebuild b/gnome-base/nautilus/nautilus-2.32.0.ebuild
new file mode 100644
index 000000000000..c6fb2a50f884
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-2.32.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.32.0.ebuild,v 1.1 2010/10/12 18:49:52 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/nautilus/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc gnome +introspection xmp"
+
+RDEPEND=">=dev-libs/glib-2.25.9
+ >=gnome-base/gnome-desktop-2.29.91:0
+ >=x11-libs/pango-1.1.2
+ >=x11-libs/gtk+-2.22:2[introspection?]
+ >=dev-libs/libxml2-2.4.7
+ >=media-libs/libexif-0.5.12
+ >=gnome-base/gconf-2
+ dev-libs/libunique
+ x11-libs/libXext
+ x11-libs/libXrender
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40.1
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+# For eautoreconf
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am"
+
+PDEPEND="gnome? ( >=x11-themes/gnome-icon-theme-1.1.91 )
+ >=gnome-base/gvfs-0.1.2"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ --disable-packagekit
+ $(use_enable introspection)
+ $(use_enable xmp)"
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove crazy CFLAGS
+ sed 's:-DG.*DISABLE_DEPRECATED::g' -i configure.in configure \
+ || die "sed 1 failed"
+
+ # Upstream chose a different way to fix this, we will try it then.
+ # Fix nautilus flipping-out with --no-desktop -- bug 266398
+ #epatch "${FILESDIR}/${PN}-2.27.4-change-reg-desktop-file-with-no-desktop.patch"
+}
+
+src_test() {
+ addpredict "/root/.gnome2_private"
+ unset SESSION_MANAGER
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "Test phase failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "nautilus can use gstreamer to preview audio files. Just make sure"
+ elog "to have the necessary plugins available to play the media type you"
+ elog "want to preview"
+}