summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-20 11:35:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-20 11:35:15 +0000
commit8caa12daebbe79eaeeb96916729a447f49f675b7 (patch)
treec4b632c1c72f5e1d7c88d8ab18f8ddbe52c0d5d6
parentVersion bump. (diff)
downloadgentoo-2-8caa12daebbe79eaeeb96916729a447f49f675b7.tar.gz
gentoo-2-8caa12daebbe79eaeeb96916729a447f49f675b7.tar.bz2
gentoo-2-8caa12daebbe79eaeeb96916729a447f49f675b7.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog8
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.5.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index cc4196d33f2f..6abe859b9e77 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.27 2014/08/25 17:18:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.28 2014/11/20 11:35:15 mrueg Exp $
+
+*pidgin-opensteamworks-1.5 (20 Nov 2014)
+
+ 20 Nov 2014; Manuel Rüger <mrueg@gentoo.org>
+ +pidgin-opensteamworks-1.5.ebuild:
+ Version bump.
25 Aug 2014; Manuel Rüger <mrueg@gentoo.org> pidgin-opensteamworks-1.4.ebuild:
Mark amd64 stable. Bug #517808.
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.5.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.5.ebuild
new file mode 100644
index 000000000000..efd58432b668
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.5.ebuild,v 1.1 2014/11/20 11:35:15 mrueg Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://pidgin-opensteamworks.googlecode.com/svn/trunk/steam-mobile/releases/steam-mobile-${PV}.tar.bz2
+ http://pidgin-opensteamworks.googlecode.com/files/icons.zip
+ -> ${PN}-icons.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/nss
+ gnome-base/libgnome-keyring
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${PN}-1.3-Makefile "${S}"/Makefile || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/pixmaps/pidgin/protocols
+ doins -r "${WORKDIR}"/{16,48}
+}