summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-06 04:17:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-06 04:17:54 +0000
commit8c1722917552cc8e99dff9c83c881450e948287e (patch)
tree9e4a23485ee154c57dcdc108235ff9cbc36ad326
parentAdd patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT stdin... (diff)
downloadgentoo-2-8c1722917552cc8e99dff9c83c881450e948287e.tar.gz
gentoo-2-8c1722917552cc8e99dff9c83c881450e948287e.tar.bz2
gentoo-2-8c1722917552cc8e99dff9c83c881450e948287e.zip
version bump
(Portage version: 2.1_rc4)
-rw-r--r--games-sports/bygfoot/ChangeLog8
-rw-r--r--games-sports/bygfoot/bygfoot-2.0.0.ebuild54
-rw-r--r--games-sports/bygfoot/files/digest-bygfoot-2.0.03
3 files changed, 64 insertions, 1 deletions
diff --git a/games-sports/bygfoot/ChangeLog b/games-sports/bygfoot/ChangeLog
index 9a4bbd912c1b..f9cd91965576 100644
--- a/games-sports/bygfoot/ChangeLog
+++ b/games-sports/bygfoot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/bygfoot
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/ChangeLog,v 1.12 2006/05/14 22:44:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/ChangeLog,v 1.13 2006/06/06 04:17:54 mr_bones_ Exp $
+
+*bygfoot-2.0.0 (06 Jun 2006)
+
+ 06 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +bygfoot-2.0.0.ebuild:
+ version bump
*bygfoot-1.9.6 (14 May 2006)
diff --git a/games-sports/bygfoot/bygfoot-2.0.0.ebuild b/games-sports/bygfoot/bygfoot-2.0.0.ebuild
new file mode 100644
index 000000000000..dd9d76b8663e
--- /dev/null
+++ b/games-sports/bygfoot/bygfoot-2.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/bygfoot-2.0.0.ebuild,v 1.1 2006/06/06 04:17:54 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GTK+2 Soccer Management Game"
+HOMEPAGE="http://bygfoot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e '/PACKAGE_LOCALE_DIR/s:\$(prefix)/\$(DATADIRNAME):/usr/share:' \
+ "${S}"/src/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e '/localedir/s:\$(libdir):/usr/share:' \
+ -e '/gnulocaledir/s:\$(datadir):/usr/share:' \
+ "${S}"/po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_install() {
+ localedir=/usr/share/locale \
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO UPDATE
+ newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
+ make_desktop_entry ${PN} "Bygfoot"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "If you'd like to keep your settings and savegames from previous"
+ einfo "1.9.x versions, you should rename the .bygfoot-1.9 directory"
+ einfo "to .bygfoot in your home directory."
+ echo
+ einfo "If you upgrade from 1.8.x, you should first delete the .bygfoot"
+ einfo "directory in your home dir to keep things clean."
+ einfo "Also note that savegames from 1.8.x are not compatible with"
+ einfo "current versions of ${PN}"
+}
diff --git a/games-sports/bygfoot/files/digest-bygfoot-2.0.0 b/games-sports/bygfoot/files/digest-bygfoot-2.0.0
new file mode 100644
index 000000000000..bb8c591f20a2
--- /dev/null
+++ b/games-sports/bygfoot/files/digest-bygfoot-2.0.0
@@ -0,0 +1,3 @@
+MD5 db92d2f1e6b8a6fe8a12f5bac9379240 bygfoot-2.0.0.tar.bz2 1384899
+RMD160 099e88c020643bca37fde650a16961e349260d92 bygfoot-2.0.0.tar.bz2 1384899
+SHA256 5e00093951a6463bb26260147dad17a6c8b37a4b3f179edf47e4befc5ca8ff82 bygfoot-2.0.0.tar.bz2 1384899