summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-04-05 11:41:21 +0000
committerCédric Krier <cedk@gentoo.org>2008-04-05 11:41:21 +0000
commit8bfaa63fff239946e4b3bb9156e069bcbcc74b18 (patch)
tree355991100dc2b7da4c684ac082da4cf1f88827ed
parentFix doins -> doins -r, also use mv instead of cp to be faster and catch symli... (diff)
downloadgentoo-2-8bfaa63fff239946e4b3bb9156e069bcbcc74b18.tar.gz
gentoo-2-8bfaa63fff239946e4b3bb9156e069bcbcc74b18.tar.bz2
gentoo-2-8bfaa63fff239946e4b3bb9156e069bcbcc74b18.zip
Version bump
(Portage version: 2.1.4.4)
-rw-r--r--app-laptop/macbook-backlight/ChangeLog10
-rw-r--r--app-laptop/macbook-backlight/macbook-backlight-0.2.ebuild26
2 files changed, 34 insertions, 2 deletions
diff --git a/app-laptop/macbook-backlight/ChangeLog b/app-laptop/macbook-backlight/ChangeLog
index 21d2e3c8f031..a10a701bbd2a 100644
--- a/app-laptop/macbook-backlight/ChangeLog
+++ b/app-laptop/macbook-backlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/macbook-backlight
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/macbook-backlight/ChangeLog,v 1.5 2007/08/24 21:39:08 cedk Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macbook-backlight/ChangeLog,v 1.6 2008/04/05 11:41:21 cedk Exp $
+
+*macbook-backlight-0.2 (05 Apr 2008)
+
+ 05 Apr 2008; Cédric Krier <cedk@gentoo.org>
+ +macbook-backlight-0.2.ebuild:
+ Version bump
24 Aug 2007; Cédric Krier <cedk@gentoo.org> macbook-backlight-0.1.ebuild:
Fix for bug #190017
diff --git a/app-laptop/macbook-backlight/macbook-backlight-0.2.ebuild b/app-laptop/macbook-backlight/macbook-backlight-0.2.ebuild
new file mode 100644
index 000000000000..749699a1b046
--- /dev/null
+++ b/app-laptop/macbook-backlight/macbook-backlight-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macbook-backlight/macbook-backlight-0.2.ebuild,v 1.1 2008/04/05 11:41:21 cedk Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="a tool to control the backlight intensity of macbook"
+HOMEPAGE="http://dev.gentoo.org/~cedk/macbook-backlight/"
+SRC_URI="http://dev.gentoo.org/~cedk/macbook-backlight/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=$DEPEND
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+ dodoc README
+}