summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-03-05 03:41:44 +0000
committerRobert Coie <rac@gentoo.org>2003-03-05 03:41:44 +0000
commit8bdad559d4e16569ea8602624eca5aeaec79dbe3 (patch)
treeefd39ec5d722641953ae7135472161976e36c225
parentgcc optimizations (diff)
downloadgentoo-2-8bdad559d4e16569ea8602624eca5aeaec79dbe3.tar.gz
gentoo-2-8bdad559d4e16569ea8602624eca5aeaec79dbe3.tar.bz2
gentoo-2-8bdad559d4e16569ea8602624eca5aeaec79dbe3.zip
fixes bug #16733
-rw-r--r--dev-db/mysqlcc/ChangeLog19
-rw-r--r--dev-db/mysqlcc/files/digest-mysqlcc-0.8.10-r11
-rw-r--r--dev-db/mysqlcc/files/mysqlcc-0.8.10-libmysqlclientac.patch46
-rw-r--r--dev-db/mysqlcc/files/mysqlcc-0.8.10-qmakespec.patch17
-rw-r--r--dev-db/mysqlcc/mysqlcc-0.8.10-r1.ebuild63
5 files changed, 145 insertions, 1 deletions
diff --git a/dev-db/mysqlcc/ChangeLog b/dev-db/mysqlcc/ChangeLog
index a9fcf2a5a3a9..553fe4ea2770 100644
--- a/dev-db/mysqlcc/ChangeLog
+++ b/dev-db/mysqlcc/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for dev-db/mysqlcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlcc/ChangeLog,v 1.4 2003/03/03 10:33:33 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlcc/ChangeLog,v 1.5 2003/03/05 03:41:44 rac Exp $
+
+*mysqlcc-0.8.10-r1 (04 Mar 2003)
+
+ 04 Mar 2003; Robert Coie <rac@gentoo.org> mysqlcc-0.8.10-r1.ebuild,
+ files/mysqlcc-0.8.10-libmysqlclientac.patch,
+ files/mysqlcc-0.8.10-qmakespec.patch:
+ The config.sub included with this package does not recognize linux-gnu
+ machines correctly, so replace it with one taken from a local automake
+ installation and run autoreconf. Allow the ebuild to override the
+ QMAKESPEC variable, so that 'linux-g++' is picked up correctly.
+ Replace the libmysqlclient autoconf macro with a simpler and sleeker
+ use of mysql_config, so that optionally dependent libraries (such as
+ libssl) are picked up for free. Make dependency on MySQL >=4.0, as
+ this version attempts to use command-line option processing from
+ libmysqlclient that is not available before that version. Fixes bug
+ #16733. Thanks to Peter Penkala <pjp@gentoo.org> for testing
+ assistance.
*mysqlcc-0.8.10 (03 Mar 2003)
diff --git a/dev-db/mysqlcc/files/digest-mysqlcc-0.8.10-r1 b/dev-db/mysqlcc/files/digest-mysqlcc-0.8.10-r1
new file mode 100644
index 000000000000..04c4ef94aa2c
--- /dev/null
+++ b/dev-db/mysqlcc/files/digest-mysqlcc-0.8.10-r1
@@ -0,0 +1 @@
+MD5 ff21b41affa228438952dfdbc1cbd7f3 mysqlcc-0.8.10-src.tar.gz 576315
diff --git a/dev-db/mysqlcc/files/mysqlcc-0.8.10-libmysqlclientac.patch b/dev-db/mysqlcc/files/mysqlcc-0.8.10-libmysqlclientac.patch
new file mode 100644
index 000000000000..f6db1a6a6bd1
--- /dev/null
+++ b/dev-db/mysqlcc/files/mysqlcc-0.8.10-libmysqlclientac.patch
@@ -0,0 +1,46 @@
+--- acinclude.m4.orig 2003-03-04 01:07:26.000000000 -0800
++++ acinclude.m4 2003-03-04 12:46:35.000000000 -0800
+@@ -6,34 +6,15 @@
+ AC_MSG_CHECKING([for libmysqlclient])
+ AC_MSG_RESULT()
+
+- mysql_ok=no
+-
+- SAVE_LIBS=$LIBS
+-
+- mysql_lib="$mysql_lib /usr/lib /usr/lib/mysql \
+- /usr/local/lib /usr/local/lib/mysql \
+- /usr/local/mysql/lib"
+-
+- for dir in $mysql_lib; do
+- if test "x$mysql_found" != "xyes"
+- then
+- AC_CHECK_FILE("$dir/libmysqlclient.a",
+- mysql_found=yes, mysql_found=no)
+- if test "x$mysql_found" = "xyes"
+- then
+- LIBS="-L$dir $SAVE_LIBS $LIBZ_LIB"
+- MYSQL_LIB="$dir/libmysqlclient.a $LIBZ_LIB"
+- AC_SUBST(MYSQL_LIB)
+- AC_CHECK_LIB(mysqlclient, mysql_real_connect,
+- mysql_ok=yes, mysql_ok=no)
+- fi
+- fi
+- done
+-
+- if test "x$mysql_ok" != "xyes"
+- then
+- AC_MSG_ERROR([Could not find libmysqlclient in '$mysql_lib'])
+- fi
++ # dependencies are guaranteed to ensure we have mysql_config
++ # available, and it is a much cleaner way of discovering what
++ # must be linked against libmysqlclient, that transparently
++ # covers USE="ssl" and other issues.
++ # Robert Coie <rac@gentoo.org> 2003.03.04
++
++ mysql_ok=yes
++ MYSQL_LIB=`mysql_config --libs`
++ LIBS="${LIBS} ${MYSQL_LIB}"
+ ])
+
+
diff --git a/dev-db/mysqlcc/files/mysqlcc-0.8.10-qmakespec.patch b/dev-db/mysqlcc/files/mysqlcc-0.8.10-qmakespec.patch
new file mode 100644
index 000000000000..0a80f4c62ea6
--- /dev/null
+++ b/dev-db/mysqlcc/files/mysqlcc-0.8.10-qmakespec.patch
@@ -0,0 +1,17 @@
+--- configure.in.orig 2003-03-04 13:13:05.000000000 -0800
++++ configure.in 2003-03-04 13:13:53.000000000 -0800
+@@ -24,7 +24,13 @@
+ AC_SUBST(MYSQLCC_HEADERS)
+ AC_SUBST(MYSQLCC_SOURCES)
+ AC_OUTPUT(mysqlcc.pro)
+-QMAKESPEC=$QTDIR/mkspecs/$host_os
++
++# the following line is disabled so that we can specify QMAKESPEC from
++# the ebuild - otherwise on some systems it looks for 'linux-gcc',
++# rather than the correct 'linux-g++'
++# Robert Coie <rac@gentoo.org> 2003.03.04
++#QMAKESPEC=$QTDIR/mkspecs/$host_os
++
+ echo "Creating Makefile with qmake"
+ QMAKESPEC=$QMAKESPEC QTDIR=$QTDIR $QTDIR/bin/qmake mysqlcc.pro
+ if test ! $? = 0 ; then
diff --git a/dev-db/mysqlcc/mysqlcc-0.8.10-r1.ebuild b/dev-db/mysqlcc/mysqlcc-0.8.10-r1.ebuild
new file mode 100644
index 000000000000..23f8efcedf58
--- /dev/null
+++ b/dev-db/mysqlcc/mysqlcc-0.8.10-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqlcc/mysqlcc-0.8.10-r1.ebuild,v 1.1 2003/03/05 03:41:44 rac Exp $
+
+S=${WORKDIR}/${P}-src
+DESCRIPTION="a MySQL GUI Client"
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/MyCC/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X qt"
+
+DEPEND="virtual/glibc
+ >=x11-libs/qt-3.0.5
+ >=dev-db/mysql-4.0.0"
+RDEPEND=""
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-qmakespec.patch
+ cd ${S}; epatch ${FILESDIR}/${P}-libmysqlclientac.patch
+}
+
+src_compile() {
+ # The config.sub in this distribution appears to be very stale
+ # so we replace it with one from a known better source. I am
+ # not attached to using 1.4, but it seemed like it had the best
+ # chance of compatibility.
+ # Robert Coie <rac@gentoo.org> 2003.03.03
+ if [ -e /usr/share/automake-1.4/config.sub ]; then
+ cp /usr/share/automake-1.4/config.sub ${S}
+ fi
+ cd ${S}; autoreconf -f;
+
+ if [ "`use ssl`" ]; then
+ SUBLIBS="${SUBLIBS} -lssl"
+ echo "libs now ${SUBLIBS}"
+ fi
+
+ QMAKESPEC="linux-g++" LIBS=${LIBS} econf --with-qt=${QTDIR} || die
+
+ cp Makefile Makefile.orig
+ sed -e "s:CFLAGS = -pipe -Wall -W -g:CFLAGS = ${CFLAGS}:" \
+ -e "s:CXXFLAGS = -pipe -Wall -W -g:CXXFLAGS = ${CXXFLAGS}:" \
+ Makefile.orig > Makefile
+
+ QTDIR=$QTDIR
+ emake || die
+}
+
+src_install() {
+ dobin mysqlcc
+ dodir /usr/share/mysqlcc
+ insinto /usr/share/mysqlcc
+ doins warning.wav information.wav error.wav syntax.txt
+ dodir /usr/share/mysqlcc/translations
+ insinto /usr/share/mysqlcc/translations
+ doins translations/Espanol.qm translations/Espanol.ts translations/Russian.qm translations/Russian.ts
+}