summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2007-09-15 18:27:57 +0000
committerJoel Martin <kanaka@gentoo.org>2007-09-15 18:27:57 +0000
commit89b319b9798e5698606700e1b1b5b0fd7e926ff8 (patch)
treeb0fae0f0901c11a495a1f1f89a90dbb7df125cc4
parentStable for HPPA (bug #192579). (diff)
downloadgentoo-2-89b319b9798e5698606700e1b1b5b0fd7e926ff8.tar.gz
gentoo-2-89b319b9798e5698606700e1b1b5b0fd7e926ff8.tar.bz2
gentoo-2-89b319b9798e5698606700e1b1b5b0fd7e926ff8.zip
Remove left hand side quotes in [[ ]] test. Don't call die if epatch fails, since this is already handled in epatch.
(Portage version: 2.1.2.12)
-rw-r--r--dev-lang/python/python-2.4.4-r4.ebuild7
-rw-r--r--dev-lang/python/python-2.4.4-r5.ebuild7
-rw-r--r--dev-lang/python/python-2.5.1-r2.ebuild7
3 files changed, 9 insertions, 12 deletions
diff --git a/dev-lang/python/python-2.4.4-r4.ebuild b/dev-lang/python/python-2.4.4-r4.ebuild
index 620516113321..ef953fbd2c15 100644
--- a/dev-lang/python/python-2.4.4-r4.ebuild
+++ b/dev-lang/python/python-2.4.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r4.ebuild,v 1.22 2007/09/11 19:24:01 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r4.ebuild,v 1.23 2007/09/15 18:27:57 kanaka Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -58,10 +58,9 @@ src_unpack() {
cd ${S}
if tc-is-cross-compiler ; then
- [[ "$(python -V 2>&1)" != "Python ${PV}" ]] && \
+ [[ $(python -V 2>&1) != "Python ${PV}" ]] && \
die "Crosscompiling requires the same host and build versions."
- epatch ${FILESDIR}/python-2.4.4-test-cross.patch || \
- die "cross patch failed"
+ epatch ${FILESDIR}/python-2.4.4-test-cross.patch
else
rm "${WORKDIR}/${PV}"/*_all_crosscompile.patch
fi
diff --git a/dev-lang/python/python-2.4.4-r5.ebuild b/dev-lang/python/python-2.4.4-r5.ebuild
index 0bbfafe9087e..7914a82e712b 100644
--- a/dev-lang/python/python-2.4.4-r5.ebuild
+++ b/dev-lang/python/python-2.4.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.5 2007/09/11 19:24:01 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.6 2007/09/15 18:27:57 kanaka Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -58,10 +58,9 @@ src_unpack() {
cd ${S}
if tc-is-cross-compiler ; then
- [[ "$(python -V 2>&1)" != "Python ${PV}" ]] && \
+ [[ $(python -V 2>&1) != "Python ${PV}" ]] && \
die "Crosscompiling requires the same host and build versions."
- epatch ${FILESDIR}/python-2.4.4-test-cross.patch || \
- die "cross patch failed"
+ epatch ${FILESDIR}/python-2.4.4-test-cross.patch
else
rm "${WORKDIR}/${PV}"/*_all_crosscompile.patch
fi
diff --git a/dev-lang/python/python-2.5.1-r2.ebuild b/dev-lang/python/python-2.5.1-r2.ebuild
index 39b498b76dbb..c1116bf977a6 100644
--- a/dev-lang/python/python-2.5.1-r2.ebuild
+++ b/dev-lang/python/python-2.5.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.1-r2.ebuild,v 1.16 2007/09/11 19:24:01 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.1-r2.ebuild,v 1.17 2007/09/15 18:27:57 kanaka Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -62,10 +62,9 @@ src_unpack() {
cd "${S}"
if tc-is-cross-compiler ; then
- [[ "$(python -V 2>&1)" != "Python ${PV}" ]] && \
+ [[ $(python -V 2>&1) != "Python ${PV}" ]] && \
die "Crosscompiling requires the same host and build versions."
- epatch ${FILESDIR}/python-2.4.4-test-cross.patch || \
- die "cross patch failed"
+ epatch ${FILESDIR}/python-2.4.4-test-cross.patch
else
rm "${WORKDIR}/${PV}"/*_all_crosscompile.patch
fi