summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-02 17:14:46 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-02 17:14:46 +0000
commit89804a7a376eedaf4bc106771cf1b6613ba30b9f (patch)
tree95998beb8cee3a659add4c3cc79da089cbf087b2
parentRemoved the executable bit from files/sysrqd.init as it's installed through n... (diff)
downloadgentoo-2-89804a7a376eedaf4bc106771cf1b6613ba30b9f.tar.gz
gentoo-2-89804a7a376eedaf4bc106771cf1b6613ba30b9f.tar.bz2
gentoo-2-89804a7a376eedaf4bc106771cf1b6613ba30b9f.zip
Removed the executable bit from files/rmake as it's installed through doinitd that calls doexe, which uses the EXEOPTIONS variable that
defaults to -m0755. Quoted some vars. (Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r2 x86_64)
-rw-r--r--app-admin/rmake/ChangeLog8
-rw-r--r--app-admin/rmake/rmake-1.0.8.ebuild14
-rw-r--r--app-admin/rmake/rmake-1.0.9.ebuild14
3 files changed, 21 insertions, 15 deletions
diff --git a/app-admin/rmake/ChangeLog b/app-admin/rmake/ChangeLog
index a55f2ec34585..af747e1f8e0d 100644
--- a/app-admin/rmake/ChangeLog
+++ b/app-admin/rmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/rmake
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/ChangeLog,v 1.16 2008/04/24 11:44:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/ChangeLog,v 1.17 2008/12/02 17:14:46 jmbsvicetto Exp $
+
+ 02 Dec 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ ChangeLog:
+ Removed the executable bit from files/rmake as it's installed through
+ doinitd that calls doexe, which uses the EXEOPTIONS variable that defaults
+ to -m0755.
24 Apr 2008; Raúl Porcel <armin76@gentoo.org> -files/digest-rmake-1.0.8,
-files/digest-rmake-1.0.9, -files/digest-rmake-1.0.13,
diff --git a/app-admin/rmake/rmake-1.0.8.ebuild b/app-admin/rmake/rmake-1.0.8.ebuild
index 95f32a2b3fb0..eb7ba03f2300 100644
--- a/app-admin/rmake/rmake-1.0.8.ebuild
+++ b/app-admin/rmake/rmake-1.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 2006-2007 Gentoo Foundation
+# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/rmake-1.0.8.ebuild,v 1.1 2007/04/24 21:24:05 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/rmake-1.0.8.ebuild,v 1.2 2008/12/02 17:14:46 jmbsvicetto Exp $
inherit eutils
@@ -22,17 +22,17 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- chmod 04755 ${D}/usr/libexec/rmake/chroothelper
- for x in ${D}/var/{rmake,{log,lib,run}/rmake} ${D}/{etc,srv}/rmake;do
+ make DESTDIR="${D}" install || die "install failed"
+ chmod 04755 "${D}/usr/libexec/rmake/chroothelper"
+ for x in "${D}/var/{rmake,{log,lib,run}/rmake}" "${D}/{etc,srv}/rmake"; do
mkdir -p $x
chown rmake:rmake $x
touch ${x}/.keep
done
- chmod 700 ${D}/var/rmake
+ chmod 700 "${D}/var/rmake"
# replace with updstream-provided in next release... see
# https://issues.rpath.com/browse/RMK-242
- doinitd ${FILESDIR}/rmake
+ doinitd "${FILESDIR}/rmake"
}
pkg_setup() {
diff --git a/app-admin/rmake/rmake-1.0.9.ebuild b/app-admin/rmake/rmake-1.0.9.ebuild
index 1276354838d9..c1eff4d349fe 100644
--- a/app-admin/rmake/rmake-1.0.9.ebuild
+++ b/app-admin/rmake/rmake-1.0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 2006-2007 Gentoo Foundation
+# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/rmake-1.0.9.ebuild,v 1.1 2007/05/23 14:49:26 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/rmake-1.0.9.ebuild,v 1.2 2008/12/02 17:14:46 jmbsvicetto Exp $
inherit eutils
@@ -22,17 +22,17 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- chmod 04755 ${D}/usr/libexec/rmake/chroothelper
- for x in ${D}/var/{rmake,{log,lib,run}/rmake} ${D}/{etc,srv}/rmake;do
+ make DESTDIR="${D}" install || die "install failed"
+ chmod 04755 "${D}/usr/libexec/rmake/chroothelper"
+ for x in "${D}/var/{rmake,{log,lib,run}/rmake}" "${D}/{etc,srv}/rmake"; do
mkdir -p $x
chown rmake:rmake $x
touch ${x}/.keep
done
- chmod 700 ${D}/var/rmake
+ chmod 700 "${D}/var/rmake"
# replace with updstream-provided in next release... see
# https://issues.rpath.com/browse/RMK-242
- doinitd ${FILESDIR}/rmake
+ doinitd "${FILESDIR}/rmake"
}
pkg_setup() {