summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-23 22:58:02 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-23 22:58:02 +0000
commit88da830cf79776d5ac9ed741b68b34c41ed59186 (patch)
tree4542328e23142191715c9e941d32c6879958e7d1
parentVersion bumped. Fixed QA issue. (diff)
downloadgentoo-2-88da830cf79776d5ac9ed741b68b34c41ed59186.tar.gz
gentoo-2-88da830cf79776d5ac9ed741b68b34c41ed59186.tar.bz2
gentoo-2-88da830cf79776d5ac9ed741b68b34c41ed59186.zip
Version bumped. Fixed QA issue.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
-rw-r--r--app-i18n/ibus-hangul/ChangeLog8
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-0.1.1.20081023.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index 7b1ea43302c5..d34878dcb529 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-hangul
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.1 2008/09/06 00:23:40 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.2 2008/10/23 22:58:02 matsuu Exp $
+
+*ibus-hangul-0.1.1.20081023 (23 Oct 2008)
+
+ 23 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-hangul-0.1.1.20081023.ebuild:
+ Version bumped. inherit python.
*ibus-hangul-0.1.1.20080901 (06 Sep 2008)
diff --git a/app-i18n/ibus-hangul/ibus-hangul-0.1.1.20081023.ebuild b/app-i18n/ibus-hangul/ibus-hangul-0.1.1.20081023.ebuild
new file mode 100644
index 000000000000..8dec791c3d12
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-0.1.1.20081023.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-0.1.1.20081023.ebuild,v 1.1 2008/10/23 22:58:02 matsuu Exp $
+
+inherit python
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ app-i18n/libhangul
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}