summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-02 18:39:26 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-02 18:39:26 +0000
commit88aed9c7e8febfec024c7798a9fed183e78e7ad6 (patch)
tree272d12fbc4ed1e077c72895c2bcee53de01d0872
parentBuild and install tools only when requested since they are considered depreca... (diff)
downloadgentoo-2-88aed9c7e8febfec024c7798a9fed183e78e7ad6.tar.gz
gentoo-2-88aed9c7e8febfec024c7798a9fed183e78e7ad6.tar.bz2
gentoo-2-88aed9c7e8febfec024c7798a9fed183e78e7ad6.zip
Remove old versions.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--dev-ruby/bundler/ChangeLog6
-rw-r--r--dev-ruby/bundler/bundler-1.0.3.ebuild45
-rw-r--r--dev-ruby/bundler/bundler-1.0.7.ebuild48
3 files changed, 5 insertions, 94 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 37b9538bea2e..cf2067e85df1 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.11 2011/01/20 07:52:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.12 2011/02/02 18:39:26 graaff Exp $
+
+ 02 Feb 2011; Hans de Graaff <graaff@gentoo.org> -bundler-1.0.3.ebuild,
+ -bundler-1.0.7.ebuild:
+ Remove old versions.
*bundler-1.0.9 (20 Jan 2011)
diff --git a/dev-ruby/bundler/bundler-1.0.3.ebuild b/dev-ruby/bundler/bundler-1.0.3.ebuild
deleted file mode 100644
index e768747851fc..000000000000
--- a/dev-ruby/bundler/bundler-1.0.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.3.ebuild,v 1.1 2010/10/16 08:29:47 graaff Exp $
-
-EAPI=2
-
-# ruby19 → uncountable number of test failures
-# jruby → needs to be tested because jruby-1.5.1 fails in multiple
-# ways unrelated to this package
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy way to vendor gem dependencies"
-HOMEPAGE="http://github.com/carlhuda/bundler"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend dev-ruby/rubygems
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
-RDEPEND="${RDEPEND}
- dev-vcs/git"
-DEPEND="${DEPEND}
- test? ( dev-vcs/git )"
-
-RUBY_PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-all_ruby_prepare() {
- # Reported upstream: http://github.com/carlhuda/bundler/issues#issue/771
- sed -i -e 's:Your bundle was installed to `vendor`:It was installed into ./vendor:' -e 's:Your bundle was installed to `vendor/bundle`:It was installed into ./vendor/bundle:' spec/install/gems/simple_case_spec.rb || die
-
- # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
- sed -i -e '159s/should/should_not/' spec/runtime/environment_rb_spec.rb || die
-}
diff --git a/dev-ruby/bundler/bundler-1.0.7.ebuild b/dev-ruby/bundler/bundler-1.0.7.ebuild
deleted file mode 100644
index 72d528f702c5..000000000000
--- a/dev-ruby/bundler/bundler-1.0.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.7.ebuild,v 1.1 2010/12/04 19:37:31 graaff Exp $
-
-EAPI=2
-
-# ruby19 → uncountable number of test failures
-# jruby → needs to be tested because jruby-1.5.1 fails in multiple
-# ways unrelated to this package
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy way to vendor gem dependencies"
-HOMEPAGE="http://github.com/carlhuda/bundler"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend dev-ruby/rubygems
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
-RDEPEND="${RDEPEND}
- dev-vcs/git"
-DEPEND="${DEPEND}
- test? ( dev-vcs/git )"
-
-RUBY_PATCHES=( "${FILESDIR}"/${PN}-1.0.3-gentoo.patch )
-
-all_ruby_prepare() {
- # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
- sed -i -e '575s/should/should_not/' spec/runtime/setup_spec.rb || die
-
- # Fails randomly and no clear cause can be found. Might be related
- # to bug 346357. This was broken in previous releases without a
- # failing spec, so patch out this spec for now since it is not a
- # regression.
- sed -i -e '49,54d' spec/install/deploy_spec.rb || die
-}