summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-24 17:27:52 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-24 17:27:52 +0000
commit8890ebb138a55fc76d90fd02f0366e8bcdaa5696 (patch)
treeed003dd60f6d9b7c86fdb4bb76bb08bfa2f4e377
parentclose bug #61 (yeah) - add a makewhatis.cron (diff)
downloadgentoo-2-8890ebb138a55fc76d90fd02f0366e8bcdaa5696.tar.gz
gentoo-2-8890ebb138a55fc76d90fd02f0366e8bcdaa5696.tar.bz2
gentoo-2-8890ebb138a55fc76d90fd02f0366e8bcdaa5696.zip
new qmail-vmailmgr ebuilds - add virtual hosting capabilities to qmail
-rw-r--r--net-mail/cvm-vmailmgr/ChangeLog9
-rw-r--r--net-mail/cvm-vmailmgr/cvm-vmailmgr-0.3.ebuild45
-rw-r--r--net-mail/cvm-vmailmgr/files/cvm-vmailmgr-socket1
-rw-r--r--net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.31
-rw-r--r--net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr3
-rw-r--r--net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr-log2
-rw-r--r--net-mail/mailfront/ChangeLog9
-rw-r--r--net-mail/mailfront/files/digest-mailfront-0.741
-rw-r--r--net-mail/mailfront/files/run-pop3front6
-rw-r--r--net-mail/mailfront/files/run-smtpfront14
-rw-r--r--net-mail/mailfront/mailfront-0.74.ebuild42
-rw-r--r--net-mail/qmail-vmailmgr/ChangeLog9
-rw-r--r--net-mail/qmail-vmailmgr/files/README31
-rw-r--r--net-mail/qmail-vmailmgr/files/digest-qmail-vmailmgr-0.0.1-r10
-rw-r--r--net-mail/qmail-vmailmgr/qmail-vmailmgr-0.0.1-r1.ebuild13
-rw-r--r--net-mail/vmailmgr/ChangeLog9
-rw-r--r--net-mail/vmailmgr/files/checkvpw-loginfail3
-rw-r--r--net-mail/vmailmgr/files/digest-vmailmgr-0.96.9-r11
-rw-r--r--net-mail/vmailmgr/files/separators1
-rw-r--r--net-mail/vmailmgr/files/socket-file1
-rw-r--r--net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild62
21 files changed, 263 insertions, 0 deletions
diff --git a/net-mail/cvm-vmailmgr/ChangeLog b/net-mail/cvm-vmailmgr/ChangeLog
new file mode 100644
index 000000000000..30e75d5ba8a4
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/cvm-vmailmgr
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*cvm-vmailmgr-0.3.1 (16 Apr 2002)
+
+ 16 Apr 2002; Thilo Bangert <bangert@gentoo.org> ChangeLog :
+
+ initial release ;-)
diff --git a/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.3.ebuild b/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.3.ebuild
new file mode 100644
index 000000000000..70a45f038737
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/cvm-vmailmgr-0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="CVM modules for use with vmailmgr"
+SRC_URI="http://untroubled.org/cvm-vmailmgr/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/cvm-vmailmgr/"
+
+DEPEND="virtual/glibc"
+
+RDEPEND=">=net-mail/vmailmgr-0.96.9-r1
+ >=sys-apps/ucspi-unix-0.34"
+
+src_compile() {
+ cd ${S}
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe cvm-vmailmgr cvm-vmailmgr-local cvm-vmailmgr-udp
+ dodoc README ANNOUNCEMENT NEWS
+
+ exeinto /var/lib/supervise/cvm-vmailmgr
+ newexe ${FILESDIR}/run-cvm-vmailmgr run
+
+ exeinto /var/lib/supervise/cvm-vmailmgr/log
+ newexe ${FILESDIR}/run-cvm-vmailmgr-log run
+
+ insinto /etc/vmailmgr
+ doins ${FILESDIR}/cvm-vmailmgr-socket
+
+}
+
+pkg_postinst() {
+
+ einfo "To start cvm-vmailmgr you need to link"
+ einfo "/var/lib/supervise/cvm-vmailmgr to /service"
+
+}
diff --git a/net-mail/cvm-vmailmgr/files/cvm-vmailmgr-socket b/net-mail/cvm-vmailmgr/files/cvm-vmailmgr-socket
new file mode 100644
index 000000000000..10b59ce7e3ff
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/files/cvm-vmailmgr-socket
@@ -0,0 +1 @@
+/var/lib/supervise/cvm-vmailmgr/socket \ No newline at end of file
diff --git a/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.3 b/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.3
new file mode 100644
index 000000000000..7c98735d75cf
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/files/digest-cvm-vmailmgr-0.3
@@ -0,0 +1 @@
+MD5 14e8fb4a56b84d3ffda33e89a89ab57e cvm-vmailmgr-0.3.tar.gz 53527
diff --git a/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr b/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr
new file mode 100644
index 000000000000..f81ff31c1cdb
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec cvm-vmailmgr-local `head -1 /etc/vmailmgr/cvm-vmailmgr-socket` 2>&1
diff --git a/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr-log b/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr-log
new file mode 100644
index 000000000000..7b0d79f7d938
--- /dev/null
+++ b/net-mail/cvm-vmailmgr/files/run-cvm-vmailmgr-log
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec multilog t ./main \ No newline at end of file
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
new file mode 100644
index 000000000000..2147db16a83e
--- /dev/null
+++ b/net-mail/mailfront/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/mailfront
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*mailfront-0.74 (16 Apr 2002)
+
+ 16 Apr 2002; Thilo Bangert <bangert@gentoo.org> ChangeLog:
+
+ initial release
diff --git a/net-mail/mailfront/files/digest-mailfront-0.74 b/net-mail/mailfront/files/digest-mailfront-0.74
new file mode 100644
index 000000000000..631a70ad38ba
--- /dev/null
+++ b/net-mail/mailfront/files/digest-mailfront-0.74
@@ -0,0 +1 @@
+MD5 018894b210df1a8dfb360da5e6c70ac6 mailfront-0.74.tar.gz 59096
diff --git a/net-mail/mailfront/files/run-pop3front b/net-mail/mailfront/files/run-pop3front
new file mode 100644
index 000000000000..9e594a7e7baa
--- /dev/null
+++ b/net-mail/mailfront/files/run-pop3front
@@ -0,0 +1,6 @@
+#!/bin/sh
+exec /usr/bin/softlimit -m 2000000 \
+ /usr/bin/tcpserver -v -p -x /etc/tcp.smtp.cdb \
+ 0 pop-3 /var/qmail/bin/pop3front-auth cvm-vmailmgr-local \
+ /var/qmail/bin/pop3front-maildir .maildir 2>&1
+
diff --git a/net-mail/mailfront/files/run-smtpfront b/net-mail/mailfront/files/run-smtpfront
new file mode 100644
index 000000000000..33d0e01adf18
--- /dev/null
+++ b/net-mail/mailfront/files/run-smtpfront
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+QMAILDUID=`id -u qmaild`
+NOFILESGID=`id -g qmaild`
+
+#set CVM_SASL_LOGIN and CVM_SSASL_PLAIN to the path of cvm-vmailmgr socket (/etc/vmailmgr/cvm-vmailmgr-socket
+SOCKET=`head -1 /etc/vmailmgr/cvm-vmailmgr-socket`
+
+export CVM_SASL_LOGIN=$SOCKET
+export CVM_SASL_PLAIN=$SOCKET
+
+exec /usr/bin/softlimit -m 2000000 \
+ /usr/bin/tcpserver -H -R -v -p -x /etc/tcp.smtp.cdb \
+ -u $QMAILDUID -g $NOFILESGID 0 smtp rblsmtpd /var/qmail/bin/smtpfront-qmail 2>&1
diff --git a/net-mail/mailfront/mailfront-0.74.ebuild b/net-mail/mailfront/mailfront-0.74.ebuild
new file mode 100644
index 000000000000..1635f8c272a1
--- /dev/null
+++ b/net-mail/mailfront/mailfront-0.74.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/glibc"
+
+RDEPEND="net-mail/cvm-vmailmgr
+ net-mail/qmail
+ net-mail/qmail-pop3d"
+
+DESCRIPTION="Mail server network protocol front-ends."
+SRC_URI="http://untroubled.org/mailfront/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/mailfront/"
+
+src_compile() {
+ cd ${S}
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /var/qmail/bin
+ doexe pop3front-auth pop3front-maildir smtpfront-echo smtpfront-qmail smtpfront-reject
+
+ #install new run files for qmail-smtpd and qmail-pop3
+ exeinto /var/qmail/supervise/qmail-smtpd
+ newexe ${FILESDIR}/run-smtpfront run
+
+ exeinto /var/qmail/supervise/qmail-pop3d
+ newexe ${FILESDIR}/run-pop3front run
+
+}
+
+pkg_postinst() {
+ echo -e "\e[32;01m Now you need to restart qmail-smtpd and qmail-pop3d services:\033[0m"
+ echo ' $ svc -t /service/qmail-smtpd && svc -t /service/qmail-pop3d'
+ echo
+} \ No newline at end of file
diff --git a/net-mail/qmail-vmailmgr/ChangeLog b/net-mail/qmail-vmailmgr/ChangeLog
new file mode 100644
index 000000000000..5a917a48b17f
--- /dev/null
+++ b/net-mail/qmail-vmailmgr/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/qmail-vmailmgr
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*qmail-vmailmgr-0.0.1-r1 (02 Apr 2002)
+
+ 02 Apr 2002; Thilo Bangert <bangert@gentoo.org> ChangeLog :
+
+ initial release ;-)
diff --git a/net-mail/qmail-vmailmgr/files/README b/net-mail/qmail-vmailmgr/files/README
new file mode 100644
index 000000000000..fccc25a94f87
--- /dev/null
+++ b/net-mail/qmail-vmailmgr/files/README
@@ -0,0 +1,31 @@
+make sure these links exist
+
+/var/usr/lib/supervise/cvm-vmailmgr -> /service/cvm-vmailmgr
+/var/usr/lib/supervise/vmailmgrd -> /service/vmailmgrd
+
+restart /service/smtpd
+
+restart /service/pop3d
+
+
+remove .dot-forward support from qmail-local
+/var/qmail/control/defaultdelivery
+restart /service/qmail
+
+check /etc/vmailmgr for configuration
+
+
+
+TODO
+====
+
+qmail ebuild
+============
+
+- why empty aliases?
+- why maildir for root?
+
+something wrong with qmail.ebuild config:
+Accepting relaying by default from all ips configured on this machine.
+tcprules: fatal: unable to parse this line: se:192.168.0.3:allow,RELAYCLIENT=""
+
diff --git a/net-mail/qmail-vmailmgr/files/digest-qmail-vmailmgr-0.0.1-r1 b/net-mail/qmail-vmailmgr/files/digest-qmail-vmailmgr-0.0.1-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-mail/qmail-vmailmgr/files/digest-qmail-vmailmgr-0.0.1-r1
diff --git a/net-mail/qmail-vmailmgr/qmail-vmailmgr-0.0.1-r1.ebuild b/net-mail/qmail-vmailmgr/qmail-vmailmgr-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..ac0b765a7588
--- /dev/null
+++ b/net-mail/qmail-vmailmgr/qmail-vmailmgr-0.0.1-r1.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Author: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}
+DESCRIPTION="qmail with vmailmgr - a fullfletched virtual domains hosting enviroment"
+HOMEPAGE="http://vmailmgr.org"
+
+RDEPEND=">=net-mail/qmail-1.03-r7
+>=net-mail/vmailmgr-0.96.9-r1
+>=net-mail/cvm-vmailmgr-0.3
+>=net-mail/mailfront-0.74"
diff --git a/net-mail/vmailmgr/ChangeLog b/net-mail/vmailmgr/ChangeLog
new file mode 100644
index 000000000000..ada5a0720b04
--- /dev/null
+++ b/net-mail/vmailmgr/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/vmailmgr
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*vmailmgr-0.96.9-r1 (16 Apr 2002)
+
+ 16 Apr 2002; Thilo Bangert <bangert@gentoo.org> ChangeLog :
+
+ initial release ;-)
diff --git a/net-mail/vmailmgr/files/checkvpw-loginfail b/net-mail/vmailmgr/files/checkvpw-loginfail
new file mode 100644
index 000000000000..7cad3fceb0be
--- /dev/null
+++ b/net-mail/vmailmgr/files/checkvpw-loginfail
@@ -0,0 +1,3 @@
+#!/bin/sh
+#rate limit password fails
+sleep 2
diff --git a/net-mail/vmailmgr/files/digest-vmailmgr-0.96.9-r1 b/net-mail/vmailmgr/files/digest-vmailmgr-0.96.9-r1
new file mode 100644
index 000000000000..27e6b788aa4d
--- /dev/null
+++ b/net-mail/vmailmgr/files/digest-vmailmgr-0.96.9-r1
@@ -0,0 +1 @@
+MD5 c8d2bb288eeacb799985e8af2c7101c1 vmailmgr-0.96.9.tar.gz 362379
diff --git a/net-mail/vmailmgr/files/separators b/net-mail/vmailmgr/files/separators
new file mode 100644
index 000000000000..21a4a1b13dab
--- /dev/null
+++ b/net-mail/vmailmgr/files/separators
@@ -0,0 +1 @@
+@:% \ No newline at end of file
diff --git a/net-mail/vmailmgr/files/socket-file b/net-mail/vmailmgr/files/socket-file
new file mode 100644
index 000000000000..fc6a5134c671
--- /dev/null
+++ b/net-mail/vmailmgr/files/socket-file
@@ -0,0 +1 @@
+/var/lib/supervise/vmailmgrd/socket \ No newline at end of file
diff --git a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
new file mode 100644
index 000000000000..1dcde69358c9
--- /dev/null
+++ b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="vmailmgr - virtual domains for qmail"
+SRC_URI="http://www.vmailmgr.org/current/${P}.tar.gz"
+HOMEPAGE="http://www.vmailmgr.org"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-apps/ucspi-unix-0.34
+ >=net-mail/qmail-1.03-r7
+ >=net-mail/qmail-autoresponder-0.95"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ #make sure stuff get's installed the right places
+ mv configure configure.orig
+ sed -e "s:^cgidir=.*:cgidir=\"/etc/vmailmgr/cgi-bin\":" \
+ -e "s:^phpdir=.*:phpdir=\"/etc/vmailmgr/php\":" \
+ configure.orig > configure
+ chmod ug+x configure
+}
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ #add documentation
+
+ exeinto /var/lib/supervise/vmailmgrd
+ newexe ${S}/scripts/vmailmgrd.run run
+
+ exeinto /var/lib/supervise/vmailmgrd/log
+ newexe ${S}/scripts/vmailmgrd-log.run run
+
+ exeinto /etc/vmailmgr
+ newexe ${S}/scripts/autoresponder.sh vdeliver-postdeliver
+
+ doexe ${FILESDIR}/checkvpw-loginfail
+ doexe ${FILESDIR}/socket-file
+ doexe ${FILESDIR}/separators
+
+}
+
+pkg_postinst() {
+ einfo "To start vmailmgrd you need to link"
+ einfo "/var/lib/supervise/vmailmgrd to /service"
+}