summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-01 03:17:24 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-01 03:17:24 +0000
commit888675c9bb34b676a5367a1437104f4f39ef1da4 (patch)
tree9f2ffb0bc21e0e2bdd1b456e3c79bca326b20548
parentadded debugging support (diff)
downloadgentoo-2-888675c9bb34b676a5367a1437104f4f39ef1da4.tar.gz
gentoo-2-888675c9bb34b676a5367a1437104f4f39ef1da4.tar.bz2
gentoo-2-888675c9bb34b676a5367a1437104f4f39ef1da4.zip
needed for gst-plugins xine likes it too
-rw-r--r--media-libs/libfame/ChangeLog8
-rw-r--r--media-libs/libfame/files/digest-libfame-0.9.01
-rw-r--r--media-libs/libfame/libfame-0.9.0.ebuild38
3 files changed, 46 insertions, 1 deletions
diff --git a/media-libs/libfame/ChangeLog b/media-libs/libfame/ChangeLog
index 7fdda7d59f2a..8bdf9140d659 100644
--- a/media-libs/libfame/ChangeLog
+++ b/media-libs/libfame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.2 2002/09/03 07:41:50 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.3 2002/10/01 03:17:24 lostlogic Exp $
+
+*libfame-0.9.0 (30 Sep 2002)
+
+ 30 Sep 2002; Brandon Low <lostlogic@gentoo.org) libfame-0.9.0.ebuild
+
+ Later version, needed for gst-plugins fame support.
*libfame-0.8.10 (18 July 2002)
diff --git a/media-libs/libfame/files/digest-libfame-0.9.0 b/media-libs/libfame/files/digest-libfame-0.9.0
new file mode 100644
index 000000000000..3a3a6243d56c
--- /dev/null
+++ b/media-libs/libfame/files/digest-libfame-0.9.0
@@ -0,0 +1 @@
+MD5 256d93f51820e5ec5e1ba97a67ef4d20 libfame-0.9.0.tar.gz 236651
diff --git a/media-libs/libfame/libfame-0.9.0.ebuild b/media-libs/libfame/libfame-0.9.0.ebuild
new file mode 100644
index 000000000000..feeb9ee50ee1
--- /dev/null
+++ b/media-libs/libfame/libfame-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.0.ebuild,v 1.1 2002/10/01 03:17:24 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libfame is a video encoding library. (MPEG-1 and MPEG-4)"
+SRC_URI="mirror://sourceforge/fame/${P}.tar.gz"
+HOMEPAGE="http://fame.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+
+ use mmx && myconf="${myconf} --enable-mmx"
+ use sse && myconf="${myconf} --enable-sse"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/lib
+
+ einstall install || die
+ dobin libfame-config
+
+ insinto /usr/share/aclocal
+ doins libfame.m4
+
+ dodoc CHANGES README
+ doman doc/*.3
+}