summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-09 18:47:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-09 18:47:00 +0000
commit85c563a828a9ba2924f8fa70a9be07b8e0b76cfb (patch)
tree4356dbe01edbfb39da688b3cc6cfaff8274ffa26
parentold (diff)
downloadgentoo-2-85c563a828a9ba2924f8fa70a9be07b8e0b76cfb.tar.gz
gentoo-2-85c563a828a9ba2924f8fa70a9be07b8e0b76cfb.tar.bz2
gentoo-2-85c563a828a9ba2924f8fa70a9be07b8e0b76cfb.zip
fix LDFLAGS injection #88431
(Portage version: 2.0.51.19)
-rw-r--r--app-shells/sash/sash-3.7.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-shells/sash/sash-3.7.ebuild b/app-shells/sash/sash-3.7.ebuild
index 4c80cce76a71..548042647582 100644
--- a/app-shells/sash/sash-3.7.ebuild
+++ b/app-shells/sash/sash-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.20 2005/03/13 06:01:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.21 2005/04/09 18:47:00 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -19,15 +19,15 @@ RDEPEND=""
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/sash-3.6-fix-includes.patch
- epatch ${FILESDIR}/sash-3.7-builtin.patch
- use readline && epatch ${FILESDIR}/sash-3.6-readline.patch
+ epatch "${FILESDIR}"/sash-3.6-fix-includes.patch
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+ use readline && epatch "${FILESDIR}"/sash-3.6-readline.patch
sed -i \
-e "s:-O3:${CFLAGS}:" \
- -e "/^LDFLAGS /s:$:${LDFLAGS}:" \
+ -e "/^LDFLAGS /s:$: ${LDFLAGS}:" \
Makefile || die "sed failed"
}