summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-01-31 10:58:20 +0000
committerUlrich Müller <ulm@gentoo.org>2009-01-31 10:58:20 +0000
commit85a5786d29e195a8bc5be56d5a66e4f331a6295d (patch)
treed06e9f69bbaae81d268ff670986945361a61e193
parentBumping to 2.0.3, fixing bug #256428 (diff)
downloadgentoo-2-85a5786d29e195a8bc5be56d5a66e4f331a6295d.tar.gz
gentoo-2-85a5786d29e195a8bc5be56d5a66e4f331a6295d.tar.bz2
gentoo-2-85a5786d29e195a8bc5be56d5a66e4f331a6295d.zip
Fix problem with Supercite, bug 256886.
(Portage version: 2.2_rc23/cvs/Linux i686)
-rw-r--r--app-emacs/vm/ChangeLog10
-rw-r--r--app-emacs/vm/files/vm-8.0.12-supercite-yank.patch14
-rw-r--r--app-emacs/vm/vm-8.0.12-r2.ebuild52
3 files changed, 74 insertions, 2 deletions
diff --git a/app-emacs/vm/ChangeLog b/app-emacs/vm/ChangeLog
index 59c49958dc61..b5c66e5436b1 100644
--- a/app-emacs/vm/ChangeLog
+++ b/app-emacs/vm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/vm
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.59 2008/11/09 18:24:02 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/ChangeLog,v 1.60 2009/01/31 10:58:19 ulm Exp $
+
+*vm-8.0.12-r2 (31 Jan 2009)
+
+ 31 Jan 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/vm-8.0.12-supercite-yank.patch, +vm-8.0.12-r2.ebuild:
+ Fix problem with Supercite, bug 256886.
*vm-8.0.12-r1 (09 Nov 2008)
diff --git a/app-emacs/vm/files/vm-8.0.12-supercite-yank.patch b/app-emacs/vm/files/vm-8.0.12-supercite-yank.patch
new file mode 100644
index 000000000000..596106cf7d87
--- /dev/null
+++ b/app-emacs/vm/files/vm-8.0.12-supercite-yank.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/256886
+
+--- vm-8.0.12-orig/lisp/vm-reply.el 2008-11-05 21:04:35.000000000 +0100
++++ vm-8.0.12/lisp/vm-reply.el 2009-01-30 08:10:47.000000000 +0100
+@@ -343,6 +343,9 @@
+ (vm-insert-region-from-buffer (vm-buffer-of message)
+ (vm-headers-of message)
+ (vm-text-end-of message))
++ (vm-insert-region-from-buffer (vm-buffer-of message)
++ (vm-headers-of message)
++ (vm-text-of message))
+ (vm-decode-mime-layout layout)
+ (if vm-mime-yank-attachments
+ (vm-decode-postponed-mime-message))))
diff --git a/app-emacs/vm/vm-8.0.12-r2.ebuild b/app-emacs/vm/vm-8.0.12-r2.ebuild
new file mode 100644
index 000000000000..138f3a5cd360
--- /dev/null
+++ b/app-emacs/vm/vm-8.0.12-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-8.0.12-r2.ebuild,v 1.1 2009/01/31 10:58:19 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="The VM mail reader for Emacs"
+HOMEPAGE="http://www.nongnu.org/viewmail/"
+SRC_URI="http://download.savannah.nongnu.org/releases/viewmail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bbdb ssl"
+
+DEPEND="bbdb? ( app-emacs/bbdb )"
+RDEPEND="${DEPEND}
+ ssl? ( net-misc/stunnel )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-autoload-vm-pine.patch" #246185
+ epatch "${FILESDIR}/${P}-supercite-yank.patch" #256886
+
+ if ! use bbdb; then
+ elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
+ epatch "${FILESDIR}/vm-8.0-no-pcrisis.patch"
+ fi
+
+ # fix vm-version, bug 235563
+ #sed -i -e "/^(defvar vm-version /s/nil/\"${PV}\"/" lisp/vm-version.el \
+ # || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ use bbdb && myconf="--with-other-dirs=${SITELISP}/bbdb"
+ econf --with-emacs="emacs" \
+ --with-pixmapdir="/usr/share/pixmaps/vm" \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc NEWS README TODO example.vm || die "dodoc failed"
+}