summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2003-11-02 04:33:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2003-11-02 04:33:54 +0000
commit85a0b2452bd93a7d5f96d35e06668a02776ba34a (patch)
tree80ffeb7621f80547ceb1a032f2c7ebfa7fdde9a9
parentInitial import. (diff)
downloadgentoo-2-85a0b2452bd93a7d5f96d35e06668a02776ba34a.tar.gz
gentoo-2-85a0b2452bd93a7d5f96d35e06668a02776ba34a.tar.bz2
gentoo-2-85a0b2452bd93a7d5f96d35e06668a02776ba34a.zip
Initial import.
-rw-r--r--dev-cpp/poslib/ChangeLog7
-rw-r--r--dev-cpp/poslib/Manifest4
-rw-r--r--dev-cpp/poslib/files/digest-poslib-1.0.11
-rw-r--r--dev-cpp/poslib/metadata.xml9
-rw-r--r--dev-cpp/poslib/poslib-1.0.1.ebuild26
5 files changed, 46 insertions, 1 deletions
diff --git a/dev-cpp/poslib/ChangeLog b/dev-cpp/poslib/ChangeLog
new file mode 100644
index 000000000000..ce14a1ec1e3d
--- /dev/null
+++ b/dev-cpp/poslib/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-cpp/poslib
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.1 2003/11/02 04:33:50 matsuu Exp $
+
+ 02 Nov 2003; MATSUU Takuto <matsuu@gentoo.org> poslib-1.0.1.ebuild:
+ Initial import. #26268
+
diff --git a/dev-cpp/poslib/Manifest b/dev-cpp/poslib/Manifest
index 8b4300883354..335dab3012c1 100644
--- a/dev-cpp/poslib/Manifest
+++ b/dev-cpp/poslib/Manifest
@@ -1,2 +1,4 @@
-MD5 bc0af3d93e6d69e669b3f07ca5b0461c poslib-1.0.1.ebuild 613
+MD5 db2236865a9147566b0432566c8e9d6b poslib-1.0.1.ebuild 710
+MD5 ca160035368973903394d90e1506ff21 metadata.xml 566
+MD5 81f2c5c5df7013a7dd47173648a97e0e ChangeLog 306
MD5 a27e94a708d0593be9de871130fbee66 files/digest-poslib-1.0.1 64
diff --git a/dev-cpp/poslib/files/digest-poslib-1.0.1 b/dev-cpp/poslib/files/digest-poslib-1.0.1
new file mode 100644
index 000000000000..0e001ed779cc
--- /dev/null
+++ b/dev-cpp/poslib/files/digest-poslib-1.0.1
@@ -0,0 +1 @@
+MD5 7023b9142f89266762418283bac6df7b poslib-1.0.1.tar.gz 292970
diff --git a/dev-cpp/poslib/metadata.xml b/dev-cpp/poslib/metadata.xml
new file mode 100644
index 000000000000..1aee163b7e33
--- /dev/null
+++ b/dev-cpp/poslib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription>Poslib is a C++ library for people who want to write applications that make use of the Domain Name System. It consists of a client part, that can be used to send DNS queries, interpret Resource Records, and read master files, among other thins, and a server part which makes writing a DNS server much easier.</longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/poslib/poslib-1.0.1.ebuild b/dev-cpp/poslib/poslib-1.0.1.ebuild
new file mode 100644
index 000000000000..ccf16bbf253e
--- /dev/null
+++ b/dev-cpp/poslib/poslib-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/poslib-1.0.1.ebuild,v 1.1 2003/11/02 04:33:51 matsuu Exp $
+
+DESCRIPTION="A library for creating C++ programs using the Domain Name System"
+HOMEPAGE="http://www.posadis.org/projects/poslib.php"
+SRC_URI="mirror://sourceforge/posadis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf \
+ --with-cxxflags="${CXXFLAGS} -funsigned-char" \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}