summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-29 20:43:11 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-29 20:43:11 +0000
commit8569bf1cd88b1579d6a37018782d17a55cf3b2c5 (patch)
treed019bc34b32f5a816ef010c377f17146e4a4f47f
parentDepend on firmware, warn if wireless extensions are disabled. (diff)
downloadgentoo-2-8569bf1cd88b1579d6a37018782d17a55cf3b2c5.tar.gz
gentoo-2-8569bf1cd88b1579d6a37018782d17a55cf3b2c5.tar.bz2
gentoo-2-8569bf1cd88b1579d6a37018782d17a55cf3b2c5.zip
Version bump with a lot of bugfixes, minimum cmake required version is 2.6 now, drop 'debug' USE flag as there is no need now to filter Werror/Wall CFLAGS, add dotnet support, build tests only when needed, fix CFLAGS/CXXFLAGS/LDFLAGS parsing.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--net-libs/libproxy/ChangeLog10
-rw-r--r--net-libs/libproxy/libproxy-0.4.6.ebuild88
2 files changed, 97 insertions, 1 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 70e292787709..3ec61511cf53 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.38 2010/08/16 20:46:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.39 2010/09/29 20:43:11 pacho Exp $
+
+*libproxy-0.4.6 (29 Sep 2010)
+
+ 29 Sep 2010; Pacho Ramos <pacho@gentoo.org> +libproxy-0.4.6.ebuild:
+ Version bump with a lot of bugfixes, minimum cmake required version is 2.6
+ now, drop 'debug' USE flag as there is no need now to filter Werror/Wall
+ CFLAGS, add dotnet support, build tests only when needed, fix
+ CFLAGS/CXXFLAGS/LDFLAGS parsing.
16 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> libproxy-0.4.2.ebuild,
+files/libproxy-0.4.2-glibc212.patch:
diff --git a/net-libs/libproxy/libproxy-0.4.6.ebuild b/net-libs/libproxy/libproxy-0.4.6.ebuild
new file mode 100644
index 000000000000..e4a4ca4cc86c
--- /dev/null
+++ b/net-libs/libproxy/libproxy-0.4.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6.ebuild,v 1.1 2010/09/29 20:43:11 pacho Exp $
+
+EAPI="2"
+CMAKE_MIN_VERSION="2.6"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit cmake-utils eutils multilib python portability
+
+DESCRIPTION="Library for automatic proxy configuration management"
+HOMEPAGE="http://code.google.com/p/libproxy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome kde mono networkmanager perl python test vala webkit xulrunner"
+
+RDEPEND="
+ gnome? ( gnome-base/gconf )
+ kde? ( >=kde-base/kdelibs-4.3 )
+ mono? ( dev-lang/mono )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( dev-lang/perl )
+ vala? ( dev-lang/vala )
+ webkit? ( net-libs/webkit-gtk )
+ xulrunner? ( >=net-libs/xulrunner-1.9.1:1.9 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ base_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.4.2-glibc212.patch
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DPERL_VENDORINSTALL=ON
+ -DCMAKE_C_FLAGS="${CFLAGS}"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
+ $(cmake-utils_use_with gnome GNOME)
+ $(cmake-utils_use_with kde KDE4)
+ $(cmake-utils_use_with mono DOTNET)
+ $(cmake-utils_use_with networkmanager NM)
+ $(cmake-utils_use_with perl PERL)
+ $(cmake-utils_use_with python PYTHON)
+ $(cmake-utils_use_with vala VALA)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with xulrunner MOZJS)
+ $(cmake-utils_use test BUILD_TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ # Prevent access violation when building with mono support
+ export MONO_SHARED_DIR="${T}/shared"
+ cmake-utils_src_compile
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libproxy.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libproxy.so.0
+
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/${PN}.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup $(python_get_sitedir)/${PN}.py
+ fi
+}