summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-06-07 15:33:00 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-06-07 15:33:00 +0000
commit84c052b6d30e42618dc9ea94d27d200e6646e84a (patch)
tree8474b0fb76773f20accdef20c9aa4bacb1dd8f79
parentnew version, fixes bug# 51522 (thanks to j. <merkaba@quantumfish.com>) (Manif... (diff)
downloadgentoo-2-84c052b6d30e42618dc9ea94d27d200e6646e84a.tar.gz
gentoo-2-84c052b6d30e42618dc9ea94d27d200e6646e84a.tar.bz2
gentoo-2-84c052b6d30e42618dc9ea94d27d200e6646e84a.zip
fixes bug #52340, thanks to Matteo Bertini <veb@freemail.it>
-rw-r--r--net-mail/quotient/ChangeLog6
-rw-r--r--net-mail/quotient/quotient-0.9.1.ebuild22
2 files changed, 23 insertions, 5 deletions
diff --git a/net-mail/quotient/ChangeLog b/net-mail/quotient/ChangeLog
index 6ba6eb8406e2..6df946fc0b45 100644
--- a/net-mail/quotient/ChangeLog
+++ b/net-mail/quotient/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/quotient
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/quotient/ChangeLog,v 1.3 2004/06/07 15:05:21 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/quotient/ChangeLog,v 1.4 2004/06/07 15:33:00 lordvan Exp $
+
+ 07 Jun 2004; Thomas Raschbacher <lordvan@gentoo.org> quotient-0.9.1.ebuild:
+ fixes bug #52340, thanks to Matteo Bertini <veb@freemail.it>
+ bin/* installed to docs dir because of conflict
*quotient-0.9.1 (07 Jun 2004)
diff --git a/net-mail/quotient/quotient-0.9.1.ebuild b/net-mail/quotient/quotient-0.9.1.ebuild
index b8836f5e2024..b6c9bf183828 100644
--- a/net-mail/quotient/quotient-0.9.1.ebuild
+++ b/net-mail/quotient/quotient-0.9.1.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/quotient/quotient-0.9.1.ebuild,v 1.1 2004/06/07 15:05:21 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/quotient/quotient-0.9.1.ebuild,v 1.2 2004/06/07 15:33:00 lordvan Exp $
inherit distutils
MY_PN="Quotient"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Quotient is an open source product that combines a multi-protocol messaging server with tools for information management and retrieval. Quotient brings together your email, IM/IRC and IP telephony."
-HOMEPAGE="http://www.divmod.org/Home/Projects/Quotient/index.html"
-#SRC_URI="mirror://sourceforge/divmod/${MY_P}.tar.gz"
+HOMEPAGE="http://www.divmod.org/Home/Projects/Quotient/"
SRC_URI="http://www.divmod.org/users/release/divmod/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -17,9 +16,24 @@ KEYWORDS="~x86"
IUSE="gtk gtk2 doc"
DEPEND=">=dev-python/twisted-1.3.0
- >=mail-filter/spambayes-1.0_alpha9
+ >=mail-filter/spambayes-1.0_rc1
>=dev-python/Imaging-1.1.4
>=dev-python/lupy-0.2.1
>=dev-python/nevow-0.2.0"
S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/* || die "doc/* failed"
+ #dobin bin/* || die "bin/* failed" ---> conflict with "porthole"
+ insinto /usr/share/doc/${P}/bin || die "bin failed"
+ doins bin/* || die "bin/* failed"
+ insinto /usr/share/doc/${P}/tools || die "tools failed"
+ doins tools/* || die "tools/* failed"
+ insinto /usr/share/doc/${P}/tools/agi || die "tools/agi failed"
+ doins tools/agi/* || die "tools/agi/* failed"
+ insinto /usr/share/doc/${P}/admin || die "admin failed"
+ doins admin/* || die "admin/* failed"
+}
+