summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-11-29 09:43:20 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-11-29 09:43:20 +0000
commit836592729f5dfc2bcddb71b243aa3ee3eb94829e (patch)
tree5764d588ef69439f69d78fb02814388f4d2734b4
parentNew version (Manifest recommit) (diff)
downloadgentoo-2-836592729f5dfc2bcddb71b243aa3ee3eb94829e.tar.gz
gentoo-2-836592729f5dfc2bcddb71b243aa3ee3eb94829e.tar.bz2
gentoo-2-836592729f5dfc2bcddb71b243aa3ee3eb94829e.zip
Added a patch to the conf to honor the arts USE flag. Fixes bug #72567.
-rw-r--r--media-video/kavi2svcd/ChangeLog7
-rw-r--r--media-video/kavi2svcd/files/kavi2svcd-0.8.2-configure-arts.patch141
-rw-r--r--media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild4
3 files changed, 150 insertions, 2 deletions
diff --git a/media-video/kavi2svcd/ChangeLog b/media-video/kavi2svcd/ChangeLog
index c1579e2ddcbc..eb5b03d7a7c0 100644
--- a/media-video/kavi2svcd/ChangeLog
+++ b/media-video/kavi2svcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/kavi2svcd
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kavi2svcd/ChangeLog,v 1.6 2004/07/03 21:53:29 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kavi2svcd/ChangeLog,v 1.7 2004/11/29 09:43:20 motaboy Exp $
+
+ 29 Nov 2004; Simone Gotti <motaboy@gentoo.org>
+ +files/kavi2svcd-0.8.2-configure-arts.patch, kavi2svcd-0.8.2.ebuild:
+ Added a patch to the configure script to honor the arts USE flag. Fixes bug
+ #72567.
03 Jul 2004; Carsten Lohrke <carlo@gentoo.org> kavi2svcd-0.8.2.ebuild:
QA: need-kde after R/DEPEND, missing sed dependency
diff --git a/media-video/kavi2svcd/files/kavi2svcd-0.8.2-configure-arts.patch b/media-video/kavi2svcd/files/kavi2svcd-0.8.2-configure-arts.patch
new file mode 100644
index 000000000000..34377763cc22
--- /dev/null
+++ b/media-video/kavi2svcd/files/kavi2svcd-0.8.2-configure-arts.patch
@@ -0,0 +1,141 @@
+--- configure.orig 2004-11-26 19:48:09.498570072 +0000
++++ configure 2004-11-26 19:49:56.050371736 +0000
+@@ -23694,138 +23694,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild b/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild
index b868ebeae0e1..f3f351c7d81c 100644
--- a/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild
+++ b/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild,v 1.8 2004/07/14 21:45:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kavi2svcd/kavi2svcd-0.8.2.ebuild,v 1.9 2004/11/29 09:43:20 motaboy Exp $
inherit kde
@@ -23,4 +23,6 @@ need-kde 3
src_unpack() {
kde_src_unpack
sed -i 's:;;$:;:' ${S}/kavi2svcd/{prefclass,vcdclass}.h
+
+ use arts || epatch ${FILESDIR}/${P}-configure-arts.patch
}