summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-10-27 15:18:49 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-10-27 15:18:49 +0000
commit8329683848242b72dfeb5c1f735a73735c10dbb6 (patch)
tree049ece31b6b84409d569c4f66391e1df5178fe5d
parentVersion bump, bug #150863. (diff)
downloadgentoo-2-8329683848242b72dfeb5c1f735a73735c10dbb6.tar.gz
gentoo-2-8329683848242b72dfeb5c1f735a73735c10dbb6.tar.bz2
gentoo-2-8329683848242b72dfeb5c1f735a73735c10dbb6.zip
Version bump
(Portage version: 2.1.2_pre1)
-rw-r--r--www-apps/twiki/ChangeLog8
-rw-r--r--www-apps/twiki/files/digest-twiki-4.0.53
-rw-r--r--www-apps/twiki/twiki-4.0.5.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/www-apps/twiki/ChangeLog b/www-apps/twiki/ChangeLog
index 0b4585e0d80d..839ae1a01012 100644
--- a/www-apps/twiki/ChangeLog
+++ b/www-apps/twiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/twiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.37 2006/09/12 03:41:29 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.38 2006/10/27 15:18:49 rl03 Exp $
+
+*twiki-4.0.5 (27 Oct 2006)
+
+ 27 Oct 2006; Renat Lumpau <rl03@gentoo.org> -twiki-4.0.4-r2.ebuild,
+ +twiki-4.0.5.ebuild:
+ Version bump
*twiki-4.0.4-r2 (12 Sep 2006)
diff --git a/www-apps/twiki/files/digest-twiki-4.0.5 b/www-apps/twiki/files/digest-twiki-4.0.5
new file mode 100644
index 000000000000..8f8a216a02a1
--- /dev/null
+++ b/www-apps/twiki/files/digest-twiki-4.0.5
@@ -0,0 +1,3 @@
+MD5 d984b90886c12601b76f51419bb5352b TWiki-4.0.5.tgz 4264148
+RMD160 c1c81b6489bb88a1dfff3fb6bfe6d1838f132172 TWiki-4.0.5.tgz 4264148
+SHA256 cbe97bd965e13940a6f9aa496c0c2657d42bf900dd8d0bdcf8b4e866d090dc8f TWiki-4.0.5.tgz 4264148
diff --git a/www-apps/twiki/twiki-4.0.5.ebuild b/www-apps/twiki/twiki-4.0.5.ebuild
new file mode 100644
index 000000000000..8fcc83f71209
--- /dev/null
+++ b/www-apps/twiki/twiki-4.0.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/twiki-4.0.5.ebuild,v 1.1 2006/10/27 15:18:49 rl03 Exp $
+
+inherit webapp eutils
+
+MY_PN="TWiki"
+
+DESCRIPTION="A Web Based Collaboration Platform"
+HOMEPAGE="http://twiki.org/"
+SRC_URI="http://twiki.org/p/pub/Codev/Release/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="apache2"
+
+S=${WORKDIR}
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=app-text/rcs-5.7
+ sys-apps/diffutils
+ dev-perl/Algorithm-Diff
+ >=virtual/perl-CGI-3.20
+ perl-core/File-Spec
+ dev-perl/Text-Diff
+ perl-core/Time-Local
+ dev-perl/CGI-Session
+ perl-core/digest-base
+ dev-perl/Digest-SHA1
+ dev-perl/locale-maketext-lexicon
+ virtual/perl-libnet
+ dev-perl/URI
+ virtual/cron
+ dev-perl/HTML-Parser
+ apache2? ( >=net-www/apache-2.0.54 )
+ !apache2? ( =net-www/apache-1* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv ${S}/bin/LocalLib.cfg.txt ${S}/bin/LocalLib.cfg
+ mv ${S}/lib/LocalSite.cfg.txt ${S}/lib/LocalSite.cfg
+ # change web user to apache
+ cd ${S}/lib/TWiki
+ find . -name '*,v' -exec sed -i 's|nobody:|apache:|g' '{}' ';'
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -r . ${D}/${MY_HTDOCSDIR}
+
+ dodoc readme.txt
+ dohtml T*.html
+
+ for file in $(find data pub) lib/LocalSite.cfg; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ for a in bin/setlib.cfg bin/LocalLib.cfg lib/TWiki.cfg lib/LocalSite.cfg; do
+ webapp_configfile ${MY_HTDOCSDIR}/${a}
+ done
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postupgrade_txt en ${FILESDIR}/postupgrade-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version of TWiki, back up your"
+ ewarn "data/ and pub/ directories and any local changes before upgrading!"
+ ewarn
+ ewarn "You are _strongly_ encouraged to to read the upgrade guide:"
+ ewarn "http://twiki.org/cgi-bin/view/TWiki/TWikiDocumentation"
+ ewarn
+ elog "webapp-config will not be run automatically"
+ elog "Run webapp-config -I -h <host> -d ${PN} ${PN} ${PVR} to install"
+ elog
+ # webapp_pkg_postinst
+}