summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-05-05 18:22:24 +0000
committerFabian Groffen <grobian@gentoo.org>2012-05-05 18:22:24 +0000
commit8249ccb0547bb06a12a7e0aec91875768acc9c70 (patch)
tree056027fee050cbfc00b21c176f42a004e682cc67
parentEliminate another duplicate slash. (diff)
downloadgentoo-2-8249ccb0547bb06a12a7e0aec91875768acc9c70.tar.gz
gentoo-2-8249ccb0547bb06a12a7e0aec91875768acc9c70.tar.bz2
gentoo-2-8249ccb0547bb06a12a7e0aec91875768acc9c70.zip
Fixed for Prefix, keyworded for *-solaris
(Portage version: 2.2.01.20366-prefix/cvs/SunOS i386)
-rw-r--r--dev-libs/libelf/ChangeLog6
-rw-r--r--dev-libs/libelf/files/libelf-0.8.13-build.patch2
-rw-r--r--dev-libs/libelf/libelf-0.8.13-r1.ebuild16
3 files changed, 15 insertions, 9 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index 23dcd4ce1860..538528db91c6 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libelf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.36 2012/04/26 14:06:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.37 2012/05/05 18:22:24 grobian Exp $
+
+ 05 May 2012; Fabian Groffen <grobian@gentoo.org>
+ files/libelf-0.8.13-build.patch, libelf-0.8.13-r1.ebuild:
+ Fixed for Prefix, keyworded for *-solaris
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> libelf-0.8.13-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-libs/libelf/files/libelf-0.8.13-build.patch b/dev-libs/libelf/files/libelf-0.8.13-build.patch
index 57173d6138a2..7e0cce6384d9 100644
--- a/dev-libs/libelf/files/libelf-0.8.13-build.patch
+++ b/dev-libs/libelf/files/libelf-0.8.13-build.patch
@@ -7,7 +7,7 @@ Index: libelf-0.8.13/aclocal.m4
AC_PATH_PROG(LD, ld, ld)
case "$host" in
- *-linux*|*-gnu*)
-+ *-linux*|*-gnu*|*-freebsd*)
++ *-linux*|*-gnu*|*-freebsd*|*-solaris*)
if test "$GCC" = yes; then
mr_TARGET_ELF
if test "$mr_cv_target_elf" = yes; then
diff --git a/dev-libs/libelf/libelf-0.8.13-r1.ebuild b/dev-libs/libelf/libelf-0.8.13-r1.ebuild
index a24356130d65..992b39568b49 100644
--- a/dev-libs/libelf/libelf-0.8.13-r1.ebuild
+++ b/dev-libs/libelf/libelf-0.8.13-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.13-r1.ebuild,v 1.8 2012/04/26 14:06:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.13-r1.ebuild,v 1.9 2012/05/05 18:22:24 grobian Exp $
+
+EAPI="3"
-EAPI=2
inherit eutils multilib autotools
DESCRIPTION="A ELF object file access library"
@@ -11,7 +12,7 @@ SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 hppa ppc sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug nls elibc_FreeBSD"
RDEPEND="!dev-libs/elfutils"
@@ -37,13 +38,14 @@ src_configure() {
src_install() {
emake \
- prefix="${D}usr" \
- libdir="${D}usr/$(get_libdir)" \
+ prefix="${ED}usr" \
+ libdir="${ED}usr/$(get_libdir)" \
install \
- install-compat || die
+ install-compat \
+ -j1 || die
dodoc ChangeLog README || die
# Stop libelf from stamping on the system nlist.h
- use elibc_FreeBSD && rm "${D}"/usr/include/nlist.h
+ use elibc_FreeBSD && rm "${ED}"/usr/include/nlist.h
}