summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-05-10 10:20:54 +0000
committerMichael Weber <xmw@gentoo.org>2011-05-10 10:20:54 +0000
commit8220b6dcd3a28ea7b707bf9f5337adec1cd09d4d (patch)
tree3f94a7297238138868ed66542360be0c03606081
parentVersion bump (diff)
downloadgentoo-2-8220b6dcd3a28ea7b707bf9f5337adec1cd09d4d.tar.gz
gentoo-2-8220b6dcd3a28ea7b707bf9f5337adec1cd09d4d.tar.bz2
gentoo-2-8220b6dcd3a28ea7b707bf9f5337adec1cd09d4d.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-lang/mmix/ChangeLog10
-rw-r--r--dev-lang/mmix/files/mmix-20110420-makefile.patch71
-rw-r--r--dev-lang/mmix/mmix-20100311.ebuild6
-rw-r--r--dev-lang/mmix/mmix-20110420.ebuild44
4 files changed, 126 insertions, 5 deletions
diff --git a/dev-lang/mmix/ChangeLog b/dev-lang/mmix/ChangeLog
index a1c711b94308..c94ec2f21f63 100644
--- a/dev-lang/mmix/ChangeLog
+++ b/dev-lang/mmix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mmix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/ChangeLog,v 1.17 2010/09/18 01:38:42 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/ChangeLog,v 1.18 2011/05/10 10:20:54 xmw Exp $
+
+*mmix-20110420 (10 May 2011)
+
+ 10 May 2011; Michael Weber <xmw@gentoo.org> mmix-20100311.ebuild,
+ +mmix-20110420.ebuild, +files/mmix-20110420-makefile.patch:
+ Version bump
*mmix-20100311 (18 Sep 2010)
*mmix-20060324-r1 (18 Sep 2010)
diff --git a/dev-lang/mmix/files/mmix-20110420-makefile.patch b/dev-lang/mmix/files/mmix-20110420-makefile.patch
new file mode 100644
index 000000000000..f531cfa33610
--- /dev/null
+++ b/dev-lang/mmix/files/mmix-20110420-makefile.patch
@@ -0,0 +1,71 @@
+--- /var/tmp/portage/dev-lang/mmix-20110420/work/Makefile 2011-03-30 01:47:08.000000000 +0200
++++ /tmp/Makefile 2011-05-10 12:16:32.752503223 +0200
+@@ -27,23 +27,23 @@
+ if test -r $*.ch; then cweave $*.w $*.ch; else cweave $*.w; fi
+
+ .w.o:
+- make $*.c
+- make $*.o
++ $(MAKE) $*.c
++ $(MAKE) $*.o
+
+ .w:
+- make $*.c
+- make $*
++ $(MAKE) $*.c
++ $(MAKE) $*
+
+ .w.dvi:
+- make $*.tex
+- make $*.dvi
++ $(MAKE) $*.tex
++ $(MAKE) $*.dvi
+
+ .w.ps:
+- make $*.dvi
+- make $*.ps
++ $(MAKE) $*.dvi
++ $(MAKE) $*.ps
+
+ .w.pdf:
+- make $*.tex
++ $(MAKE) $*.tex
+ case "$(PDFTEX)" in \
+ dvipdfm ) tex "\let\pdf+ \input $*"; dvipdfm $* ;; \
+ pdftex ) pdftex $* ;; \
+@@ -73,27 +73,26 @@
+ clean:
+ rm -f *~ *.o *.c *.h *.tex *.log *.dvi *.toc *.idx *.scn *.ps core
+
+-mmix-pipe.o: mmix-pipe.c abstime
++abstime.h: abstime
+ ./abstime > abstime.h
++
++mmix-pipe.o: mmix-pipe.c abstime abstime.h
+ $(CC) $(CFLAGS) -c mmix-pipe.c
+- rm abstime.h
+
+ mmix-config.o: mmix-pipe.o
+
+ mmmix: mmix-arith.o mmix-pipe.o mmix-config.o mmix-mem.o mmix-io.o mmmix.c
+- $(CC) $(CFLAGS) mmmix.c \
++ $(CC) $(CFLAGS) $(LDFLAGS) mmmix.c \
+ mmix-arith.o mmix-pipe.o mmix-config.o mmix-mem.o mmix-io.o -o mmmix
+
+ mmixal: mmix-arith.o mmixal.c
+- $(CC) $(CFLAGS) mmixal.c mmix-arith.o -o mmixal
++ $(CC) $(CFLAGS) $(LDFLAGS) mmixal.c mmix-arith.o -o mmixal
+
+-mmix: mmix-arith.o mmix-io.o mmix-sim.c abstime
+- ./abstime > abstime.h
+- $(CC) $(CFLAGS) mmix-sim.c mmix-arith.o mmix-io.o -o mmix
+- rm abstime.h
++mmix: mmix-arith.o mmix-io.o mmix-sim.c abstime abstime.h
++ $(CC) $(CFLAGS) $(LDFLAGS) mmix-sim.c mmix-arith.o mmix-io.o -o mmix
+
+ mmotype: mmotype.c
+- $(CC) $(CFLAGS) mmotype.c -o mmotype
++ $(CC) $(CFLAGS) $(LDFLAGS) mmotype.c -o mmotype
+
+ tarfile: $(ALL)
+ tar cvf /tmp/mmix.tar $(ALL)
diff --git a/dev-lang/mmix/mmix-20100311.ebuild b/dev-lang/mmix/mmix-20100311.ebuild
index f27f8a8dfb5d..73ec8b08c00b 100644
--- a/dev-lang/mmix/mmix-20100311.ebuild
+++ b/dev-lang/mmix/mmix-20100311.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20100311.ebuild,v 1.1 2010/09/18 01:38:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20100311.ebuild,v 1.2 2011/05/10 10:20:54 xmw Exp $
EAPI="2"
@@ -15,7 +15,7 @@ RDEPEND=""
SLOT="0"
LICENSE="mmix"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc"
S="${WORKDIR}"
diff --git a/dev-lang/mmix/mmix-20110420.ebuild b/dev-lang/mmix/mmix-20110420.ebuild
new file mode 100644
index 000000000000..bcff3b22baf6
--- /dev/null
+++ b/dev-lang/mmix/mmix-20110420.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20110420.ebuild,v 1.1 2011/05/10 10:20:54 xmw Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator."
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
+SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/${P}.tar.gz"
+
+DEPEND="|| ( >=dev-util/cweb-3.63 virtual/tex-base )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="mmix"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake all \
+ CFLAGS="${CFLAGS}" \
+ CC=$(tc-getCC) \
+ || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install () {
+ dobin mmix mmixal mmmix mmotype abstime || die
+ dodoc README mmix.1 || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins *.ps || die
+ fi
+}