summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-08-25 16:47:50 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-08-25 16:47:50 +0000
commit8133817614d151401edd0ec578bd6d331989b17c (patch)
tree87d4cc632788706e471a6ace83e29aa53a3bd22f
parentUpdate ebuild to fix sandbox violation during install phase. Fixes bug 380397... (diff)
downloadgentoo-2-8133817614d151401edd0ec578bd6d331989b17c.tar.gz
gentoo-2-8133817614d151401edd0ec578bd6d331989b17c.tar.bz2
gentoo-2-8133817614d151401edd0ec578bd6d331989b17c.zip
Remove automagic dependency on virtual/jpeg and sci-libs/hdf. Simplify logic since we don't provide h4toh5
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--sci-misc/h5utils/ChangeLog10
-rw-r--r--sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch63
-rw-r--r--sci-misc/h5utils/h5utils-1.12.1-r2.ebuild (renamed from sci-misc/h5utils/h5utils-1.12.1-r1.ebuild)23
-rw-r--r--sci-misc/h5utils/metadata.xml1
4 files changed, 92 insertions, 5 deletions
diff --git a/sci-misc/h5utils/ChangeLog b/sci-misc/h5utils/ChangeLog
index acea4b0fb6fe..893590242491 100644
--- a/sci-misc/h5utils/ChangeLog
+++ b/sci-misc/h5utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-misc/h5utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/h5utils/ChangeLog,v 1.12 2011/08/25 15:57:24 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/h5utils/ChangeLog,v 1.13 2011/08/25 16:47:50 xarthisius Exp $
+
+*h5utils-1.12.1-r2 (25 Aug 2011)
+
+ 25 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ -h5utils-1.12.1-r1.ebuild, +h5utils-1.12.1-r2.ebuild,
+ +files/h5utils-1.12.1-automagic.patch:
+ Remove automagic dependency on virtual/jpeg and sci-libs/hdf. Simplify logic
+ since we don't provide h4toh5
*h5utils-1.12.1-r1 (25 Aug 2011)
diff --git a/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch b/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch
new file mode 100644
index 000000000000..8de8580cfe38
--- /dev/null
+++ b/sci-misc/h5utils/files/h5utils-1.12.1-automagic.patch
@@ -0,0 +1,63 @@
+--- configure.ac
++++ configure.ac
+@@ -74,44 +74,23 @@
+
+ ###########################################################################
+
+-# Only build h5fromh4 if we are using a version of HDF5 prior to 1.4, and
+-# thus don't have the superior h4toh5 utility. Similarly for h5toh4.
+-AC_CHECK_PROG(H4TOH5, h4toh5, h4toh5)
+-AC_CHECK_PROG(H5TOH4, h5toh4, h5toh4)
+-
+-AC_ARG_WITH(hdf4,
+- [AC_HELP_STRING([--with-hdf4], [build hdf4 utils even if h4toh5 and h5toh4 are present])],
+- ok=$withval, ok=maybe)
+-if test "x$ok" = xyes; then
+- H4TOH5=""
+- H5TOH4=""
+-elif test "x$ok" = xno; then
+- H4TOH5="h4toh5"
+- H5TOH4="h5toh4"
+-fi
+-
+-HDF4=no
+-if test "x$H4TOH5" != xh4toh5 -o "x$H5TOH4" != xh5toh4; then
+- AC_CHECK_LIB(jpeg, jpeg_start_compress,
+- [AC_CHECK_LIB(df, DFSDgetdata,
+- [H4_LIBS="-ldf -ljpeg"; HDF4=yes],
+- [AC_MSG_WARN([can't find libdf (HDF4): won't be able to compile h5fromh4 or h4fromh5])], -ljpeg)],
+- [AC_MSG_WARN([can't find libjpeg: won't be able to compile h5fromh4 or h4fromh5])])
+-
+- if test $HDF4 = yes; then
+- if test "x$H4TOH5" != xh4toh5; then
+- MORE_H5UTILS="h5fromh4\$(EXEEXT) $MORE_H5UTILS"
+- MORE_H5UTILS_MANS="h5fromh4.1 $MORE_H5UTILS_MANS"
+- fi
+- if test "x$H5TOH4" != xh5toh4; then
+- MORE_H5UTILS="h4fromh5\$(EXEEXT) $MORE_H5UTILS"
+- # MORE_H5UTILS_MANS="h4fromh5.1 $MORE_H5UTILS_MANS"
+- fi
+- fi
+-fi
+-AC_CHECK_HEADERS(hdf.h hdf/hdf.h)
++AC_ARG_WITH([hdf], AS_HELP_STRING([--with-hdf], [build hdf4 utils even if h4toh5 and h5toh4 are present]))
+
+-AC_SUBST(H4_LIBS)
++AS_IF([test "x$with_hdf" = "xyes"], [
++ AC_CHECK_HEADERS(hdf.h hdf/hdf.h)
++ AC_CHECK_LIB(jpeg, jpeg_start_compress,
++ [AC_CHECK_LIB(df, DFSDgetdata,
++ [H4_LIBS="-ldf -ljpeg"; HDF4=yes],
++ [AC_MSG_WARN([can't find libdf (HDF4): won't be able to compile h5fromh4 or h4fromh5])], -ljpeg)],
++ [AC_MSG_WARN([can't find libjpeg: won't be able to compile h5fromh4 or h4fromh5])])
++ if test $HDF4 = yes; then
++ MORE_H5UTILS="h5fromh4\$(EXEEXT) $MORE_H5UTILS"
++ MORE_H5UTILS_MANS="h5fromh4.1 $MORE_H5UTILS_MANS"
++ MORE_H5UTILS="h4fromh5\$(EXEEXT) $MORE_H5UTILS"
++ fi
++
++ AC_SUBST(H4_LIBS)
++])
+
+ ###########################################################################
+
diff --git a/sci-misc/h5utils/h5utils-1.12.1-r1.ebuild b/sci-misc/h5utils/h5utils-1.12.1-r2.ebuild
index 53aa7c2d923a..b9497503360f 100644
--- a/sci-misc/h5utils/h5utils-1.12.1-r1.ebuild
+++ b/sci-misc/h5utils/h5utils-1.12.1-r2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/h5utils/h5utils-1.12.1-r1.ebuild,v 1.1 2011/08/25 15:57:24 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/h5utils/h5utils-1.12.1-r2.ebuild,v 1.1 2011/08/25 16:47:50 xarthisius Exp $
EAPI=4
+inherit autotools eutils
+
DESCRIPTION="utilities for visualization and conversion of HDF5 files"
HOMEPAGE="http://ab-initio.mit.edu/h5utils/"
SRC_URI="http://ab-initio.mit.edu/h5utils/${P}.tar.gz"
@@ -11,14 +13,27 @@ SRC_URI="http://ab-initio.mit.edu/h5utils/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="octave"
+IUSE="hdf octave"
SLOT="0"
-DEPEND="sci-libs/hdf5"
+DEPEND="media-libs/libpng
+ sci-libs/hdf5
+ hdf? (
+ sci-libs/hdf
+ virtual/jpeg
+ )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic.patch
+ eautoreconf
+}
+
src_configure() {
- econf $(use_with octave) --without-v5d
+ econf \
+ --without-v5d \
+ $(use_with octave) \
+ $(use_with hdf)
}
src_install() {
diff --git a/sci-misc/h5utils/metadata.xml b/sci-misc/h5utils/metadata.xml
index ed8298ef88d2..35866ea57d98 100644
--- a/sci-misc/h5utils/metadata.xml
+++ b/sci-misc/h5utils/metadata.xml
@@ -4,5 +4,6 @@
<herd>sci</herd>
<use>
<flag name='octave'>Build Octave plugins</flag>
+ <flag name='hdf'>Build hdf to hdf5 (and vice-versa) converter</flag>
</use>
</pkgmetadata>