summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-02-26 10:23:01 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-02-26 10:23:01 +0000
commit80e7d7b681d46d407781af9d8cfece86df9f2dfe (patch)
tree3c587b3855abc2c994a1a404f9fa87ae0bc974fe
parentRevert udev-rules to match also parent-devices (using ATTRS), Bug #166492. (diff)
downloadgentoo-2-80e7d7b681d46d407781af9d8cfece86df9f2dfe.tar.gz
gentoo-2-80e7d7b681d46d407781af9d8cfece86df9f2dfe.tar.bz2
gentoo-2-80e7d7b681d46d407781af9d8cfece86df9f2dfe.zip
Bug 166960, version bump. Thanks Chaze
(Portage version: 2.1.2-r9)
-rw-r--r--net-analyzer/nikto/ChangeLog7
-rw-r--r--net-analyzer/nikto/files/digest-nikto-1.363
-rw-r--r--net-analyzer/nikto/nikto-1.36.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/nikto/ChangeLog b/net-analyzer/nikto/ChangeLog
index b2af15f422fa..cf1acc65a3d9 100644
--- a/net-analyzer/nikto/ChangeLog
+++ b/net-analyzer/nikto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nikto
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.16 2007/02/09 08:04:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.17 2007/02/26 10:23:01 mcummings Exp $
+
+*nikto-1.36 (26 Feb 2007)
+
+ 26 Feb 2007; Michael Cummings <mcummings@gentoo.org> +nikto-1.36.ebuild:
+ Bug 166960, version bump. Thanks Chaze
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-analyzer/nikto/files/digest-nikto-1.36 b/net-analyzer/nikto/files/digest-nikto-1.36
new file mode 100644
index 000000000000..c79da753b472
--- /dev/null
+++ b/net-analyzer/nikto/files/digest-nikto-1.36
@@ -0,0 +1,3 @@
+MD5 bda93904a3ffa42cb6f392e8222ca477 nikto-1.36.tar.gz 206921
+RMD160 29aa7008a065ae5a2b39bc72f72fbddbc2665a51 nikto-1.36.tar.gz 206921
+SHA256 a5c7f10e73b3ab9d262732a1377902589a7cde268666db892cc59f4b00e1bedc nikto-1.36.tar.gz 206921
diff --git a/net-analyzer/nikto/nikto-1.36.ebuild b/net-analyzer/nikto/nikto-1.36.ebuild
new file mode 100644
index 000000000000..e29467cbf39a
--- /dev/null
+++ b/net-analyzer/nikto/nikto-1.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-1.36.ebuild,v 1.1 2007/02/26 10:23:01 mcummings Exp $
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/source/nikto/ARCHIVE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+RDEPEND="dev-lang/perl
+ >=net-analyzer/nmap-3.00
+ ssl? ( dev-libs/openssl )"
+IUSE="ssl"
+
+src_compile() {
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:\$CFG{configfile}="nikto.conf":\$CFG{configfile}="/etc/nikto/nikto.conf":' \
+ nikto.pl
+
+ mv config.txt nikto.conf
+
+ sed -i -e 's:^#NMAP:NMAP:' \
+ -i -e 's:^PROXYHOST:#PROXYHOST:' \
+ -i -e 's:^PROXYPORT:#PROXYPORT:' \
+ -i -e 's:^PROXYUSER:#PROXYUSER:' \
+ -i -e 's:^PROXYPASS:#PROXYPASS:' \
+ -i -e 's:# PLUGINDIR=/usr/local/nikto/plugins:PLUGINDIR=/usr/share/nikto/plugins:' \
+ nikto.conf
+
+ cp ${S}/docs/nikto-1.34.man ${WORKDIR}/${PN}.1
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ doins plugins/*
+
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt README_plugins.txt nikto_usage.txt
+ dohtml nikto_usage.html
+ doman ${WORKDIR}/${PN}.1
+}