summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-01 09:01:19 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-01 09:01:19 +0000
commit80e2affc8b4771b01191949e85e600dc8fb7e5ca (patch)
tree2288d8f3ac869a51f4d9bf1210f3d008235af39f
parentVersion bump. (diff)
downloadgentoo-2-80e2affc8b4771b01191949e85e600dc8fb7e5ca.tar.gz
gentoo-2-80e2affc8b4771b01191949e85e600dc8fb7e5ca.tar.bz2
gentoo-2-80e2affc8b4771b01191949e85e600dc8fb7e5ca.zip
Create new revision for ruby19. Drop old versions and remove ruby19 from fully keyworded version due to missing dependencies.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rcairo/ChangeLog15
-rw-r--r--dev-ruby/rcairo/rcairo-1.10.0-r4.ebuild84
-rw-r--r--dev-ruby/rcairo/rcairo-1.10.2-r1.ebuild (renamed from dev-ruby/rcairo/rcairo-1.10.1.ebuild)10
-rw-r--r--dev-ruby/rcairo/rcairo-1.10.2.ebuild6
4 files changed, 21 insertions, 94 deletions
diff --git a/dev-ruby/rcairo/ChangeLog b/dev-ruby/rcairo/ChangeLog
index ad7565460126..c0cc20359fad 100644
--- a/dev-ruby/rcairo/ChangeLog
+++ b/dev-ruby/rcairo/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-ruby/rcairo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.68 2011/12/04 14:07:44 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.69 2012/01/01 09:01:19 graaff Exp $
+
+*rcairo-1.10.2-r1 (01 Jan 2012)
+
+ 01 Jan 2012; Hans de Graaff <graaff@gentoo.org> -rcairo-1.10.0-r4.ebuild,
+ -rcairo-1.10.1.ebuild, rcairo-1.10.2.ebuild, +rcairo-1.10.2-r1.ebuild:
+ Create new revision for ruby19. Drop old versions and remove ruby19 from
+ fully keyworded version due to missing dependencies.
+
+ 31 Dec 2011; Hans de Graaff <graaff@gentoo.org> -rcairo-1.10.0-r4.ebuild,
+ -rcairo-1.10.1.ebuild:
+ Remove old versions.
04 Dec 2011; Raúl Porcel <armin76@gentoo.org> rcairo-1.10.2.ebuild:
Add ~alpha/~ia64/~sparc wrt #391759
diff --git a/dev-ruby/rcairo/rcairo-1.10.0-r4.ebuild b/dev-ruby/rcairo/rcairo-1.10.0-r4.ebuild
deleted file mode 100644
index c2a1e0f14b90..000000000000
--- a/dev-ruby/rcairo/rcairo-1.10.0-r4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.0-r4.ebuild,v 1.2 2011/09/18 13:21:26 flameeyes Exp $
-
-EAPI=2
-
-# jruby → cannot work, it's a compiled extension
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_NAME="cairo"
-
-# Documentation depends on files that are not distributed.
-RUBY_FAKEGEM_TASK_DOC=""
-
-# Depends on test-unit-2 which is currently masked.
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Ruby bindings for cairo"
-HOMEPAGE="http://cairographics.org/rcairo/"
-
-IUSE=""
-
-SLOT="0"
-LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-
-RDEPEND="${RDEPEND}
- >=x11-libs/cairo-1.2.0[svg]"
-DEPEND="${DEPEND}
- >=x11-libs/cairo-1.2.0[svg]
- dev-util/pkgconfig"
-
-ruby_add_bdepend "
- dev-ruby/ruby-glib2
- test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
-
-all_ruby_prepare() {
- # Remove a failing test for the new recording surface. It's not
- # clear if this is a test failure or not, but we need to move on
- # with cairo 1.10.
- rm test/test_recording_surface.rb || die
-
- # We don't need pkg-config since we compile directly so remove
- # metadata because otherwise rubygems or bundler may get confused.
- rm ../metadata || die
-}
-
-each_ruby_configure() {
- ${RUBY} extconf.rb || die "extconf failed"
-}
-
-each_ruby_compile() {
- emake || die "make failed"
-
- # again, try to make it more standard, to install it more easily.
- cp ext/cairo/cairo$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- # don't rely on the Rakefile because it's a mess to load with
- # their hierarchy, do it manually.
- ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
- -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- insinto $(ruby_get_hdrdir)
- doins ext/cairo/rb_cairo.h || die "Cannot install header file."
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/samples
- doins -r samples/* || die "Cannot install sample files."
-}
diff --git a/dev-ruby/rcairo/rcairo-1.10.1.ebuild b/dev-ruby/rcairo/rcairo-1.10.2-r1.ebuild
index 8464821304ad..4e9461a6fd35 100644
--- a/dev-ruby/rcairo/rcairo-1.10.1.ebuild
+++ b/dev-ruby/rcairo/rcairo-1.10.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.1.ebuild,v 1.1 2011/10/30 10:39:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.2-r1.ebuild,v 1.1 2012/01/01 09:01:19 graaff Exp $
EAPI=2
@@ -28,15 +28,15 @@ IUSE=""
SLOT="0"
LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
RDEPEND="${RDEPEND}
>=x11-libs/cairo-1.2.0[svg]"
DEPEND="${DEPEND}
- >=x11-libs/cairo-1.2.0[svg]
- dev-util/pkgconfig"
+ >=x11-libs/cairo-1.2.0[svg]"
ruby_add_bdepend "
+ dev-ruby/pkg-config
dev-ruby/ruby-glib2
test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
diff --git a/dev-ruby/rcairo/rcairo-1.10.2.ebuild b/dev-ruby/rcairo/rcairo-1.10.2.ebuild
index a4c84c794c95..34182aeaff48 100644
--- a/dev-ruby/rcairo/rcairo-1.10.2.ebuild
+++ b/dev-ruby/rcairo/rcairo-1.10.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.2.ebuild,v 1.2 2011/12/04 14:07:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.2.ebuild,v 1.3 2012/01/01 09:01:19 graaff Exp $
EAPI=2
# jruby → cannot work, it's a compiled extension
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18"
RUBY_FAKEGEM_NAME="cairo"