summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-07-04 14:35:37 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-07-04 14:35:37 +0000
commit8005968e042bc755d1d1044136cb73db859ea09f (patch)
tree7973d39518a5ce47a918ca1a797b11a752034132
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-8005968e042bc755d1d1044136cb73db859ea09f.tar.gz
gentoo-2-8005968e042bc755d1d1044136cb73db859ea09f.tar.bz2
gentoo-2-8005968e042bc755d1d1044136cb73db859ea09f.zip
bump libglade to 2.6.1
(Portage version: 2.1.3_rc6)
-rw-r--r--gnome-base/libglade/ChangeLog10
-rw-r--r--gnome-base/libglade/files/digest-libglade-2.6.13
-rw-r--r--gnome-base/libglade/libglade-2.6.1.ebuild52
3 files changed, 64 insertions, 1 deletions
diff --git a/gnome-base/libglade/ChangeLog b/gnome-base/libglade/ChangeLog
index 8ff7318275ae..4cc913ec8bb3 100644
--- a/gnome-base/libglade/ChangeLog
+++ b/gnome-base/libglade/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/libglade
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.94 2007/05/27 05:29:47 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/ChangeLog,v 1.95 2007/07/04 14:35:37 eva Exp $
+
+*libglade-2.6.1 (04 Jul 2007)
+
+ 04 Jul 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ +libglade-2.6.1.ebuild:
+ bump to 2.6.1
+ - Added glade_xml_construct_from_buffer(), for language
+ bindings. (Douglas C. MacKenzie)
27 May 2007; Joshua Kinard <kumba@gentoo.org> libglade-2.6.0.ebuild:
Stable on mips.
diff --git a/gnome-base/libglade/files/digest-libglade-2.6.1 b/gnome-base/libglade/files/digest-libglade-2.6.1
new file mode 100644
index 000000000000..c7c07874d236
--- /dev/null
+++ b/gnome-base/libglade/files/digest-libglade-2.6.1
@@ -0,0 +1,3 @@
+MD5 489be887b26b9973f77e2c6111ab7d5a libglade-2.6.1.tar.bz2 346536
+RMD160 74c546e68c479f59b3100c6e267592d91539dcef libglade-2.6.1.tar.bz2 346536
+SHA256 94c33ffe748c849021358c1e9f758c1fd5f1abda00ba6776975837f42c730cf2 libglade-2.6.1.tar.bz2 346536
diff --git a/gnome-base/libglade/libglade-2.6.1.ebuild b/gnome-base/libglade/libglade-2.6.1.ebuild
new file mode 100644
index 000000000000..fa9163130fb6
--- /dev/null
+++ b/gnome-base/libglade/libglade-2.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.6.1.ebuild,v 1.1 2007/07/04 14:35:37 eva Exp $
+
+# FIXME : catalog stuff
+inherit eutils gnome2
+
+DESCRIPTION="Library to construct graphical interfaces at runtime"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.10
+ >=dev-libs/atk-1.9
+ >=dev-libs/libxml2-2.4.10
+ >=dev-lang/python-2.0-r7"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_compile() {
+ # patch to stop make install installing the xml catalog
+ # because we do it ourselves in postinst()
+ epatch "${FILESDIR}"/Makefile.in.am-2.4.2-xmlcatalog.patch
+
+ gnome2_src_compile
+}
+
+src_install() {
+ dodir /etc/xml
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ echo ">>> Updating XML catalog"
+ /usr/bin/xmlcatalog --noout --add "system" \
+ "http://glade.gnome.org/glade-2.0.dtd" \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ echo ">>> removing entries from the XML catalog"
+ /usr/bin/xmlcatalog --noout --del \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+}