summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-26 16:35:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-26 16:35:39 +0000
commit7f81d8c893a789ffaf65ea82266036d8c5dc342b (patch)
tree6b77abdbd4e3af9d76a48f32f2b96ceb0a3aa7bb
parentDelete older ebuild. (diff)
downloadgentoo-2-7f81d8c893a789ffaf65ea82266036d8c5dc342b.tar.gz
gentoo-2-7f81d8c893a789ffaf65ea82266036d8c5dc342b.tar.bz2
gentoo-2-7f81d8c893a789ffaf65ea82266036d8c5dc342b.zip
Fix build with sys-libs/db-5.0, bug #349778 by me.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
-rw-r--r--net-proxy/c-icap/ChangeLog6
-rw-r--r--net-proxy/c-icap/c-icap-0.1.3.ebuild3
-rw-r--r--net-proxy/c-icap/files/c-icap-0.1.3+db-5.0.patch13
3 files changed, 20 insertions, 2 deletions
diff --git a/net-proxy/c-icap/ChangeLog b/net-proxy/c-icap/ChangeLog
index 869f9b0df8b9..90669b5e90e6 100644
--- a/net-proxy/c-icap/ChangeLog
+++ b/net-proxy/c-icap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/c-icap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.2 2010/12/12 15:40:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.3 2010/12/26 16:35:39 flameeyes Exp $
+
+ 26 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> c-icap-0.1.3.ebuild,
+ +files/c-icap-0.1.3+db-5.0.patch:
+ Fix build with sys-libs/db-5.0, bug #349778 by me.
12 Dec 2010; Christian Faulhammer <fauli@gentoo.org> c-icap-0.1.3.ebuild:
keyworded ~arch for x86, bug 346439
diff --git a/net-proxy/c-icap/c-icap-0.1.3.ebuild b/net-proxy/c-icap/c-icap-0.1.3.ebuild
index 6a21257148f7..34593741a996 100644
--- a/net-proxy/c-icap/c-icap-0.1.3.ebuild
+++ b/net-proxy/c-icap/c-icap-0.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/c-icap-0.1.3.ebuild,v 1.2 2010/12/12 15:40:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/c-icap-0.1.3.ebuild,v 1.3 2010/12/26 16:35:39 flameeyes Exp $
EAPI=2
@@ -28,6 +28,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}/${P}-asneeded.patch"
epatch "${FILESDIR}/${P}-implicit.patch"
+ epatch "${FILESDIR}/${P}+db-5.0.patch"
eautoreconf
}
diff --git a/net-proxy/c-icap/files/c-icap-0.1.3+db-5.0.patch b/net-proxy/c-icap/files/c-icap-0.1.3+db-5.0.patch
new file mode 100644
index 000000000000..6be5fafb2311
--- /dev/null
+++ b/net-proxy/c-icap/files/c-icap-0.1.3+db-5.0.patch
@@ -0,0 +1,13 @@
+Index: c_icap-0.1.3/modules/bdb_tables.c
+===================================================================
+--- c_icap-0.1.3.orig/modules/bdb_tables.c
++++ c_icap-0.1.3/modules/bdb_tables.c
+@@ -108,7 +108,7 @@ int bdb_table_do_real_open(struct ci_loo
+ }
+
+
+-#if(DB_VERSION_MINOR>=1)
++#if (DB_VERSION_MAJOR > 4) || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
+ if ((ret = dbdata->db->open( dbdata->db, NULL, table->path, NULL,
+ DB_BTREE, DB_RDONLY|DB_THREAD, 0)) != 0) {
+ #else