summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-04 18:03:13 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-04 18:03:13 +0000
commit7f28f24cf1f8b09f2c688f01c7c2f16c09f1ab93 (patch)
tree0d46a123db96a59c5bf0e6d4447133e34f803a71
parentFix breakage with >=sci-libs-4.8.0. See http://www.mail-archive.com/xastir-de... (diff)
downloadgentoo-2-7f28f24cf1f8b09f2c688f01c7c2f16c09f1ab93.tar.gz
gentoo-2-7f28f24cf1f8b09f2c688f01c7c2f16c09f1ab93.tar.bz2
gentoo-2-7f28f24cf1f8b09f2c688f01c7c2f16c09f1ab93.zip
Update x32 syscall table.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
-rw-r--r--dev-util/strace/ChangeLog6
-rw-r--r--dev-util/strace/files/strace-4.7-x32.patch89
-rw-r--r--dev-util/strace/strace-4.7.ebuild3
3 files changed, 96 insertions, 2 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index c719c8e32eb5..f188459dd502 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.176 2012/05/13 19:47:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.177 2012/06/04 18:03:13 vapier Exp $
+
+ 04 Jun 2012; Mike Frysinger <vapier@gentoo.org> +files/strace-4.7-x32.patch,
+ strace-4.7.ebuild:
+ Update x32 syscall table.
13 May 2012; Mike Frysinger <vapier@gentoo.org>
+files/strace-4.7-glibc-2.15.patch, strace-4.7.ebuild:
diff --git a/dev-util/strace/files/strace-4.7-x32.patch b/dev-util/strace/files/strace-4.7-x32.patch
new file mode 100644
index 000000000000..4a7a3db41682
--- /dev/null
+++ b/dev-util/strace/files/strace-4.7-x32.patch
@@ -0,0 +1,89 @@
+From 364ed4f14c5edb5ddbc79c72d22498219033b29d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 4 Jun 2012 13:19:42 -0400
+Subject: [PATCH] x32: update syscall table
+
+This syncs with the syscall table as it is in linux 3.4.
+
+* linux/x32/syscallent.h (59): Fix comment typo.
+(78): Add missing getdents entry.
+(174): Delete create_module entry (not in the kernel).
+(181, 182, 183, 184, 185): Add missing entries.
+(524, 536, 539, 540): Fix spacing.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ linux/x32/syscallent.h | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/linux/x32/syscallent.h b/linux/x32/syscallent.h
+index fcb6a23..ee4c4ce 100644
+--- a/linux/x32/syscallent.h
++++ b/linux/x32/syscallent.h
+@@ -57,7 +57,7 @@
+ { 5, TP, sys_clone, "clone" }, /* 56 */
+ { 0, TP, sys_fork, "fork" }, /* 57 */
+ { 0, TP, sys_vfork, "vfork" }, /* 58 */
+- { }, /* 47 */
++ { }, /* 59 */
+ { 1, TP, sys_exit, "_exit" }, /* 60 */
+ { 4, TP, sys_wait4, "wait4" }, /* 61 */
+ { 2, TS, sys_kill, "kill" }, /* 62 */
+@@ -76,7 +76,7 @@
+ { 1, TD, sys_fdatasync, "fdatasync" }, /* 75 */
+ { 2, TF, sys_truncate, "truncate" }, /* 76 */
+ { 2, TD, sys_ftruncate, "ftruncate" }, /* 77 */
+- { }, /* 78 */
++ { 3, TD, sys_getdents, "getdents" }, /* 78 */
+ { 2, TF, sys_getcwd, "getcwd" }, /* 79 */
+ { 1, TF, sys_chdir, "chdir" }, /* 80 */
+ { 1, TD, sys_fchdir, "fchdir" }, /* 81 */
+@@ -172,18 +172,18 @@
+ { 2, 0, sys_setdomainname, "setdomainname" }, /* 171 */
+ { 1, 0, sys_iopl, "iopl" }, /* 172 */
+ { 3, 0, sys_ioperm, "ioperm" }, /* 173 */
+- { 2, 0, sys_create_module, "create_module" }, /* 174 */
++ { }, /* 174 */
+ { 3, 0, sys_init_module, "init_module" }, /* 175 */
+ { 2, 0, sys_delete_module, "delete_module" }, /* 176 */
+ { }, /* 177 */
+ { }, /* 178 */
+ { 4, 0, sys_quotactl, "quotactl" }, /* 179 */
+ { }, /* 180 */
+- { }, /* 181 */
+- { }, /* 182 */
+- { }, /* 183 */
+- { }, /* 184 */
+- { }, /* 185 */
++ { 5, 0, sys_getpmsg, "getpmsg" }, /* 181 */
++ { 5, 0, sys_putpmsg, "putpmsg" }, /* 182 */
++ { 5, 0, sys_afs_syscall, "afs_syscall" }, /* 183 */
++ { 3, 0, sys_tuxcall, "tuxcall" }, /* 184 */
++ { 3, 0, sys_security, "security" }, /* 185 */
+ { 0, 0, sys_gettid, "gettid" }, /* 186 */
+ { 4, TD, sys_readahead, "readahead" }, /* 187 */
+ { 5, TF, sys_setxattr, "setxattr" }, /* 188 */
+@@ -325,7 +325,7 @@
+ { 4, 0, sys_ptrace, "ptrace" }, /* 521 */
+ { 2, TS, sys_rt_sigpending, "rt_sigpending" }, /* 522 */
+ { 4, TS, sys_rt_sigtimedwait, "rt_sigtimedwait" }, /* 523 */
+- { 3, TS, sys_rt_sigqueueinfo, "rt_sigqueueinfo" }, /* 524 */
++ { 3, TS, sys_rt_sigqueueinfo, "rt_sigqueueinfo" }, /* 524 */
+ { 2, TS, sys_sigaltstack, "sigaltstack" }, /* 525 */
+ { 3, 0, sys_timer_create, "timer_create" }, /* 526 */
+ { 2, 0, sys_mq_notify, "mq_notify" }, /* 527 */
+@@ -337,8 +337,8 @@
+ { 6, 0, sys_move_pages, "move_pages" }, /* 533 */
+ { 5, TD, sys_preadv, "preadv" }, /* 534 */
+ { 5, TD, sys_pwritev, "pwritev" }, /* 535 */
+- { 4, TP|TS, sys_rt_tgsigqueueinfo, "rt_tgsigqueueinfo"}, /* 536 */
++ { 4, TP|TS, sys_rt_tgsigqueueinfo, "rt_tgsigqueueinfo" }, /* 536 */
+ { 5, TN, sys_recvmmsg, "recvmmsg" }, /* 537 */
+ { 4, TN, sys_sendmmsg, "sendmmsg" }, /* 538 */
+- { 6, 0, sys_process_vm_readv, "process_vm_readv"}, /* 539 */
+- { 6, 0, sys_process_vm_writev, "process_vm_writev"}, /* 540 */
++ { 6, 0, sys_process_vm_readv, "process_vm_readv" }, /* 539 */
++ { 6, 0, sys_process_vm_writev, "process_vm_writev" }, /* 540 */
+--
+1.7.9.7
+
diff --git a/dev-util/strace/strace-4.7.ebuild b/dev-util/strace/strace-4.7.ebuild
index 86659664de04..1d063a681c39 100644
--- a/dev-util/strace/strace-4.7.ebuild
+++ b/dev-util/strace/strace-4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.7.ebuild,v 1.2 2012/05/13 19:47:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.7.ebuild,v 1.3 2012/06/04 18:03:13 vapier Exp $
EAPI="4"
@@ -34,6 +34,7 @@ src_prepare() {
fi
epatch "${FILESDIR}"/${P}-glibc-2.15.patch #414637
+ epatch "${FILESDIR}"/${P}-x32.patch
filter-lfs-flags # configure handles this sanely
use static && append-ldflags -static