summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-04-10 19:27:37 +0000
committerUlrich Müller <ulm@gentoo.org>2012-04-10 19:27:37 +0000
commit7eb59d863962d06a493b9906c844be1010467bc3 (patch)
treef2281b0e090d2c7a816c746523426be8b6f2cf56
parentVersion bump. (diff)
downloadgentoo-2-7eb59d863962d06a493b9906c844be1010467bc3.tar.gz
gentoo-2-7eb59d863962d06a493b9906c844be1010467bc3.tar.bz2
gentoo-2-7eb59d863962d06a493b9906c844be1010467bc3.zip
Update Unicode file to version 6.1.0.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
-rw-r--r--sys-apps/miscfiles/ChangeLog9
-rw-r--r--sys-apps/miscfiles/miscfiles-1.5-r1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-apps/miscfiles/ChangeLog b/sys-apps/miscfiles/ChangeLog
index 5756b603e33a..505c218f0f1d 100644
--- a/sys-apps/miscfiles/ChangeLog
+++ b/sys-apps/miscfiles/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/miscfiles
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/miscfiles/ChangeLog,v 1.38 2010/12/29 17:40:14 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/miscfiles/ChangeLog,v 1.39 2012/04/10 19:27:37 ulm Exp $
+
+*miscfiles-1.5-r1 (10 Apr 2012)
+
+ 10 Apr 2012; Ulrich Müller <ulm@gentoo.org> +miscfiles-1.5-r1.ebuild:
+ Update Unicode file to version 6.1.0 (with permission from vapier).
29 Dec 2010; Ulrich Mueller <ulm@gentoo.org> miscfiles-1.5.ebuild:
Add build-time dependency on xz-utils, bug 346091.
diff --git a/sys-apps/miscfiles/miscfiles-1.5-r1.ebuild b/sys-apps/miscfiles/miscfiles-1.5-r1.ebuild
new file mode 100644
index 000000000000..a7f44916e985
--- /dev/null
+++ b/sys-apps/miscfiles/miscfiles-1.5-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/miscfiles/miscfiles-1.5-r1.ebuild,v 1.1 2012/04/10 19:27:37 ulm Exp $
+
+EAPI="3"
+
+UNI_PV=6.1.0
+DESCRIPTION="Miscellaneous files"
+HOMEPAGE="http://savannah.gnu.org/projects/miscfiles/"
+# http://www.unicode.org/Public/${UNI_PV}/ucd/UnicodeData.txt
+SRC_URI="mirror://gnu/miscfiles/${P}.tar.gz
+ mirror://gentoo/UnicodeData-${UNI_PV}.txt.xz"
+
+LICENSE="GPL-2 unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="minimal"
+
+# Collides with older versions/revisions
+RDEPEND="!<sys-freebsd/freebsd-share-7.2-r1"
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ mv "${WORKDIR}"/UnicodeData-${UNI_PV}.txt unicode || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/usr/share/misc
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc NEWS ORIGIN README dict-README
+
+ # not sure if this is still needed ...
+ dodir /usr/share/dict
+ cd "${ED}"/usr/share/misc
+ mv $(awk '$1=="dictfiles"{$1="";$2="";print}' "${S}"/Makefile) ../dict/ || die
+ cd ../dict
+ ln -s web2 words || die
+ ln -s web2a extra.words || die
+
+ if use minimal ; then
+ cd "${ED}"/usr/share/dict
+ rm -f words extra.words
+ gzip -9 *
+ ln -s web2.gz words
+ ln -s web2a.gz extra.words
+ ln -s connectives{.gz,}
+ ln -s propernames{.gz,}
+ cd ..
+ rm -r misc rfc
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] && type -P create-cracklib-dict >/dev/null ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+}