summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-21 08:03:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-21 08:03:55 +0000
commit7d204e470bd85c443ef19bbfdf063f790707b7e2 (patch)
tree46bc2e3355f90533665185a10dde7b701bac3248
parentSilence repoman. (diff)
downloadgentoo-2-7d204e470bd85c443ef19bbfdf063f790707b7e2.tar.gz
gentoo-2-7d204e470bd85c443ef19bbfdf063f790707b7e2.tar.bz2
gentoo-2-7d204e470bd85c443ef19bbfdf063f790707b7e2.zip
Bump for #416807
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
-rw-r--r--dev-python/routes/ChangeLog9
-rw-r--r--dev-python/routes/routes-1.13.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/routes/ChangeLog b/dev-python/routes/ChangeLog
index e490f57ce5e5..c89bd072b5f4 100644
--- a/dev-python/routes/ChangeLog
+++ b/dev-python/routes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/routes
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.11 2010/12/18 19:53:08 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.12 2012/05/21 08:03:55 patrick Exp $
+
+*routes-1.13 (21 May 2012)
+
+ 21 May 2012; Patrick Lauer <patrick@gentoo.org> +routes-1.13.ebuild:
+ Bump for #416807
18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-routes-1.11.ebuild:
diff --git a/dev-python/routes/routes-1.13.ebuild b/dev-python/routes/routes-1.13.ebuild
new file mode 100644
index 000000000000..03c5db60d38d
--- /dev/null
+++ b/dev-python/routes/routes-1.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.13.ebuild,v 1.1 2012/05/21 08:03:54 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions."
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools
+ dev-python/webob
+ dev-python/repoze-lru
+ test? ( dev-python/coverage
+ dev-python/webtest )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ cd docs/_build/html
+ docinto html
+ cp -R [a-z]* _images _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ fi
+} \ No newline at end of file