summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-15 11:45:29 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-15 11:45:29 +0000
commit7ae5fbcdaf0ce2368e3441d8a5cd3550a4047e3f (patch)
tree46c6c8a2ef257001ddd77af609c55f806108510f
parentVersion bump, bug #220577, thank Conrad Kostecki for report. Don't build test... (diff)
downloadgentoo-2-7ae5fbcdaf0ce2368e3441d8a5cd3550a4047e3f.tar.gz
gentoo-2-7ae5fbcdaf0ce2368e3441d8a5cd3550a4047e3f.tar.bz2
gentoo-2-7ae5fbcdaf0ce2368e3441d8a5cd3550a4047e3f.zip
Drop installation of OLD tk.h headers, bug #255590, thank Nathan Brink for report.
(Portage version: 2.2_rc23/cvs/Linux i686)
-rw-r--r--app-dicts/wordnet/ChangeLog10
-rw-r--r--app-dicts/wordnet/wordnet-3.0-r3.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/app-dicts/wordnet/ChangeLog b/app-dicts/wordnet/ChangeLog
index 6b68a54fd681..c407cedabf2a 100644
--- a/app-dicts/wordnet/ChangeLog
+++ b/app-dicts/wordnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/wordnet
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.18 2008/12/16 00:48:25 pva Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.19 2009/03/15 11:45:29 pva Exp $
+
+*wordnet-3.0-r3 (15 Mar 2009)
+
+ 15 Mar 2009; Peter Volkov <pva@gentoo.org> +wordnet-3.0-r3.ebuild:
+ Drop installation of OLD tk.h headers, bug #255590, thank Nathan Brink for
+ report.
16 Dec 2008; Peter Volkov <pva@gentoo.org> -wordnet-3.0.ebuild,
wordnet-3.0-r2.ebuild:
diff --git a/app-dicts/wordnet/wordnet-3.0-r3.ebuild b/app-dicts/wordnet/wordnet-3.0-r3.ebuild
new file mode 100644
index 000000000000..da56abaa0615
--- /dev/null
+++ b/app-dicts/wordnet/wordnet-3.0-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r3.ebuild,v 1.1 2009/03/15 11:45:29 pva Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="A lexical database for the English language"
+HOMEPAGE="http://wordnet.princeton.edu/"
+SRC_URI="ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PV}/WordNet-${PV}.tar.gz
+ mirror://gentoo/${P}-patchset-1.tar.bz2"
+LICENSE="Princeton"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+# In contrast to what the configure script seems to imply, Tcl/Tk is NOT optional.
+# cf. bug 163478 for details. (Yes, it's about 2.1 but it's still the same here.)
+DEPEND="dev-lang/tcl
+ dev-lang/tk"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/WordNet-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Don't install into PREFIX/dict but PREFIX/share/wordnet/dict
+ epatch "${WORKDIR}/${P}-dict-location.patch"
+ # Fixes bug 130024, make an additional shared lib
+ epatch "${WORKDIR}/${P}-shared-lib.patch"
+ # Don't install the docs directly into PREFIX/doc but PREFIX/doc/PN
+ epatch "${WORKDIR}/${P}-docs-path.patch"
+ epatch "${WORKDIR}"/${P}-CVE-2008-3908.patch #211491
+ epatch "${WORKDIR}"/${P}-CVE-2008-2149.patch #211491
+
+ # Don't install all the extra docs (html, pdf, ps) without doc USE flag.
+ use doc || sed -i -e "s:SUBDIRS =.*:SUBDIRS = man:" doc/Makefile.am
+
+ # Drop installation of OLD tk.h headers #255590
+ sed '/^SUBDIRS/d' -i include/Makefile.am
+ sed 's: include/tk/Makefile::' -i configure.ac
+ rm -rf include/tk/
+
+ rm -f configure
+ eautoreconf
+}
+
+src_compile() {
+ append-flags -DUNIX -I${T}/usr/include
+
+ PLATFORM=linux WN_ROOT="${T}/usr" \
+ WN_DICTDIR="${T}/usr/share/wordnet/dict" \
+ WN_MANDIR="${T}/usr/share/man" \
+ WN_DOCDIR="${T}/usr/share/doc/wordnet-${PV}" \
+ WNHOME="/usr/share/wordnet" \
+ econf
+ emake -e || die "emake Failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL README || die "dodoc failed"
+}