summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-30 06:28:51 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-30 06:28:51 +0000
commit7ac38b59b0598a9325cfe074c9ff7560af9c707a (patch)
treea8081b4942c7d9133cadea1a042ead0c009bdc99
parentrm old (diff)
downloadgentoo-2-7ac38b59b0598a9325cfe074c9ff7560af9c707a.tar.gz
gentoo-2-7ac38b59b0598a9325cfe074c9ff7560af9c707a.tar.bz2
gentoo-2-7ac38b59b0598a9325cfe074c9ff7560af9c707a.zip
New package by me.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--sys-apps/salinfo/ChangeLog9
-rw-r--r--sys-apps/salinfo/files/salinfo-1.2-build.patch47
-rw-r--r--sys-apps/salinfo/metadata.xml5
-rw-r--r--sys-apps/salinfo/salinfo-1.2.ebuild29
4 files changed, 90 insertions, 0 deletions
diff --git a/sys-apps/salinfo/ChangeLog b/sys-apps/salinfo/ChangeLog
new file mode 100644
index 000000000000..a1a018d4a053
--- /dev/null
+++ b/sys-apps/salinfo/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/salinfo
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/salinfo/ChangeLog,v 1.1 2014/03/30 06:28:51 vapier Exp $
+
+*salinfo-1.2 (30 Mar 2014)
+
+ 30 Mar 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/salinfo-1.2-build.patch, +metadata.xml, +salinfo-1.2.ebuild:
+ New package by me.
diff --git a/sys-apps/salinfo/files/salinfo-1.2-build.patch b/sys-apps/salinfo/files/salinfo-1.2-build.patch
new file mode 100644
index 000000000000..848b363939af
--- /dev/null
+++ b/sys-apps/salinfo/files/salinfo-1.2-build.patch
@@ -0,0 +1,47 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,4 @@
++prefix = $(DESTDIR)
+ mandir := /usr/share/man
+ sbindir := /usr/sbin
+ logdir := /var/log/salinfo
+@@ -5,7 +6,7 @@ initdir := /etc/rc.d/init.d
+ sysconfigdir := /etc/sysconfig
+ logrotate := /etc/logrotate.d
+
+-CFLAGS += -Wall -g -O2 $(EXTRA_CFLAGS)
++CFLAGS += -Wall $(EXTRA_CFLAGS)
+ export CFLAGS
+
+ ifneq ($(VPATH),)
+--- a/sal.h
++++ b/sal.h
+@@ -27,6 +27,8 @@
+ * Keith Owens <kaos@sgi.com>
+ */
+
++#include <asm/fpu.h>
++
+ #include "efi.h"
+ #include "pal.h"
+
+--- a/salinfo_decode.c
++++ b/salinfo_decode.c
+@@ -303,7 +303,7 @@ log_dropped_records(void)
+ snprintf(line, sizeof(line), ", %d %s",
+ dropped_all[i]->dropped, dropped_all[i]->name);
+ dropped_all[i]->dropped = 0;
+- strncat(log, line, sizeof(log));
++ strncat(log, line, sizeof(log) - strlen(log));
+ }
+ }
+ syslog(LOG_NOTICE, "%s", log);
+@@ -424,7 +424,7 @@ talk_to_sal (void)
+ int fd;
+ char filename[PATH_MAX];
+ snprintf(filename, sizeof(filename), "%s/%s/.check", directory, rd[i]);
+- if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC)) < 0) {
++ if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC, 0644)) < 0) {
+ perror(filename);
+ goto out;
+ }
diff --git a/sys-apps/salinfo/metadata.xml b/sys-apps/salinfo/metadata.xml
new file mode 100644
index 000000000000..fe15722775f2
--- /dev/null
+++ b/sys-apps/salinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ia64</herd>
+</pkgmetadata>
diff --git a/sys-apps/salinfo/salinfo-1.2.ebuild b/sys-apps/salinfo/salinfo-1.2.ebuild
new file mode 100644
index 000000000000..bc42bc3690b9
--- /dev/null
+++ b/sys-apps/salinfo/salinfo-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/salinfo/salinfo-1.2.ebuild,v 1.1 2014/03/30 06:28:51 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="decode Itanium SAL records (e.g. various hardware errors)"
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/people/helgaas/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/etc/{rc.d,sysconfig} "${ED}"/var || die
+}