summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-05-29 19:36:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-05-29 19:36:57 +0000
commit79e7c636981b59faef12f4963f4a9073059f6973 (patch)
tree429bada511b68e197a909f094824915922ff3f48
parentMake FEATURES=-userpriv test non-fatal during pkg_setup, as portage always ru... (diff)
downloadgentoo-2-79e7c636981b59faef12f4963f4a9073059f6973.tar.gz
gentoo-2-79e7c636981b59faef12f4963f4a9073059f6973.tar.bz2
gentoo-2-79e7c636981b59faef12f4963f4a9073059f6973.zip
Convert all all FEATURES=userpriv tests to be UID -eq 0 to make Paludis et al happy.
(Portage version: 2.1.5.2)
-rw-r--r--dev-db/mysql/ChangeLog10
-rw-r--r--dev-db/mysql/mysql-5.0.26-r2.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.32.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.34.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.38.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.40.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.42.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.44-r1.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.44-r2.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.44.ebuild6
-rw-r--r--dev-db/mysql/mysql-5.0.54.ebuild4
-rw-r--r--dev-db/mysql/mysql-5.0.56.ebuild4
-rw-r--r--dev-db/mysql/mysql-5.0.60.ebuild6
13 files changed, 43 insertions, 35 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 4eb739434ecb..636726a552f1 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.450 2008/05/29 05:51:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.451 2008/05/29 19:36:57 robbat2 Exp $
+
+ 29 May 2008; Robin H. Johnson <robbat2@gentoo.org> mysql-5.0.26-r2.ebuild,
+ mysql-5.0.32.ebuild, mysql-5.0.34.ebuild, mysql-5.0.38.ebuild,
+ mysql-5.0.40.ebuild, mysql-5.0.42.ebuild, mysql-5.0.44.ebuild,
+ mysql-5.0.44-r1.ebuild, mysql-5.0.44-r2.ebuild, mysql-5.0.54.ebuild,
+ mysql-5.0.56.ebuild, mysql-5.0.60.ebuild:
+ Convert all all FEATURES=userpriv tests to be UID -eq 0 to make Paludis et
+ al happy.
*mysql-5.0.60 (29 May 2008)
diff --git a/dev-db/mysql/mysql-5.0.26-r2.ebuild b/dev-db/mysql/mysql-5.0.26-r2.ebuild
index a55e9bcdbd44..ab19d0b5540d 100644
--- a/dev-db/mysql/mysql-5.0.26-r2.ebuild
+++ b/dev-db/mysql/mysql-5.0.26-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.26-r2.ebuild,v 1.2 2007/01/12 17:58:32 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.26-r2.ebuild,v 1.3 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070105"
SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
@@ -22,7 +22,7 @@ src_test() {
# mysqladmin start before dir creation
mkdir -p "${S}"/mysql-test/var{,/log}
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.32.ebuild b/dev-db/mysql/mysql-5.0.32.ebuild
index daef7ffeb2f2..e02ae8af4956 100644
--- a/dev-db/mysql/mysql-5.0.32.ebuild
+++ b/dev-db/mysql/mysql-5.0.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.32.ebuild,v 1.3 2007/01/12 17:58:32 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.32.ebuild,v 1.4 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070108"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -22,7 +22,7 @@ src_test() {
# mysqladmin start before dir creation
mkdir -p "${S}"/mysql-test/var{,/log}
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.34.ebuild b/dev-db/mysql/mysql-5.0.34.ebuild
index 29ae784d4c1a..b5780e76b1a7 100644
--- a/dev-db/mysql/mysql-5.0.34.ebuild
+++ b/dev-db/mysql/mysql-5.0.34.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.34.ebuild,v 1.3 2007/03/06 16:11:48 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.34.ebuild,v 1.4 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070217"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -22,7 +22,7 @@ src_test() {
# mysqladmin start before dir creation
mkdir -p "${S}"/mysql-test/var{,/log}
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.38.ebuild b/dev-db/mysql/mysql-5.0.38.ebuild
index bac1f569f6c6..9fc96c148d93 100644
--- a/dev-db/mysql/mysql-5.0.38.ebuild
+++ b/dev-db/mysql/mysql-5.0.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.38.ebuild,v 1.12 2007/06/24 21:20:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.38.ebuild,v 1.13 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070415"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -26,7 +26,7 @@ src_test() {
# Ensure that parallel runs don't die
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.40.ebuild b/dev-db/mysql/mysql-5.0.40.ebuild
index f2ed48f48528..d5d184135549 100644
--- a/dev-db/mysql/mysql-5.0.40.ebuild
+++ b/dev-db/mysql/mysql-5.0.40.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.40.ebuild,v 1.9 2007/06/24 21:20:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.40.ebuild,v 1.10 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070415"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -29,7 +29,7 @@ src_test() {
# Ensure that parallel runs don't die
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.42.ebuild b/dev-db/mysql/mysql-5.0.42.ebuild
index 3fc099d0c400..a67895be44ee 100644
--- a/dev-db/mysql/mysql-5.0.42.ebuild
+++ b/dev-db/mysql/mysql-5.0.42.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.42.ebuild,v 1.9 2007/06/24 21:20:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.42.ebuild,v 1.10 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070415"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -29,7 +29,7 @@ src_test() {
# Ensure that parallel runs don't die
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
mysql_disable_test "im_daemon_life_cycle" "fails as root"
mysql_disable_test "im_life_cycle" "fails as root"
mysql_disable_test "im_options_set" "fails as root"
diff --git a/dev-db/mysql/mysql-5.0.44-r1.ebuild b/dev-db/mysql/mysql-5.0.44-r1.ebuild
index 5227d0a843bb..64233f6a9719 100644
--- a/dev-db/mysql/mysql-5.0.44-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.44-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r1.ebuild,v 1.7 2007/12/11 09:43:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r1.ebuild,v 1.8 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070710"
@@ -15,7 +15,7 @@ EPATCH_EXCLUDE=''
src_test() {
make check || die "make check failed"
if ! use "minimal" ; then
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
die "Testing with FEATURES=-userpriv is no longer supported by upstream"
fi
cd "${S}"
diff --git a/dev-db/mysql/mysql-5.0.44-r2.ebuild b/dev-db/mysql/mysql-5.0.44-r2.ebuild
index 56ceecd94b6d..7b83a856f2db 100644
--- a/dev-db/mysql/mysql-5.0.44-r2.ebuild
+++ b/dev-db/mysql/mysql-5.0.44-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r2.ebuild,v 1.9 2007/12/11 09:43:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r2.ebuild,v 1.10 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20071115"
@@ -15,7 +15,7 @@ EPATCH_EXCLUDE=''
src_test() {
make check || die "make check failed"
if ! use "minimal" ; then
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
die "Testing with FEATURES=-userpriv is no longer supported by upstream"
fi
cd "${S}"
diff --git a/dev-db/mysql/mysql-5.0.44.ebuild b/dev-db/mysql/mysql-5.0.44.ebuild
index 4a9b53692114..f97456e2af57 100644
--- a/dev-db/mysql/mysql-5.0.44.ebuild
+++ b/dev-db/mysql/mysql-5.0.44.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44.ebuild,v 1.5 2007/08/25 22:35:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44.ebuild,v 1.6 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20070710"
SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
@@ -29,7 +29,7 @@ src_test() {
# Ensure that parallel runs don't die
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
# As of 5.0.38, these work with the sandbox
# but they break if you are root
for t in \
diff --git a/dev-db/mysql/mysql-5.0.54.ebuild b/dev-db/mysql/mysql-5.0.54.ebuild
index de3a4c153b63..c7ae5c7d3877 100644
--- a/dev-db/mysql/mysql-5.0.54.ebuild
+++ b/dev-db/mysql/mysql-5.0.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.10 2008/01/28 07:06:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.11 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20080124"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -16,7 +16,7 @@ EPATCH_EXCLUDE=''
src_test() {
make check || die "make check failed"
if ! use "minimal" ; then
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
die "Testing with FEATURES=-userpriv is no longer supported by upstream"
fi
cd "${S}"
diff --git a/dev-db/mysql/mysql-5.0.56.ebuild b/dev-db/mysql/mysql-5.0.56.ebuild
index d7d30dac5525..a9617b051d5a 100644
--- a/dev-db/mysql/mysql-5.0.56.ebuild
+++ b/dev-db/mysql/mysql-5.0.56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.56.ebuild,v 1.2 2008/03/10 02:58:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.56.ebuild,v 1.3 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20080310"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -20,7 +20,7 @@ EPATCH_EXCLUDE=''
src_test() {
make check || die "make check failed"
if ! use "minimal" ; then
- if ! hasq "userpriv" ${FEATURES} ; then
+ if [[ $UID -eq 0 ]]; then
die "Testing with FEATURES=-userpriv is no longer supported by upstream"
fi
cd "${S}"
diff --git a/dev-db/mysql/mysql-5.0.60.ebuild b/dev-db/mysql/mysql-5.0.60.ebuild
index 6ba044e9f753..cec829f4d307 100644
--- a/dev-db/mysql/mysql-5.0.60.ebuild
+++ b/dev-db/mysql/mysql-5.0.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.60.ebuild,v 1.1 2008/05/29 05:51:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.60.ebuild,v 1.2 2008/05/29 19:36:57 robbat2 Exp $
MY_EXTRAS_VER="20080529"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -20,8 +20,8 @@ EPATCH_EXCLUDE=''
src_test() {
make check || die "make check failed"
if ! use "minimal" ; then
- if ! hasq "userpriv" ${FEATURES} ; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
fi
cd "${S}"
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"