summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-11-09 20:17:52 +0000
committerRichard Yao <ryao@gentoo.org>2012-11-09 20:17:52 +0000
commit794a3ecb9d0ab204674def31228303524b434888 (patch)
treecbfbeaca2d9826f43ead330bc483e1267a3b4c31
parentkeyword -x86-amd64 for now, its not supported (diff)
downloadgentoo-2-794a3ecb9d0ab204674def31228303524b434888.tar.gz
gentoo-2-794a3ecb9d0ab204674def31228303524b434888.tar.bz2
gentoo-2-794a3ecb9d0ab204674def31228303524b434888.zip
Patch usbhid-dump to include stdint.h to resolve build failure on Gentoo FreeBSD
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sys-apps/usbutils/ChangeLog6
-rw-r--r--sys-apps/usbutils/files/usbutils-006-stdint.patch36
-rw-r--r--sys-apps/usbutils/usbutils-006.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index aa8cd8339044..09d2476677db 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.148 2012/10/31 17:21:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.149 2012/11/09 20:17:52 ryao Exp $
+
+ 09 Nov 2012; Richard Yao <ryao@gentoo.org> +files/usbutils-006-stdint.patch,
+ usbutils-006.ebuild:
+ Patch usbhid-dump to proper include stdint.h to fix build failure on FreeBSD
31 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> usbutils-006.ebuild:
Use REPLACING_VERSIONS to silence pkg_postinst() message about removed
diff --git a/sys-apps/usbutils/files/usbutils-006-stdint.patch b/sys-apps/usbutils/files/usbutils-006-stdint.patch
new file mode 100644
index 000000000000..18d4e70344da
--- /dev/null
+++ b/sys-apps/usbutils/files/usbutils-006-stdint.patch
@@ -0,0 +1,36 @@
+diff --git a/usbhid-dump/lib/iface.c b/usbhid-dump/lib/iface.c
+index 7209188..a86c365 100644
+--- a/usbhid-dump/lib/iface.c
++++ b/usbhid-dump/lib/iface.c
+@@ -30,6 +30,7 @@
+ #include <assert.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <string.h>
+
+ bool
+diff --git a/usbhid-dump/lib/iface_list.c b/usbhid-dump/lib/iface_list.c
+index 1b028b1..d947475 100644
+--- a/usbhid-dump/lib/iface_list.c
++++ b/usbhid-dump/lib/iface_list.c
+@@ -30,6 +30,7 @@
+ #include <assert.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ bool
+ uhd_iface_list_valid(const uhd_iface *list)
+diff --git a/usbhid-dump/src/usbhid-dump.c b/usbhid-dump/src/usbhid-dump.c
+index 56a2956..892ea6e 100644
+--- a/usbhid-dump/src/usbhid-dump.c
++++ b/usbhid-dump/src/usbhid-dump.c
+@@ -40,6 +40,7 @@
+ #include <unistd.h>
+ #include <getopt.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ /* Define LIBUSB_CALL for libusb <= 1.0.8 */
+ #ifndef LIBUSB_CALL \ No newline at end of file
diff --git a/sys-apps/usbutils/usbutils-006.ebuild b/sys-apps/usbutils/usbutils-006.ebuild
index 808240285453..af8590400d79 100644
--- a/sys-apps/usbutils/usbutils-006.ebuild
+++ b/sys-apps/usbutils/usbutils-006.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006.ebuild,v 1.7 2012/10/31 17:21:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006.ebuild,v 1.8 2012/11/09 20:17:52 ryao Exp $
EAPI="4"
@@ -34,6 +34,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-libusbx-1.0.13.patch
+ epatch "${FILESDIR}"/${P}-stdint.patch
if use python; then
python_convert_shebangs 2 lsusb.py