summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-12-23 19:59:12 +0000
committerSven Vermeulen <swift@gentoo.org>2013-12-23 19:59:12 +0000
commit793767b701de30d608101b64f6c962549a9f6273 (patch)
treede996214d607ea20376322c5f56ae42f3384fdc4
parentForce latest autoconf-wrapper to keep people up-to-date. (diff)
downloadgentoo-2-793767b701de30d608101b64f6c962549a9f6273.tar.gz
gentoo-2-793767b701de30d608101b64f6c962549a9f6273.tar.bz2
gentoo-2-793767b701de30d608101b64f6c962549a9f6273.zip
Add 1.0.1, drop 0.9.4.1, update 9999; proxy-committed for Corentin Labbe
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
-rw-r--r--app-forensics/openscap/ChangeLog16
-rw-r--r--app-forensics/openscap/metadata.xml1
-rw-r--r--app-forensics/openscap/openscap-1.0.1.ebuild (renamed from app-forensics/openscap/openscap-0.9.4.1.ebuild)39
-rw-r--r--app-forensics/openscap/openscap-9999.ebuild15
4 files changed, 56 insertions, 15 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index 848fa1709a55..8c0bd10b7a5e 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.25 2013/09/26 08:19:06 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.26 2013/12/23 19:59:12 swift Exp $
+
+ 23 Dec 2013; Sven Vermeulen <swift@gentoo.org> -openscap-0.9.4.1.ebuild,
+ +openscap-1.0.1.ebuild, openscap-9999.ebuild, metadata.xml:
+ Add fixes of 1.0.1 in live ebuild
+
+ 23 Dec 2013; Sven Vermeulen <swift@gentoo.org> -openscap-0.9.4.1.ebuild,
+ +openscap-1.0.1.ebuild, metadata.xml:
+ Remove old ebuilds
+
+*openscap-1.0.1 (23 Dec 2013)
+
+ 23 Dec 2013; Sven Vermeulen <swift@gentoo.org> +openscap-1.0.1.ebuild,
+ metadata.xml:
+ Bump openscap to 1.0.1
*openscap-9999 (26 Sep 2013)
diff --git a/app-forensics/openscap/metadata.xml b/app-forensics/openscap/metadata.xml
index fb7ee2d0a1aa..6537c58a4650 100644
--- a/app-forensics/openscap/metadata.xml
+++ b/app-forensics/openscap/metadata.xml
@@ -8,6 +8,7 @@
<description>Maintainer</description>
</maintainer>
<use>
+<flag name="gconf">Build the gconf independant probes</flag>
<flag name="nss">Prefer NSS over libgcrypt as the crypto engine</flag>
<flag name="rpm">Compiles the RPM probes</flag>
<flag name="sce">Enables Script Check Engine (SCE) support</flag>
diff --git a/app-forensics/openscap/openscap-0.9.4.1.ebuild b/app-forensics/openscap/openscap-1.0.1.ebuild
index 3c9b82eefaba..7d5ef44c1a38 100644
--- a/app-forensics/openscap/openscap-0.9.4.1.ebuild
+++ b/app-forensics/openscap/openscap-1.0.1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.9.4.1.ebuild,v 1.1 2013/03/04 19:09:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-1.0.1.ebuild,v 1.1 2013/12/23 19:59:12 swift Exp $
-EAPI=3
+EAPI=5
PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit eutils multilib python bash-completion-r1
+inherit bash-completion-r1 eutils multilib python-r1
DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
HOMEPAGE="http://www.open-scap.org/"
@@ -15,19 +16,25 @@ SRC_URI="https://fedorahosted.org/releases/o/p/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion doc ldap nss perl python rpm selinux sql test"
+IUSE="acl bash-completion caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
#RESTRICT="test"
RDEPEND="!nss? ( dev-libs/libgcrypt )
nss? ( dev-libs/nss )
+ acl? ( virtual/acl )
+ caps? ( sys-libs/libcap )
+ gconf? ( gnome-base/gconf )
ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
rpm? ( >=app-arch/rpm-4.9 )
sql? ( dev-db/opendbx )
+ xattr? ( sys-apps/attr )
dev-libs/libpcre
dev-libs/libxml2
dev-libs/libxslt
net-misc/curl"
DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
perl? ( dev-lang/swig )
python? ( dev-lang/swig )
test? (
@@ -36,12 +43,11 @@ DEPEND="${RDEPEND}
net-misc/ipcalc
sys-apps/grep )"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_prepare() {
+# uncoment for debugging test
+# sed -i 's,set -e,&;set -x,' tests/API/XCCDF/unittests/test_remediate_simple.sh || die
+ sed -i 's,^ bash, LC_ALL=C bash,' tests/probes/process/test_probes_process.sh || die
+
sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
#probe runlevel for non-centos/redhat/fedora is not implemented
@@ -87,6 +93,9 @@ src_prepare() {
src_configure() {
local myconf
+ if use debug ; then
+ myconf+=" --enable-debug"
+ fi
if use python ; then
myconf+=" --enable-python"
else
@@ -100,9 +109,21 @@ src_configure() {
else
myconf+=" --with-crypto=gcrypt"
fi
+ if use sce ; then
+ myconf+=" --enable-sce"
+ else
+ myconf+=" --enable-sce=no"
+ fi
econf ${myconf}
}
+src_compile() {
+ emake
+ if use doc ; then
+ cd docs && doxygen Doxyfile || die
+ fi
+}
+
src_install() {
emake install DESTDIR="${D}" || die
find "${D}" -name '*.la' -delete || die
diff --git a/app-forensics/openscap/openscap-9999.ebuild b/app-forensics/openscap/openscap-9999.ebuild
index 0926190e719f..72c3b1cd7f3f 100644
--- a/app-forensics/openscap/openscap-9999.ebuild
+++ b/app-forensics/openscap/openscap-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-9999.ebuild,v 1.1 2013/09/26 08:19:06 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-9999.ebuild,v 1.2 2013/12/23 19:59:12 swift Exp $
EAPI=5
@@ -25,14 +25,19 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="bash-completion debug doc ldap nss perl python rpm selinux sce sql test"
-RESTRICT="test"
+IUSE="acl bash-completion caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
+#RESTRICT="test"
RDEPEND="!nss? ( dev-libs/libgcrypt )
nss? ( dev-libs/nss )
+ acl? ( virtual/acl )
+ caps? ( sys-libs/libcap )
+ gconf? ( gnome-base/gconf )
ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
rpm? ( >=app-arch/rpm-4.9 )
sql? ( dev-db/opendbx )
+ xattr? ( sys-apps/attr )
dev-libs/libpcre
dev-libs/libxml2
dev-libs/libxslt
@@ -135,9 +140,9 @@ src_configure() {
src_compile() {
emake
- if [[ "${PV}" == "9999" ]] && use doc ; then
+ if use doc ; then
einfo "Building HTML documentation using Doxygen (which will take a while)"
- cd docs && doxygen Doxyfile
+ cd docs && doxygen Doxyfile || die
fi
}