summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-08 23:05:19 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-08 23:05:19 +0000
commit78e1a4f70943b071a2018388f9c38ef767e62c9b (patch)
tree67b29775bd83644735b3d615d7e4f63693802e4b
parentVersion bump. (diff)
downloadgentoo-2-78e1a4f70943b071a2018388f9c38ef767e62c9b.tar.gz
gentoo-2-78e1a4f70943b071a2018388f9c38ef767e62c9b.tar.bz2
gentoo-2-78e1a4f70943b071a2018388f9c38ef767e62c9b.zip
initial import as per bug #51938.
-rw-r--r--dev-libs/botan/ChangeLog11
-rw-r--r--dev-libs/botan/Manifest2
-rw-r--r--dev-libs/botan/botan-1.4.3.ebuild71
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.31
-rw-r--r--dev-libs/botan/metadata.xml15
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
new file mode 100644
index 000000000000..59b3d918fc91
--- /dev/null
+++ b/dev-libs/botan/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-libs/botan
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.1 2004/11/08 23:05:19 dragonheart Exp $
+
+*botan-1.4.3 (09 Nov 2004)
+
+ 09 Nov 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +botan-1.4.3.ebuild:
+ initial import as per bug #51938. Thanks to the author (Jack Lloyd
+ <lloyd@randombit.net>) for the program and ebuild
+
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
new file mode 100644
index 000000000000..396824367f88
--- /dev/null
+++ b/dev-libs/botan/Manifest
@@ -0,0 +1,2 @@
+MD5 ff83b467db28cfd847d8d47c23e2470c botan-1.4.3.ebuild 2117
+MD5 c9748b2c6a670b1f0b8cbcb3ca74b8bb files/digest-botan-1.4.3 61
diff --git a/dev-libs/botan/botan-1.4.3.ebuild b/dev-libs/botan/botan-1.4.3.ebuild
new file mode 100644
index 000000000000..df6b344837ad
--- /dev/null
+++ b/dev-libs/botan/botan-1.4.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.3.ebuild,v 1.1 2004/11/08 23:05:19 dragonheart Exp $
+
+# Comments/fixes to lloyd@randombit.net (author)
+
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/Botan-${PV}.tgz"
+
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzlib zlib gmp ssl debug"
+
+S="${WORKDIR}/Botan-${PV}"
+
+# FIXME: libstdc++ here?
+RDEPEND="virtual/libc
+ bzlib? ( >=app-arch/bzip2-1.0.1 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ gmp? ( >=dev-libs/gmp-4.1.2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )"
+
+# configure.pl requires DirHandle, Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,mux_pthr"
+
+ if useq bzlib; then modules="$modules,comp_bzip2"; fi
+ if use zlib; then modules="$modules,comp_zlib"; fi
+ if use gmp; then modules="$modules,eng_gmp"; fi
+ if use ssl; then modules="$modules,eng_ossl"; fi
+
+
+ # This is also supported on i586+ and sparcv9 - how to test for them? CCHOST?
+ if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
+
+ # Also works on mips64 and sparc64
+ if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' -o \
+ ${ARCH} = 'ia64' -o ${ARCH} = 'ppc64' ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Are there any CHOSTs in use which break this?
+ CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+
+ cd ${S}
+ einfo "Enabling modules: " $(echo $modules | sed 's/,/ /g')
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl --noauto gcc-linux-$CHOSTARCH --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH=${S} ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
+}
diff --git a/dev-libs/botan/files/digest-botan-1.4.3 b/dev-libs/botan/files/digest-botan-1.4.3
new file mode 100644
index 000000000000..abc3ca1773ff
--- /dev/null
+++ b/dev-libs/botan/files/digest-botan-1.4.3
@@ -0,0 +1 @@
+MD5 4a17826468e55156c8a32adeba23d7fa Botan-1.4.3.tgz 1435821
diff --git a/dev-libs/botan/metadata.xml b/dev-libs/botan/metadata.xml
new file mode 100644
index 000000000000..e5a6aeb8d6cf
--- /dev/null
+++ b/dev-libs/botan/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>Gentoo Commiter</description>
+</maintainer>
+<maintainer>
+ <email>lloyd@randombit.net</email>
+ <name>Jack Lloyd </name>
+ <description>Ebuild contributor and botan author</description>
+</maintainer>
+</pkgmetadata>