summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-03-21 13:52:56 +0000
committerMichael Januszewski <spock@gentoo.org>2010-03-21 13:52:56 +0000
commit78cab3ccb604a815fe8834fa84b3c45b9167e4d7 (patch)
tree15ad95e43e6365e1942cc329cc7daf953cf99f2c
parentVersion bump. (diff)
downloadgentoo-2-78cab3ccb604a815fe8834fa84b3c45b9167e4d7.tar.gz
gentoo-2-78cab3ccb604a815fe8834fa84b3c45b9167e4d7.tar.bz2
gentoo-2-78cab3ccb604a815fe8834fa84b3c45b9167e4d7.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-util/nvidia-cuda-sdk/ChangeLog8
-rw-r--r--dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-3.0.ebuild97
2 files changed, 104 insertions, 1 deletions
diff --git a/dev-util/nvidia-cuda-sdk/ChangeLog b/dev-util/nvidia-cuda-sdk/ChangeLog
index f1796701f555..5df45bb89187 100644
--- a/dev-util/nvidia-cuda-sdk/ChangeLog
+++ b/dev-util/nvidia-cuda-sdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/nvidia-cuda-sdk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-sdk/ChangeLog,v 1.18 2010/02/08 12:10:19 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-sdk/ChangeLog,v 1.19 2010/03/21 13:52:56 spock Exp $
+
+*nvidia-cuda-sdk-3.0 (21 Mar 2010)
+
+ 21 Mar 2010; Michał Januszewski <spock@gentoo.org>
+ +nvidia-cuda-sdk-3.0.ebuild:
+ Version bump.
*nvidia-cuda-sdk-3.0_beta1 (08 Feb 2010)
diff --git a/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-3.0.ebuild b/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-3.0.ebuild
new file mode 100644
index 000000000000..389a4e8f64ac
--- /dev/null
+++ b/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-3.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-3.0.ebuild,v 1.1 2010/03/21 13:52:56 spock Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="NVIDIA CUDA Software Development Kit"
+HOMEPAGE="http://developer.nvidia.com/cuda"
+
+CUDA_V=${PV//_/-}
+DIR_V=${CUDA_V//./_}
+DIR_V=${DIR_V//beta/Beta}
+
+SRC_URI="http://developer.download.nvidia.com/compute/cuda/${DIR_V}/sdk/gpucomputingsdk_${CUDA_V}_linux.run"
+LICENSE="CUDPP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +doc emulation +examples opencl +cuda"
+
+RDEPEND=">=dev-util/nvidia-cuda-toolkit-3.0_beta1
+ examples? ( !emulation? ( >=x11-drivers/nvidia-drivers-195.30 ) )
+ virtual/glut"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+RESTRICT="binchecks"
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" -a $(gcc-minor-version) -ge 4 ]; then
+ eerror "This package requires <=sys-devel/gcc-4.3 to build sucessfully."
+ eerror "Please use gcc-config to switch to a compatible GCC version."
+ die "<=sys-devel/gcc-4.3 required"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_compile() {
+ if ! use examples; then
+ return
+ fi
+ local myopts=""
+
+ if use emulation; then
+ myopts="emu=1"
+ fi
+
+ if use debug; then
+ myopts="${myopts} dbg=1"
+ fi
+
+ cd "${S}/sdk"
+
+ if use cuda; then
+ cd C
+ emake cuda-install=/opt/cuda ${myopts} || die
+ cd ..
+ fi
+
+ if use opencl; then
+ cd OpenCL
+ emake || die
+ cd ..
+ fi
+}
+
+src_install() {
+ cd "${S}/sdk"
+
+ if ! use doc; then
+ rm -rf doc ReleaseNotes.htm releaseNotesData
+ fi
+
+ if ! use examples; then
+ rm -rf bin tools
+ fi
+
+ for f in $(find .); do
+ local t="$(dirname ${f})"
+ if [[ "${t/obj\/}" != "${t}" || "${t##*.}" == "a" ]]; then
+ continue
+ fi
+
+ if [[ -x "${f}" && ! -d "${f}" ]]; then
+ exeinto "/opt/cuda/sdk/${t}"
+ doexe "${f}"
+ else
+ insinto "/opt/cuda/sdk/${t}"
+ doins "${f}"
+ fi
+ done
+}