summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-03-18 14:46:04 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-03-18 14:46:04 +0000
commit780a654d64b199a93fe121a0700c265b2107ed95 (patch)
treeee274e1ecd037ae3041b4b843b7c64a75f6d92d4
parentrev bump. UPnP fixes. StorageGroups DB upgrade fix. Text alignment in Recordi... (diff)
downloadgentoo-2-780a654d64b199a93fe121a0700c265b2107ed95.tar.gz
gentoo-2-780a654d64b199a93fe121a0700c265b2107ed95.tar.bz2
gentoo-2-780a654d64b199a93fe121a0700c265b2107ed95.zip
Add aac support via faad2
(Portage version: 2.1.4.4)
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.21_p16658.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 8c40c29ed32b..9beae92ddbaf 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.225 2008/03/18 14:04:48 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.226 2008/03/18 14:46:04 cardoe Exp $
+
+ 18 Mar 2008; Doug Goldstein <cardoe@gentoo.org> mythtv-0.21_p16658.ebuild:
+ Add aac support via faad2
*mythtv-0.21_p16658 (18 Mar 2008)
diff --git a/media-tv/mythtv/mythtv-0.21_p16658.ebuild b/media-tv/mythtv/mythtv-0.21_p16658.ebuild
index ae7eee5147ad..0d16103af1fb 100644
--- a/media-tv/mythtv/mythtv-0.21_p16658.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p16658.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p16658.ebuild,v 1.1 2008/03/18 14:04:48 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p16658.ebuild,v 1.2 2008/03/18 14:46:04 cardoe Exp $
EAPI=1
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python
@@ -10,7 +10,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_via"
-IUSE="alsa altivec autostart dbox2 debug directv dvb dvd hdhomerun ieee1394 iptv \
+IUSE="aac alsa altivec autostart dbox2 debug directv dvb dvd hdhomerun ieee1394 iptv \
ivtv jack joystick lcd lirc mmx opengl opengl-video opengl-xvmc perl python \
vorbis xvmc ${IUSE_VIDEO_CARDS}"
@@ -27,6 +27,7 @@ RDEPEND=">=media-libs/freetype-2.0
virtual/opengl
virtual/glu
|| ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.43 )
+ aac? ( media-libs/faad2 )
alsa? ( >=media-libs/alsa-lib-0.9 )
autostart? ( net-dialup/mingetty
x11-wm/evilwm
@@ -112,6 +113,7 @@ src_compile() {
local myconf="--prefix=/usr
--mandir=/usr/share/man
--libdir-name=$(get_libdir)"
+ use aac && myconf="${myconf} --enable-libfaad"
use alsa || myconf="${myconf} --disable-audio-alsa"
use altivec || myconf="${myconf} --disable-altivec"
use dbox2 || myconf="${myconf} --disable-dbox2"