summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-25 15:15:10 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-25 15:15:10 +0000
commit778f8c459cd8b7330918e8a9b08c729dc806ad82 (patch)
tree3cb066dd7e2fb3ae78dab4f8f443fcebbfeaf587
parentVersion bump. Always disable the test that depends on gzip having the --rsync... (diff)
downloadgentoo-2-778f8c459cd8b7330918e8a9b08c729dc806ad82.tar.gz
gentoo-2-778f8c459cd8b7330918e8a9b08c729dc806ad82.tar.bz2
gentoo-2-778f8c459cd8b7330918e8a9b08c729dc806ad82.zip
dev-python/feedparser: Bump to snapshot of revision 316 (current trunk)
(Portage version: 2.1.9.24/cvs/Linux x86_64)
-rw-r--r--dev-python/feedparser/ChangeLog10
-rw-r--r--dev-python/feedparser/feedparser-4.2_pre316.ebuild35
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index c4763c1d6caa..29b57d01b564 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/feedparser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.20 2010/08/14 17:38:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.21 2010/11/25 15:15:10 sping Exp $
+
+*feedparser-4.2_pre316 (25 Nov 2010)
+
+ 25 Nov 2010; Sebastian Pipping <sping@gentoo.org>
+ +feedparser-4.2_pre316.ebuild:
+ Bump to snapshot of revision 316 (current trunk) to fix email subjects of
+ rss2email. Except feedparser.py, all files in the snapshot are taken from the
+ 4.1 release. Fix license from Python to BSD-2.
14 Aug 2010; Raúl Porcel <armin76@gentoo.org> feedparser-4.1.ebuild:
sparc stable
diff --git a/dev-python/feedparser/feedparser-4.2_pre316.ebuild b/dev-python/feedparser/feedparser-4.2_pre316.ebuild
new file mode 100644
index 000000000000..7578f851e314
--- /dev/null
+++ b/dev-python/feedparser/feedparser-4.2_pre316.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-4.2_pre316.ebuild,v 1.1 2010/11/25 15:15:10 sping Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Parse RSS and Atom feeds in Python"
+HOMEPAGE="http://www.feedparser.org/"
+SRC_URI="http://www.hartwork.org/public/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+PYTHON_MODNAME="feedparser.py"
+DOCS="LICENSE"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r docs || die
+}