summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:43:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 22:43:30 +0000
commit76e79bb7738a1c74f8eace0e4167f9c22edbfd1c (patch)
treecc7deedb3f681cca9642290ba7ffa9515aea2652
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-76e79bb7738a1c74f8eace0e4167f9c22edbfd1c.tar.gz
gentoo-2-76e79bb7738a1c74f8eace0e4167f9c22edbfd1c.tar.bz2
gentoo-2-76e79bb7738a1c74f8eace0e4167f9c22edbfd1c.zip
Delete older ebuilds.
-rw-r--r--dev-python/flask/flask-0.4.ebuild63
-rw-r--r--dev-python/flask/flask-0.5.1.ebuild60
2 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/flask/flask-0.4.ebuild b/dev-python/flask/flask-0.4.ebuild
deleted file mode 100644
index 1c6727729523..000000000000
--- a/dev-python/flask/flask-0.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.4.ebuild,v 1.1 2010/06/18 18:55:19 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="http://pypi.python.org/pypi/Flask"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/jinja-2.4
- dev-python/setuptools
- >=dev-python/werkzeug-0.6.1"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flask.py"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH=. "$(PYTHON)" tests/flask_tests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-# python_clean_installation_image
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/flask/flask-0.5.1.ebuild b/dev-python/flask/flask-0.5.1.ebuild
deleted file mode 100644
index 71522c083a41..000000000000
--- a/dev-python/flask/flask-0.5.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.5.1.ebuild,v 1.1 2010/07/06 23:35:52 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="http://pypi.python.org/pypi/Flask"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/jinja-2.4
- dev-python/setuptools
- >=dev-python/werkzeug-0.6.1"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="." "$(PYTHON)" tests/flask_tests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Installation of examples failed"
- fi
-}