summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-04-24 01:40:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-04-24 01:40:03 +0000
commit7654d414399da62fe440dcccee14304f48244c93 (patch)
treec18cc60b6b2cb78f889700d5ce9570a50310ebbb
parentRemoved old (diff)
downloadgentoo-2-7654d414399da62fe440dcccee14304f48244c93.tar.gz
gentoo-2-7654d414399da62fe440dcccee14304f48244c93.tar.bz2
gentoo-2-7654d414399da62fe440dcccee14304f48244c93.zip
Revert rack-1.0.1-r1 and revision bump for www-apps/redmine, bug #353286.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rack/ChangeLog8
-rw-r--r--dev-ruby/rack/rack-1.0.1-r2.ebuild54
-rw-r--r--dev-ruby/rack/rack-1.2.1.ebuild4
-rw-r--r--dev-ruby/rack/rack-1.2.2.ebuild4
4 files changed, 65 insertions, 5 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index ce0fe2855f55..5eae4343c27b 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.42 2011/03/14 19:25:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.43 2011/04/24 01:40:03 matsuu Exp $
+
+*rack-1.0.1-r2 (24 Apr 2011)
+
+ 24 Apr 2011; MATSUU Takuto <matsuu@gentoo.org> +rack-1.0.1-r2.ebuild,
+ rack-1.2.1.ebuild, rack-1.2.2.ebuild:
+ Revert rack-1.0.1-r1 and revision bump for www-apps/redmine, bug #353286.
*rack-1.1.2 (14 Mar 2011)
diff --git a/dev-ruby/rack/rack-1.0.1-r2.ebuild b/dev-ruby/rack/rack-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..62bc5482f918
--- /dev/null
+++ b/dev-ruby/rack/rack-1.0.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.0.1-r2.ebuild,v 1.1 2011/04/24 01:40:03 matsuu Exp $
+
+EAPI="3"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend test dev-ruby/test-spec
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
+
+#USE_RUBY=ruby19 \
+# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Auth::OpenID)' \
+ || die "test failed for ${RUBY}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if [ "${SLOT}" != "0" ] ; then
+ for f in "${ED}"/usr/bin/* ; do
+ mv "${f}" "${f}-${SLOT}" || die "failed to mv ${f} to ${f}-${SLOT}."
+ done
+ fi
+}
diff --git a/dev-ruby/rack/rack-1.2.1.ebuild b/dev-ruby/rack/rack-1.2.1.ebuild
index fd07fc14eeef..99b76f0f397d 100644
--- a/dev-ruby/rack/rack-1.2.1.ebuild
+++ b/dev-ruby/rack/rack-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.1.ebuild,v 1.6 2011/01/10 18:18:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.1.ebuild,v 1.7 2011/04/24 01:40:03 matsuu Exp $
EAPI="2"
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -25,7 +25,7 @@ IUSE=""
ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1"
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
#USE_RUBY=ruby19 \
# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
diff --git a/dev-ruby/rack/rack-1.2.2.ebuild b/dev-ruby/rack/rack-1.2.2.ebuild
index 7695dc7a3c1b..42a62fd3f782 100644
--- a/dev-ruby/rack/rack-1.2.2.ebuild
+++ b/dev-ruby/rack/rack-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.2.ebuild,v 1.1 2011/03/14 19:23:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.2.ebuild,v 1.2 2011/04/24 01:40:03 matsuu Exp $
EAPI="2"
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -26,7 +26,7 @@ IUSE=""
ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1"
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
#USE_RUBY=ruby19 \
# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'