summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-09 11:28:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-09 11:28:33 +0000
commit756ab22a11fb488ae5588fd2e168b6e22208fc84 (patch)
tree24a9cffdb70232f4af8712f60c927359d45646b6
parentStable for ppc, wrt bug #460564 (diff)
downloadgentoo-2-756ab22a11fb488ae5588fd2e168b6e22208fc84.tar.gz
gentoo-2-756ab22a11fb488ae5588fd2e168b6e22208fc84.tar.bz2
gentoo-2-756ab22a11fb488ae5588fd2e168b6e22208fc84.zip
Do not make linker warnings fatal, fixes bug 430968
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 7887F787)
-rw-r--r--dev-libs/grantlee/ChangeLog6
-rw-r--r--dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch14
-rw-r--r--dev-libs/grantlee/grantlee-0.3.0.ebuild7
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-libs/grantlee/ChangeLog b/dev-libs/grantlee/ChangeLog
index c7138489dde4..d2e7ad140a64 100644
--- a/dev-libs/grantlee/ChangeLog
+++ b/dev-libs/grantlee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/grantlee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.20 2013/03/02 19:59:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.21 2013/03/09 11:28:33 dilfridge Exp $
+
+ 09 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org> grantlee-0.3.0.ebuild,
+ +files/grantlee-0.3.0-nonfatal-warnings.patch:
+ Do not make linker warnings fatal, fixes bug 430968
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> grantlee-0.1.9.ebuild,
grantlee-0.2.0.ebuild, grantlee-0.3.0.ebuild:
diff --git a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
new file mode 100644
index 000000000000..a25f52b3c63d
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
@@ -0,0 +1,14 @@
+diff -ruN grantlee-0.3.0.orig/CMakeLists.txt grantlee-0.3.0/CMakeLists.txt
+--- grantlee-0.3.0.orig/CMakeLists.txt 2012-11-01 21:14:18.000000000 +0100
++++ grantlee-0.3.0/CMakeLists.txt 2013-03-09 12:25:56.498096399 +0100
+@@ -62,8 +62,8 @@
+ endif()
+
+ if (NOT APPLE)
+- set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
+- set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
++ set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
++ set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
+ endif ()
+
+ if (NOT MINGW)
diff --git a/dev-libs/grantlee/grantlee-0.3.0.ebuild b/dev-libs/grantlee/grantlee-0.3.0.ebuild
index 2b398ccd2ff3..bd9155da8f44 100644
--- a/dev-libs/grantlee/grantlee-0.3.0.ebuild
+++ b/dev-libs/grantlee/grantlee-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.3.0.ebuild,v 1.2 2013/03/02 19:59:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.3.0.ebuild,v 1.3 2013/03/09 11:28:32 dilfridge Exp $
EAPI=4
@@ -32,7 +32,10 @@ DOCS=(AUTHORS CHANGELOG GOALS README)
# Some tests fail
RESTRICT="test"
-PATCHES=( "${FILESDIR}/${PN}-0.1.9-qt-test-optional.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.9-qt-test-optional.patch"
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+)
src_configure() {
mycmakeargs=(