summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-05 16:08:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-05 16:08:00 +0000
commit754d7d7d3799dbd92ba97f21927aadb143c954a3 (patch)
treee346f754b25db6a4c6209deb5901864025af2159
parentBump version of extensions patch to 56. Add dxr3 hack for subtitles, Bug #215... (diff)
downloadgentoo-2-754d7d7d3799dbd92ba97f21927aadb143c954a3.tar.gz
gentoo-2-754d7d7d3799dbd92ba97f21927aadb143c954a3.tar.bz2
gentoo-2-754d7d7d3799dbd92ba97f21927aadb143c954a3.zip
make python bindings optional, fix bug #212830
(Portage version: 2.1.4.4)
-rw-r--r--app-admin/gamin/ChangeLog10
-rw-r--r--app-admin/gamin/gamin-0.1.9-r1.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index 3a42288c30e5..d82fecc384ad 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/gamin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.80 2007/11/06 21:51:35 leio Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.81 2008/04/05 16:08:00 eva Exp $
+
+*gamin-0.1.9-r1 (05 Apr 2008)
+
+ 05 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gamin-0.1.9-r1.ebuild:
+ make python bindings optional, fix bug #212830
06 Nov 2007; Mart Raudsepp <leio@gentoo.org> -gamin-0.1.7.ebuild,
-gamin-0.1.8.ebuild:
diff --git a/app-admin/gamin/gamin-0.1.9-r1.ebuild b/app-admin/gamin/gamin-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..63c61369848b
--- /dev/null
+++ b/app-admin/gamin/gamin-0.1.9-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.9-r1.ebuild,v 1.1 2008/04/05 16:08:00 eva Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/${PN}/sources/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug kernel_linux python"
+
+RDEPEND=">=dev-libs/glib-2
+ python? ( virtual/python )
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix compile warnings; bug #188923
+ epatch "${FILESDIR}"/${P}-compile-warnings.patch
+ epatch "${FILESDIR}/${P}-user-cflags.patch"
+ epatch "${FILESDIR}/${P}-freebsd.patch"
+
+ # autoconf is required as the user-cflags patch modifies configure.in
+ # however, elibtoolize is also required, so when the above patch is
+ # removed, replace the following call with a call to elibtoolize
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-debug \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug debug-api) \
+ $(use_with python) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ dohtml doc/*
+}