summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-19 17:57:16 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-19 17:57:16 +0000
commit74f4be78e2e65b0e465312c9acb5372b470f085c (patch)
tree9c5099cbc55403b1bdf6bf2e600dc3210c3a7d90
parentFix build when USE=-dbus. (diff)
downloadgentoo-2-74f4be78e2e65b0e465312c9acb5372b470f085c.tar.gz
gentoo-2-74f4be78e2e65b0e465312c9acb5372b470f085c.tar.bz2
gentoo-2-74f4be78e2e65b0e465312c9acb5372b470f085c.zip
Version
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-2.3.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index 0be1620dd8d4..d87b482c9eec 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.31 2011/09/15 04:48:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.32 2011/10/19 17:57:16 graaff Exp $
+
+*ruby_parser-2.3.1 (19 Oct 2011)
+
+ 19 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby_parser-2.3.1.ebuild:
+ Version bump.
15 Sep 2011; Jeroen Roovers <jer@gentoo.org> ruby_parser-2.0.5.ebuild:
Stable for HPPA (bug #369573).
diff --git a/dev-ruby/ruby_parser/ruby_parser-2.3.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-2.3.1.ebuild
new file mode 100644
index 000000000000..242248f1a03d
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-2.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-2.3.1.ebuild,v 1.1 2011/10/19 17:57:16 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby."
+HOMEPAGE="http://parsetree.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp-processor-3.0.1"
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/sexp-processor-3.0.6 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ sed -i -e '/perforce/d' Rakefile || die
+}