summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-01-06 05:35:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-01-06 05:35:43 +0000
commit738d2bba21b0625831b716f783ac3716a6204fce (patch)
treee6ae14a3e2ecab563a274a69122e85a7a6414435
parentstable on ppc64 (diff)
downloadgentoo-2-738d2bba21b0625831b716f783ac3716a6204fce.tar.gz
gentoo-2-738d2bba21b0625831b716f783ac3716a6204fce.tar.bz2
gentoo-2-738d2bba21b0625831b716f783ac3716a6204fce.zip
Version bumped.
(Portage version: 2.1.1-r2)
-rw-r--r--dev-lang/tcl/ChangeLog10
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.143
-rw-r--r--dev-lang/tcl/tcl-8.4.14.ebuild113
3 files changed, 124 insertions, 2 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 7c1c81783129..a411a1c2768b 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tcl
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.71 2006/12/26 04:54:47 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.72 2007/01/06 05:35:43 matsuu Exp $
+
+*tcl-8.4.14 (06 Jan 2007)
+
+ 06 Jan 2007; MATSUU Takuto <matsuu@gentoo.org> -tcl-8.3.4.ebuild,
+ +tcl-8.4.14.ebuild:
+ Version bumped.
26 Dec 2006; Mike Frysinger <vapier@gentoo.org> tcl-8.4.13.ebuild:
Clean up src_install() to use proper ebuild commands rather than running
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.14 b/dev-lang/tcl/files/digest-tcl-8.4.14
new file mode 100644
index 000000000000..dbdb813bb271
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.14
@@ -0,0 +1,3 @@
+MD5 51c6bf74d3ffdb0bd866ecdac6ff6460 tcl8.4.14-src.tar.gz 3544609
+RMD160 392a4f4617ee77cfdae10b24e9ccbe84afed0a40 tcl8.4.14-src.tar.gz 3544609
+SHA256 2746e3c568a5837cfb7a83359ab34401886ad621965ab4571333859807ab6143 tcl8.4.14-src.tar.gz 3544609
diff --git a/dev-lang/tcl/tcl-8.4.14.ebuild b/dev-lang/tcl/tcl-8.4.14.ebuild
new file mode 100644
index 000000000000..5dd3c44c9f07
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.14.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.14.ebuild,v 1.1 2007/01/06 05:35:43 matsuu Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Tool Command Language"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug threads"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.3.5-tclm4-soname.patch
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tcl-configure-LANG.patch
+ done
+}
+
+src_compile() {
+ tc-export CC
+ local local_config_use=""
+
+ if use threads ; then
+ local_config_use="--enable-threads"
+ fi
+
+ cd "${S}"/unix
+ econf \
+ $(use_enable threads) \
+ $(use_enable debug symbols) || die
+ emake || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ S= make DESTDIR="${D}" install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ [[ ${ROOT:0-1} != "/" ]] && ROOT=${ROOT}/
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}usr/${mylibdir}," \
+ -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${ROOT}usr/${mylibdir}/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${ROOT}usr/${mylibdir}," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${ROOT}usr/${mylibdir}," \
+ -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
+ -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
+ -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
+ "${D}"/usr/${mylibdir}/tclConfig.sh || die
+
+ # install private headers
+ insinto /usr/${mylibdir}/tcl${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tcl${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
+ rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
+
+ ln -sf tclsh${v1} "${D}"/usr/bin/tclsh
+
+ cd "${S}"
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild"
+ ewarn "in package app-portage/gentoolkit."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+}